• WiFi works after 3 reboots !!??


    Hi, not sure since when but maybe it all started 3 or 4 days ago, the WiFi icon shows empty, without connection, as if the WiFi adaptor was OFF. I usually install updates as they show in my system. My computer is somewhat old, a Toshiba Satellite Pro S300L and it has a switch for the WiFi but it is and it was always ON. Just rebooting the computer, after the 3rd one, fixes this problem.

    Please any comment will be appreciated… I have attached some log files 0_1462148312091_logs.tar

    Thank you in advance.


    Fer

  • Could it be related to an inminent Wireless HW failure? Today, I had to reboot the laptop 6 times :-)

    Any comment will be appreciated…


    Fer

  • Hi,

    It would be easier if you put the logs when it does not work, and then put them when it works, so we can tell the difference (just put the last boot log with journalctl -xb

    Thanks.

  • I have exactly the same problem. Since ~3 days on my Thinkpad T460p, using linux-mainline . Also have to reboot for a few times…

    journalctl -xb output while Wifi NOT working: 0_1462307558137_journalctl.zip

  • Just to add my 2 cents here, it seems to be a general problem, as I have also been experiencing this same WiFi problem since this weekend with my 2013 Dell Precision M3800. Haven’t counted the number of reboots needed in general, but it is definitely working correctly less than 33 percent of the time.

  • I’m having the same problem on a Thinkpad T410. The boot drive is SSD. The odd thing is that I had the idea of installing Plymouth and the problem disappeared. When I uninstalled Plymouth, the problem returned–no WiFi connection. I’d be interested to see if Plymouth makes a difference for any one else; perhaps it slows down the boot-time enough for the WiFI to be recognized. I used the legacy version of Plymouth.

  • Today I had to reboot my old trusty Toshiba around 6 times… before it could connect to the WiFi. I’m thinking of trying another distro or definitely buy another notebook :-)

    I’m attaching the journalctl -xb when my WiFi is working, next time I will upload when WiFi is not connected.

    [0_1462358889549_journalctl_xb.log_wifi_working.tar.gz](Uploading 100%)

    Thank you!


    Fer

  • i have the same problem, its like my wifi card didnt exist. i got connect using wifi-menu, but now i cant do it.

  • It looks like being quite an issue for many. I could only suggest 3 solutions. 2 lazy ones and one neeging digging up:

    1. Try the lts kernel to see if it gets fixed
    2. Wait for a fix
    3. The Arch Wiki
      https://wiki.archlinux.org/index.php/Wireless_network_configuration

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Thank you, so it could be related to a kernel update? was a new kernel released by Antergos / Arch during last week? Thank you!!


    Fer

  • Antergos gets updated when Arch does. When an update appears in the Arch repos, it is also available in Antergos, since Antergos uses the Arch repos. It doesn t modify or delay anything. The lts kernel I mentioned above, is considered to be more stable than the stock one, because of its lts (Long Term Support) nature. You can install it by
    sudo pacman -S linux-lts
    regenerating your grub with
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    and then
    reboot

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Since yesterday my Toshiba’s WiFi doesn’t connect anymore. 5, 10 or 20 reboots, all the same, my Samsung NC10 with all the updates, works flawlessly… I’m uploading journalctl -xb when there is no WiFi connection.
    I will try to install the LTS kernel…
    [0_1462573156733_journalctl_xb_no_wifi.log.tar.gz](Uploading 100%) [0_1462573199992_journalctl_xb_no_wifi.log.tar.gz](Uploading 100%) 0_1462573262061_journalctl_xb_no_wifi.log.zip


    Fer

  • @anarch Thank you! Going back to the LTS has got WiFi back to work :+1:

    i was wondering whether I’ll receive or be notified when a new kernel appears??

    Thank you again!


    Fer

  • @ferthelet said i

    i was wondering whether I’ll receive or be notified when a new kernel appears??

    Definately! You will get updates for both kernels, whenever there are any available. The only thing that will change is that in your grub you will see 2 options to choose. Just pick the lts kernel to enter.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Hi there and many thanks for your quick reply! Unfortunately, today I had exactly the same issue, no WiFi and after many reboots, at least 15, it got connected.
    Of course I made myself very sure I’m running LTS 4.4.9.
    Also I’m attaching to this message the journalctl -xb log for both situations.
    Any other comment will be very much appreciated.

    0_1462619332919_TOSHIBA_S300L_journalctl_xb_wifi_lts_issues.log.zip


    Fer

  • Sorry to hear. Maybe you should try this suddestion here?
    https://forum.antergos.com/topic/4400/wireless-card-doesn-t-always-work-on-boot/10

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Many thanks !! There are two suggestions there, to downgrade networkmanager or to replace it with WICD… what would you do first? Thank you again!


    Fer

  • Definitely, it seems there is no way to get my Toshiba’s Satellite S300L WiFi back to work again. I swear it was working great for the past two or three years using Antergos+OB.
    As I have tried Manjaro in this notebook again and my WiFi it worked fine so far, I guess I will install it for good.
    Yesterday I tried the latest released kernel in Antergos and, to my surprise, it worked fine, but today I had the same old problems, after more than 10 reboots, trying the latest or the LTS kernel, I could successfully get my WiFi connect to my network.
    Should the journal -xb may help to find any clues to solve this problem, I’m attaching it here:
    0_1462963661105_journalctl_xb_wifi_problems.zip


    Fer

  • It seems to become a major issue. Ubuntu 16.04 users also comlain. I happened to find this in a Ubuntu forum. Does it work?
    sudo service network-manager restart

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Thank you @anarch, after many, many reboots, what seems to work is the Network Service restart… I have tried it successfully today three times …

    sudo systemctl stop NetworkManager.service
    sudo systemctl start NetworkManager.service
    

    Of course, restart is more concise and equally effective :-)

    Having said the above, it not a kernel problem, so @anarch, what would be the easiest way to change the default kernel? After installing LTS, I must select “Advanced Options” and then the last one is the current kernel…

    Thank you again, I will keep you informed…


    Fer

Posts 21Views 2552
Log in to reply