• Stuck on a boot loop after installing Antergos on a UEFI system


    Hello,

    I have just installed Antergos today on an UEFI system, but sadly, after installing, it is stuck in a boot loop unless I unplug the SSD. The installation went fine, without any errors, I used manual partitioning and made sure an EFI partition was created (in FAT32).

    Since my motherboard has two UEFIs available, I tried switching them around but to no avail.

    Here’s the PC specs:

    • CPU: Intel Core i7-2600K
    • Motherboard: MSI Z77 MPower (running the UEFI that came with it, not particularly up-to-date, but still)
    • RAM: 8 GB
    • SSD: Samsung 840 PRO, 256 GB

    I can’t even boot on a USB drive if the SSD is plugged due to that boot looping issue, so how would I reinstall Antergos on it?

  • You mean you can t set the boot order to USB?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch In fact, I can’t even access the UEFI by pressing/holding Delete (which is the correct key) whenever the SSD is plugged when booting. This means I can’t change the boot order either (F11 also doesn’t work, which is the key used to change boot order without entering the UEFI).

    The system will attempt to initialize, then at the end, it will reboot (without ever displaying GRUB), indefinitely.

    Update: I installed Antergos again on the same system on a HDD this time (also in UEFI mode). I get the same boot loop issue whenever it is plugged, so I’m quite convinced there’s an Antergos or UEFI issue. For the record, I could boot Fedora and Debian in UEFI just fine in the past (in 2015).

  • Sorry to hear that. I can see the loop issue but I cannot understand why UEFI can t be accessed . Try accessing it WITHOUT the SSD in place. Logically, you won t have any problem changing the boot order.
    Just in case, what make is the PC?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch I can access the UEFI if the SSD is not plugged. During that time, I tried changing the boot order, including disabling all UEFI boot options, the PC still will be stuck in a boot loop whenever the SSD is plugged.

    This is a self-built PC, you can read the specs in the first post.

    Update: I have flashed the UEFI to the newest version and I can now boot to UEFI with the SSD plugged. I will try reinstalling now.

    Update 2: Reinstalling has been a success, marking as solved.

  • Nice to hear. Welcome to Antergos!
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

Posts 6Views 1122
Log in to reply