• log in graphically not possible


    Since at about a little bit more than two weeks I can’t log in, because the only thing I see on my screen is a white building block in the center of my screen. On top left of the cuboid there is written in blue colour “Antergos”. I do not see anything else. There is no area where I could write my username and no area, where I could type in my password.
    With Ctrl+Alt-F3 I get the administration-screen and can log in, but after that I am not able to start a graphical surface.
    So my system is quite unusable. Does anyone have an idea how to solve this problem?

  • Two weeks is quite a long time with no updates. So, update your system from tty, when it finishes, type reboot and let s hope you ll be able to login. If not, here we are again.
    ***When you say 'With Ctrl+Alt-F3 I get the administration-screen and can log in, but after that I am not able to start a graphical surface", what do you mean? You get stuck with the tty screen?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I updated with tty. But the problem still exists.
    From tty the command startx does not help. If I do Ctrl+Alt+F7, I come back to the unreadable login-Screenshot.

  • What DE are you running?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Have you tried doing
    systemctl stop lightdm
    systemctl disable lightdm (might not be necessary)
    Then see if you can login.
    If running Xfce enter
    startxfce4
    Gnome - I would assume gnome-session or something like that
    KDE - absolutlely no idea,l

  • Oh, if startxfce4 works, then perhaps try a differnt Display Manager,
    SDDM, MDM, Slim.
    I use slim even though I have read that developement has ceased; my guess would be because of Gnome requiring logind, but, I could be wrong.

  • Thanks for so many good tips! Overnight I could not read and the next hours I am at work. I will try in the afternoon to do the purposes. What I see just now is that there several commands i maybe used wrong: i.e. startx or startxfce4.
    I am using the XFCE-surface. Hope this was ment with “DE” - I don’t know the abbreviation.

  • DE = Desktop Enviroment

    I had this same problem. What I did was

    yaourt -Syua
    pacman -S gdm
    systemctl disable lightdm
    systemctl enable gdm
    pacman -Rns lightdm-webkit2-greeter
    reboot
    pacman -S lightdm-webkit2-greeter
    systemctl disable gdm
    systemctl enable lightdm
    pacman -Rns gdm

    Cheers! I don't know what I'm talking about!

  • I tried herbies first propose. It works. But I have to do on this way after every reboot. Because of that I will tomorrow either stop the login routine (I am the only user) or I have to change the manager. More on Wednesday evening.

  • I think I solved the problem. I installed another greeter theme: pantheon. I changed as root the line in /etc/lightdm/lightdm.conf “session-greeter=lightdm-pantheon-greeter”, saved and rebooted. It worked.
    The idea to do it in this way I got from german Manjaro-Forum. Some user complained that older gtk2-themes had become destroyed by the last update, because more and more there should be gtk3-themes. I thought that perhaps my problem that I don’t see anything in that window for login, that this problem has a connection to what the Manjaro-Users reported. Thanks to all who helped me with good advices.

Posts 10Views 960
Log in to reply