• Wireless card doesn't always work on boot

    I have been having an issue with my wireless card for a while now. Sometimes when I boot into my computer the WiFi doesn’t work. In the network applet it will display the wireless card and underneath it just says ‘disconnected’ in greyed out text. To fix the issue I usually just reboot but recently I have had to completely power off the system at the plug to make sure it will work again on boot. The system can recognise that the PCI wireless card is there but for whatever reason it cannot search for a network, let alone connect to one.

    The card I am using is the TP-LINK TL-WN851ND with the ath9k driver.

    lspci displays:
    04:03.0 Network controller: Qualcomm Atheros AR9227 Wireless Network Adapter (rev 01)

  • I’m having a similar problem after a recent update. The WIFI Card is recognized when I boot (its an Intel 7260-AC) and it also recognizes the network, but it won’t complete the connection. I have to switch the WIFi off and on again; then, it connects. I have two installations of Antergos, one with Cinnamon, the other with Gnome. Both have the same issue. This just started recently. It wasn’t an issue when I first installed.

  • @yamon123 , this reminds me of an overnight discussion with the customer service of my Internet provider. After looong tests we discovered that i was using an ADSL router while they had switched to VDSL 3 days before. They swapped my router and that was that. So, just an idea to both. Are they desktops or laptops, so that they can be tested elsewhere to determine if the problem is the card or the router. I have also heard of cases where a router would t work with channels higher than 10. (Sorry, I don t know about TP-Link).
    Also, you both mention “recently”, “after a recent upgrade”.
    Have you tried using the lts kernel?

  • @anarch the issue is definitely with the card as no wireless networks are shown at all, even though there are around 8 networks it can usually pick up. I have always had this issue and a reboot would usually fix the problem, but in the last few days I have had to power off my system at the plug to ensure it will work again on boot. I have tried the LTS kernel and the issue still persists.

  • Can you check it is not a hardware issue, boot from a live usb several times and see what happens with the wifi. This will also tell us if it could be a recent update.

  • i have the same problem,
    In the last days i cant connect to wifi. After that, sometimes i had this problem, but rebooting i fixed the problem.
    i tried to install again, but nothing.

  • @anika200 I have tried booting from a live USB a few times and the WiFi has worked as expected each time so it must be a software issue.

  • yeah, i hope the ploblem be fixed soon, i only can connect to wifi using a usb.

  • Has anyone tried downgrading Network Manager? Arch form thread here.

    Basically these steps
    Confirm you have the new and old versions

    sudo ls -la | grep networkmanager

    then install the older one with

    sudo pacman -U

    And keep from upgrading by adding IgnorePkg = networkmanager to /etc/pacman.conf

  • I know this isn’t exactly a fix but I just uninstalled networkmanager and installed wicd instead. Everything is now working as expected. Thanks for your help everyone!

  • @mtrack Hi there, as I’m having this same issue, https://forum.antergos.com/topic/4406/wifi-works-after-3-reboots/16, I would like to know if installing Wicd was the solution to the WiFi problems??
    Thank you in advance!!

  • @ferthelet said in Wireless card doesn't always work on boot:

    @mtrack Hi there, as I’m having this same issue, https://forum.antergos.com/topic/4406/wifi-works-after-3-reboots/16, I would like to know if installing Wicd was the solution to the WiFi problems??
    Thank you in advance!!

    I have the same concern and question as ferthelet – any further information on this would be greatly appreciated.

  • @ everyone, Have you downgraded Networkmanager??? It is the recommended solution from the arch forums and google search.
    If you guys do not try it then you/we will not be helping anyone and just wasting a bunch of time.

  • @ferthelet I uninstalled network manager completely and install wicd, essentially replacing networkmanager. This has fixed my problem but as others have said downgrading network manager should fix the issue.

  • @mtrack thank you! I’ve tried to replace NM by Wicd, but my first attempt failed miserably… i guess I need a fool-proof guide :-)
    In the meantine, it seems that restarting the Network Manager also does the trick… I have done it three times and it worked consistently fine.

  • As of today 5/11 NetworkManager was updated and possibly will fix your problem. Can you try an upgrade and see if it is working for you.

  • @anika200 yes, I have just updated NM… we’ll see… thank you!!

Posts 17Views 3436
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.