• antergos is "damaging" my HDD


    Hi,

    something is wrong with my installation.
    i had 32 GB free on a HDD. I made a 30 GB / and a 2 GB /swap. then installed antergos.
    Now i get errors when i boot and yesterday antergos stopped working while in use.
    On this Partition were many different OS from Linux to Win and i never had any problem.

    Its always the same error:

    [email protected] ~ $ sudo e2fsck -f /dev/sdb6
    e2fsck 1.42.9 (4-Feb-2014)
    Durchgang 1: Prüfe Inodes, Blocks und Größen
    Inodes gefunden, die Teil einer defekten verketteten Liste von verwaisten Inodes waren.  Repariere<j>? ja
    Inode 547818 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 547825 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 547851 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 549974 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 550156 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 550303 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 550366 war Teil der Liste verwaister Inodes.  REPARIERT.
    dtime in gelöscht Inode 550628 ist Null.  Repariere<j>? ja
    Inode 550905 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 550907 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 815226 war Teil der Liste verwaister Inodes.  REPARIERT.
    Inode 815230 war Teil der Liste verwaister Inodes.  REPARIERT.
    Durchgang 2: Prüfe die Verzeichnisstruktur
    Durchgang 3: Prüfe Verzeichnis-Verknüpfungen
    Durchgang 4: Überprüfe die Referenzzähler
    Durchgang 5: Überprüfe die zusammengefasste Gruppeninformation
    Unterschiede in der Block-Bitmap:  -34624 -(1294862--1294864) -(2261221--2261223) -(2471583--2471585) -(2910429--2910431) -(3011886--3011894) -(3299865--3299867) -(3299871--3299873) -(3300003--3300005) -(6451211--6451213) -(6451320--6451322)
    Repariere<j>? ja
    Die Anzahl freier Blöcke in Gruppe #1 ist falsch (1432, gezählt=1433).
    Repariere<j>? ja
    Die Anzahl freier Blöcke in Gruppe #39 ist falsch (1357, gezählt=1360).
    Repariere<j>? ja
    Die Anzahl freier Blöcke in Gruppe #69 ist falsch (330, gezählt=333).
    Repariere<j>? ja
    Die Anzahl freier Blöcke in Gruppe #75 ist falsch (703, gezählt=706).
    Repariere<j>? ja
    Die Anzahl freier Blöcke in Gruppe #88 ist falsch (1491, gezählt=1494).
    Repariere<j>? ja
    Die Anzahl freier Blöcke in Gruppe #91 ist falsch (2141, gezählt=2150).
    Repariere<j>? ja
    Die Anzahl freier Blöcke in Gruppe #100 ist falsch (4275, gezählt=4284).
    Repariere<j>? ja
    Die Anzahl freier Blöcke in Gruppe #196 ist falsch (6304, gezählt=6310).
    Repariere<j>? ja
    Die Anzahl freier Blöcke ist falsch (2958760, gezählt=2958797).
    Repariere<j>? ja
    Unterschiede in der Inode-Bitmap:  -547818 -547825 -547851 -549974 -550156 -550303 -550366 -550628 -550905 -550907 -815226 -815230
    Repariere<j>? ja
    Die Anzahl freier Inodes ist falsch für Gruppe #67 (3509, gezählt=3519).
    Repariere<j>? ja
    Die Anzahl freier Inodes ist falsch für Gruppe #99 (2, gezählt=4).
    Repariere<j>? ja
    Die Anzahl freier Inodes ist falsch (1581026, gezählt=1581038).
    Repariere<j>? ja
    
    /dev/sdb6: ***** DATEISYSTEM WURDE VERÄNDERT *****
    /dev/sdb6: 263122/1844160 Dateien (0.2% nicht zusammenhängend), 4417234/7376031 Blöcke
    
    
  • Did you run that command from Antergos? The reason I ask is because the partition should not be mounted whenever you run that command. One thing you might try is to install the LTS kernel and see if you get the same results. The issues sounds like a bug in the latest kernel. You can install the LTS kernel and regenerate your grub config like this:

    sudo pacman -S linux-lts
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Cheers!

  • Hi,

    no it was from my Mint.
    I tested the drive with sudo badblocks -vsn /dev/sdb6 and there were 3 Errors. Then i did sudo e2fsck -c -p -f -v /dev/sdb6.
    I used the system yesterday with no error. And tested the drive this morning in Mint with sudo e2fsck -f /dev/sdb6 and there
    was also no error.

    I dont know maybe it was just bad luck for antergos that the damage happen since i installed it.Ore can the kernel cause bad blocks?

    Greetings

Posts 3Views 429
Log in to reply