• Like 0

    Can't update qt5-base or qt4, vfio kernel


    Hi I have an issue where I can’t update qt5 (or qt4) because it asks me to choose a provider for libgl and when I choose nvidia-libgl (or any option actually) it tells me there are file conflicts and the files already exist then bombs out and fails.

    I believe the problem is that I am using VGA Passthrough (which is freaking amazing btw) and I had to install the nvidia driver direct from the Nvidia website. If I install it through Pacman then I don’t get a graphical environment when I reboot. Not sure exactly why this is but believe it is related to the vfio kernal I am using.

    So I believe I already have nvidia-libgl installed but Pacman doesn’t realise that I do and wants to install it but then fails when the files are already on my system. Is there a way around this or to get Pacman to ignore looking for libgl?

    Thanks

  • Like 1

    Ok so I have managed to solve my own problem by creating my own package that provides ‘libgl’, then the various qt packages updated without issue.

    An article on unix.stackexchange pointed me in the right direction and reading the arch wiki and about a rather similar package: dummy package I was able to work out what was needed. :tada:

qt57 qt42 vga-passthrough1 libgl3 Posts 2Views 277
Log in to reply