• Antergos ISO 3.20 64-bit does not boot in virtualbox

    I am unable to boot with the normal iso in virtualbox, but the minimal one does boot. Except, I need the normal one because it has all of the programs in it that I need.

  • Hi,

    That’s odd, because we always use Virtualbox in our tests (I just used it yesterday).

    Do you get any error messages?

  • with the latest nightly iso. All i get is blank screen, but I can switch to the other tty’s.

  • Looks like I can get the GUI working if I select no KMS at the boot option. Not sure why this is necessary, but I guess it works for now.

  • Is this possibly the same issue as https://forum.antergos.com/topic/4302/antergos-running-in-virtualbox-blank-screen

    In which case does setting the kernel parameter iomem=relaxed allow you to boot to a desktop?

  • @gavmassingham Yes it appears that iomem=relaxed also makes the GUI load. I didn’t see that there was already a post about it.

  • Hi, I wonder if this is the same situation as mine. I downloaded Antergos 2016.04.22 and loaded into virtualbox. I only get a blank screen with the cousor blinking in the top left hand corner. I have waited 5, 10 and 20 minutes but it keeps hanging. My host system is an iMac 21.5", 3.1GHz Quad Core i7, 500GB SSD, 16GB Ram, NVIDIA GeForce GT 650M 512M Card. This is very strange as the previous ISO worked perfectly fine. Please let me know if there is a solution to this. Thank you.

  • It sounds the same. If so it’s a bug in VirtualBox that should be fixed in the next release. In the meantime the ‘solution’ linked to above - setting the kernel parameter iomem=relaxed (see the linked post for fuller instructions) - is a work around that allows the desktop to boot. (At the blinking cursor pressing Alt+Ctrl+F1 should drop you into a command line). Does doing this allow you to boot?

  • Thank you Gavmassingham, this may be an issue since I am on a mac. Do you know the alternate keys ALT + CTL F2, thank you again.

  • No. But googling brought up this:


    Which may, or may not, help!

    If not, and assuming it is the same issue, you should be able to edit the boot command when the loading screen appears by pressing ‘e’. Add the iomem=relaxed at the end of the Linux line after ‘quiet’. That should boot you into a desktop and then you can make the change stick by editing the grub config file.

  • Thank you again. I have a Win 10 machine which has the same issue. I did enter ALT CTL F2 but this droped me into an error screen telling me "Welcome to Antergos - 4.5.1-1ARCH (tty2)…ant-16 login:…???

  • That is a command line, you could log in there and make changes to the grub file. But you don’t need to:

    If you follow the instructions in my post linked a couple of comments above these will work:

    Press ‘E’ to edit the kernel parameters when the boot up screen appears and insert iomem=relaxed at the end of the linux line (you may need to scroll down) after it says ‘quiet’. The system should boot normally.

    (Once you’ve booted into a desktop)
    To make the change permanent - at least until VirtualBox is updated - edit the file /etc/default/grub and add the iomem=relaxed to the line GRUB_CMDLINE_LINUX_DEFAULT within the quotes. Then run
    sudo grub-mkconfig -o /boot/grub/grub.cfg


  • I am sorry but I am not a programmer all I want to do is try out Antergos. Not matter what I do this error screen appears. I am very disappointed I have to do all this just to try out a distro. I am have to move on to a more user friendly distro…

  • It’s not a problem with Antergos, it’s a bug in VirtualBox.

    What you’re seeing when you type ctrl alt f1 isn’t a error message but a command line login prompt. If you enter your username you will be prompted for your password and will be able to log in to a command prompt. But as I said you don’t need to do that -is the loading screen appearing? If it is you can try my previous instructions to edit the boot command.

    The bit that’s not working is that the desktop won’t load - this is the virtual box bug. It will be fixed in the next release of virtual box. My instructions give you a way to get round the bug until that happens.

    I realise that people who have never used the command line, or edited a config file, are often put off by being asked to do so, but since this is a free operating system running in a free virtual machine, and it doesn’t work anyway, trying my instructions is at worst going to leave you in exactly the same position, and at best will get Antergos working!

    If you actually installed Antergos on disk, rather than in Virtual Box it would almost certainly work fine. Possibly however a more ‘mainstream’ Linux might suit you better. Antergos is a ‘rolling’ distribution which means it uses bang up to date packages, and this can sometimes, though rarely, lead to things breaking.

  • Thank you again. I do not have a username and password. If you can give me a username and password that would be great. I loaded the iso in vb and I was presented with a blank screen. The previous Antergos iso’s did not have this issues so I cant see why the new one one is any different. Yes I relies Linux is free and I suppose this is the price you pay but than again fixing any problems is very rewarding.

  • Hi, do you know when vb will release an update for this issue as I am keen to try this distro out again.

  • Do you get the loading screen - the one with the Antergos logo and which has options at the bottom of the screen “Enter: Boot Selection E: Edit Selection. C: GRUB Command line” ?

    If you don’t even get this then it may be another issue. If you do get this screen I’ll go thorough it step by step and see if we can get you into the desktop.

  • VirtualBox has been updated to 5.0.18 and the vbox packages in Antergos have been updated as well. So it might be worth updating VirtualBox and maybe re-downloading the ISO and trying again.

    For anyone else reading this thread - you no longer need the iomem=relaxed kernel parameter with latest VirtualBox 5.0.18 and latest Antergos packages it should just work again

  • Hi again, No I did not get the loading screen with the Antergos logo which I think is LightDDM. As per my previous message all I get is a BLACK SCREEN with the cursor blinking in the top left hand corner. All previous Antergos iso’s have worked so I can’t see why this one wont. We may have to wait until VB upgrades to the next version and who knows when that will be. One very disappointed customer.

  • Hi again, sorry I should have advised earlier the issue’s I am having are in the current version of Virtual Box 5.0.18 r106667. So Antergos (for me anyway) is not working in the current version of VB.

Posts 40Views 10960
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.