• Antergos ISO 3.20 64-bit does not boot in virtualbox


    Hi,

    It doesn’t sound like quite the same issue - did you manage to install Antergos or were you trying to run it from the live cd version?

    Also note that I’m not a member of the Antergos ‘team’ or anything. I’m just an Antergos user who had the Virtual Box issue, worked out a way round it and shared that so that others could also benefit. But I’m happy to try and get you up and running with Antergos if I can.

  • Hi again, thank you for your time on this. I know all Linux or most users are volunteers who try to help out which I appreciate. I downloaded the iso from the Antergos website and saved it on the mac. Created a new vm named “Antergos” in virtualbox and ran it from there no physical CD to load.

  • I am downloading another Antergos iso and I will see how the new one goes. Again thank you for your time on this.

  • I am experiencing exactly the same issue on my Win 10 Lenovo laptop. I am wondering if anyone else is having the same issue’s and if so are there any solutions.

  • Right. I think the original answer to this topic might have the solution for you. My answer only works if you can change the boot options and this is not so easy if you are just booting off the lIve CD and haven’t installed yet. I’ve got step by step instructions for you below. I’ve gone through this entire process with a fresh VM on latest VirtualBox and download of the latest full Antergos Live iSO myself so I can say they definitely worked on my Windows 7 machine.

    Let me know whether the following steps get you to a desktop, or at which point you have a problem.

    1. Start booting from the ISO. You should get to the screen that has the logo and the choice “Boot from hard disk; Start from Antergos Live; and Non-graphical Boot” at this screen press space or any other key to interrupt the boot process. If you don’t even get this far then I don’t think it’s an Antergos problem!

    2. Press ‘F3’ which allows you to change the video settings. Choose ‘No KMS’ from the menu that appears and press enter.

    3. Then choose ‘Start Antergos Live’

    4. Either run from the Live CD or install (I’ve only tried the live option but I think install should also work from here)

    While running from the live CD you’ll have to set that ‘No KMS’ option at every boot.

    If you install Antergos (which given this is running in a VM is probably the best thing to do as you’ll get a better experience) you will need to do something to get the system to boot once so you can install a package that’s needed. Once that’s done you will be able to boot up normally in future. To boot into a desktop on an installed Antergos:

    1. Boot from the virtual machine’s hard drive.

    2. You should get to the boot selection screen that I mentioned in my earlier comments. Again press a key to pause the boot process.

    3. Press ‘E’ this will let you edit the boot process for this time only (i.e. it won’t change future boot ups)

    4. Don’t be put off by the text that appears - this is the command that is used to boot Linux. Use the arrow keys to scroll down to the line that starts with ‘Linux’. it will probably be split over two lines by a backslash but it’s all one line really.

    5. Use the left/right arrow keys again to move the cursor to after where it says ‘quiet’ and type iomem=relaxed making sure there is a space on either side. it will look something like quiet iomem=relaxed resume=....

    6. Now press F10 or Ctrl+x to boot.

    Once you’re in Antergos you need to install the Linux headers package. (I think this is an Antergos problem - users shouldn’t have to install any extra packages to get the system working. Hopefully the Antergos team will address this at some point.)

    1. Open ‘Add/remove software’ - how you do this will depend on which desktop you have installed. In Gnome click on the ‘Show Applications’ item in the left hand dock. Then choose ‘Add/remove software’ from the list.

    2. In the search box type ‘linux headers’.

    3. in the list of results that appears double click the ‘linux-headers’ package to mark it for install. Then click the tick at the top left of the window to install. You will be prompted for your password. Antergos will install the headers and a ‘kernel module’ that makes Antergos work properly with VirtualBox.

    You can now reboot and Antergos will start normally.

    I know that seems like a lot of steps but you’ll only need to do this once!

    Hope that all works for you. Let me know if you have any problems.

    Thanks,

    Gav

  • I was trying Antergos today for the first time, using Virtualbox and had the same issue.

    I made a video about it, and you can see, how to fix it, but it is in German:

    https://youtu.be/R3fPY11bUdo

    Regards, Nick

  • Hi Gav, thank you for the instructions. In part they have worked. I could not get grub to accept “iomen=relaxed” so I rebooted and got into Antergos using the LTS Kernel. Once I was in I installed the “Linux Headers” rebooted and then Antergos accepted the most recent / new Kernel. So to sum up all is good now. I would like to thank you for your time and help on this issue, thanks, 645dood.

  • Glad you’ve got it working. Using the LTS kernel was a good idea.

  • The latest ISO (4.22) no longer works in VB, and setting the iomem=relaxed does nothing. I am also using VB 5.0.18 not sure why the latest one doesn’t work at all with this setting when the previous one did.

  • If you had a working install of Antergos this should just work now. So I’m unclear what the issue is - are you reinstalling using the latest ISO?

    Anyway the instructions I posted above DO work for me on Windows 7 using the latest VB and the latest full Antergos iso. I’m afraid I can’t do anything more on this issue. Try the solution using the LTS kernel as this will also work and doesn’t involve setting iomem=relaxed.

  • I was trying to install Antergos in a VB, 64-bit and downloaded the latest iso.
    I’ve done this before and it worked, but all I get is this, wen picking boot Antergos live.

    I have the minimal iso.

    http://imgur.com/dD64wJl

  • Have you tried any of the suggestions above? Using F3 during the boot process to select ‘No KMS’ should get you past that error, for example.

  • Hi,

    Sorry for overlooking that, hitting F3 and selecting ‘no kms’ did the job, for both the minimal and the full iso.

    Thanks!

  • @gavmassingham I got close I think, installed the headers, but something went wrong.
    I’ve installed the lts kernel and therefore the lts headers, but received a message.

    It’s Dutch, but I hope you will be able to understand the message.

    http://imgur.com/hpyujmo

  • I didn’t use the LTS kernel so I’m afraid I’m not sure.

    I really would suggest trying the full instructions I posted earlier, and maybe watching the video that was also posted.

    If you’ve managed to actually install Antergos following the instructions from that point on should work.

  • I’ve installed the newest kernel headers as well, rebooted and it is running smoothly…
    Dunno why, but it’s running. ;)

  • just installed 2016,04 get this in begin = http://i.imgur.com/phM3Tog.png

    alt text

    hmmm will see :)

    after get black

  • it want use lightdm-plymouth …
    but i gues there is no plymouth configured :)

    alt text

  • Antergos 2016.04.22-i686 does not boot either. After using workarounds from above, I was able to enter all necessary inputs in Cnchi. Installation started but soon ( at 12 % ) froze totally, I guess wrong configured kernel. Impossible to see any logfile on a frozen machine.

  • hah seems i had is different… will see next fresh build because my Xfce had somehow no Networkmanager installed , it booted in gnome-boxes didnt follow now invbox moment.

Posts 40Views 10959
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.