• Blank black screen on logout and shutdown


    Hello,
    I’ve a fresh install of Antergos KDE on a Macbook Pro 2015. Intel graphics drivers.

    Frequently, but not always, when logging out, I get a blank black screen and a frozen system. I have to reset to proceed. I assume this is an xserver issue, but need help figuring out what to do to troubleshoot. (e.g., what logs should I be looking at?)
    Also, can wayland be used? If I can log into and out of a wayland session, would that confirm an X issue? Is it possible to install wayland on Antergors KDE?
    Thanks for suggestions.

  • Hey there,

    same problem here with an also fresh install of Antergos with KDE, but using x86_64 with an AMD X260 and an NVIDIA GTX 750 Ti video card.
    Its not possible to shut down or reboot the system without pressing the hard reset button on my machine, wether I try to reboot via the Shutdown menu or via the “sudo reboot”, “sudo shutdown” or “sudo poweroff” command, it always crashes into a black screen freeze. aswell for me…

  • @watgrad s

    Also, can wayland be used? If I can log into and out of a wayland session, would that confirm an X issue? Is it possible to install wayland on Antergors KDE?

    I don t use KDE, but in Gnome there is an option to choose the session you want. I guess there is something similar to KDE greeter.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hello,
    Switching compositor to OpenGL 2 stopped this behaviour for me…

  • @watgrad Actually no - it is still happening. Not every logoff or shutdown, but this still happens every 2nd or 3rd time the computer is shutdown. Any ideas on how to troubleshoot. I can’t even switch to a terminal when it happens, only hard reset—yikes!

Posts 5Views 999
Log in to reply