• Mouse & Touchpad: Disable Touchpad?


    Why are there absolutely no options under Mouse & Touchpad under Settings in GNOME, I want to be able to disable the touchpad like you can do using other DEs, for example, under Cinnamon, the options for both M&T are there.

    So, how can I disable the touchpad, I may have to reinstall Antergos a third – first time I chose Cinnamon, second time GNOME… – time to go with a more full featured DE that gives those options under settings.

    Michael

  • All the settings you are looking for should be there. I really don t know why there are absolutely no options for you. There is even an extention to have the enable/disable settings in your top bar…
    https://extensions.gnome.org/extension/131/touchpad-indicator/

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Take a look:

    0_1461087762524_Screenshot from 2016-04-19 11-42-10.png

    Michael

  • @anarch said in Mouse & Touchpad: Disable Touchpad?: There is even an extention to have the enable/disable settings in your top bar…

    https://extensions.gnome.org/extension/131/touchpad-indicator/

    How do I install that, I get the following on that link:

    0_1461087961212_Screenshot from 2016-04-19 11-45-52.png

    Michael

  • I didn t say you dont know what you see. Is it the latest 3.20?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • How do I check that? I just installed Antergos for the first time yesterday, went with the Cinnamon DE, but I liked the Gnome DE that you get from the Live CD, so I decided to reinstall Antergos this morning and chose Gnome.

    EDIT: Found the version: 3.20.1

    Michael

  • Did 3.20-1 solve the issue?
    *Here is mine (in greek).
    http://imgur.com/ST7SrOL

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch 3.20.1 is the version that comes with the latest – I believe – ISO for Antergos. I didn’t do anything to it, as I am new to this Linux distro, everything is default.

    Michael

  • Well, even if it wasn t the latest version in the iso, Cnchi would still have downloaded the latest one for you. I can only guess that for some reason your touchpad was not recognized. Some computers have a functional keys combinations that disable and enable touchpad.
    What make is it?
    Also, googling your issue returned me this…
    https://www.google.gr/search?q=touchpad+was+not+recognized+gnome+antergos+&ie=utf-8&oe=utf-8&gws_rd=cr&ei=nHcWV8PHNYbjU8fpm2g

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • About the extention. On the top right hand corner, click the “Allow” button. You may need to refresh the page afterwards.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Mouse & Touchpad: Disable Touchpad?:

    Well, even if it wasn t the latest version in the iso, Cnchi would still have downloaded the latest one for you. I can only guess that for some reason your touchpad was not recognized. Some computers have a functional keys combinations that disable and enable touchpad.
    What make is it?
    Also, googling your issue returned me this…
    https://www.google.gr/search?q=touchpad+was+not+recognized+gnome+antergos+&ie=utf-8&oe=utf-8&gws_rd=cr&ei=nHcWV8PHNYbjU8fpm2g

    I have an ASUS G75VW. I have tried the key combo [Fn + f9], and while it shows the disabled touchpad on the image, it doesn’t disable it at all.

    The touchpad is clearly being recognised, but I cannot disable it. Cinnamon, like I said, had the options to disable it, but you can see what Gnome is giving me.

    Michael

  • Does the extention take any effect at all?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • After playing with the extension, I finally found the right settings to get it to work. But, I shouldn’t need to use an extension, it should be accessible through Mouse & Touchpad in settings.

    Thank you.

    So, I’ll mark this solved for now.

    Michael

  • Right you are. At least you got it to work.
    Cheers!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Though solved…
    "After the update to Gnome 3.20, I had the problem of my Asus laptop’s touchpad losing features like disabling tap-to-click and it no longer showed up as configurable under Settings > Touchpad.

    I was able to fix it this way…

    sudo pacman -S xf86-input-libinput
    sudo pacman -R xf86-input-synaptics
    sudo mv /etc/X11/xorg.conf.d/50-synaptics.conf ~/
    

    Reboot."
    Found here…
    https://forum.antergos.com/topic/4271/gnome-3-20-natural-scrolling-only-working-in-wayland/11

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Mouse & Touchpad: Disable Touchpad?:

    Though solved…
    "After the update to Gnome 3.20, I had the problem of my Asus laptop’s touchpad losing features like disabling tap-to-click and it no longer showed up as configurable under Settings > Touchpad.

    I was able to fix it this way…

    sudo pacman -S xf86-input-libinput
    sudo pacman -R xf86-input-synaptics
    sudo mv /etc/X11/xorg.conf.d/50-synaptics.conf ~/
    

    Reboot."
    Found here…
    https://forum.antergos.com/topic/4271/gnome-3-20-natural-scrolling-only-working-in-wayland/11

    Well, that worked!

    Michael

  • Well done!👍

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

gnome289 touchpad39 settings4 Posts 17Views 4471
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.