• Antergos kicks me back to the login screen after logging in


    I just restarted antergos and when I logged in it showed a black screen and heard my GPU spinning after that it showed me the login again. I installed the catalyst drivers.

    Does anyone know how to fix this? Thanks in advance!

    I have been running antergos for a week without any problems until now

  • Just downgraded the kernel but now it just shows a black screen and can’t use the terminal.[0_1461068629059_VID_20160419_142250.mp4](Uploading 100%)

  • You don t make it clear if the problem started After you installed the Catalyst drivers.
    I can think of 2 things.

    1. Trying the lts kernel. If you haven t already got it, give
      sudo pacman -S linux-lts
      and then regenarete your grub with
      sudo grub-mkconfig -o /boot/grub/grub.cfg
      Reboot and see how it goes.

    2. During boot, press E key and give the nomodeset parameter.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch I installed the drivers a week ago all worked fine I even played games, the catalyst control center was on the system just today after restart this happened. I checked if the settings were reverted nomodeset wasn’t in the grub file anymore and put it back did grub-mkconfig again, still no luck. I thought maybe because of a kernel update and downgraded the kernel, then it just showed a black screen and now I am chrooted into the system trying to get the latest kernel back. I also tried the Linux LTS kernel.

  • So I got the latest kernel again but when I login it still kicks me back to the login screen…

  • Just reinstalled the drivers and regenerated the config files still the same problem… :(

  • @anarch Tried that and no luck…

  • When I type startx in the terminal I get xorg no screens found no matching device section for instance

  • @Irakli

    When I type startx in the terminal I get xorg no screens found no matching device section for instance

    Just saying…are you running xorg? What DE are you using? What you describe happening after login in the 1st post, reminds me of afriend s AMD machine running Gnome when we tried to switch to Wayland.
    Cannot say any further. I hope someone more experienced comes up with something…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Yes Xorg and Gnome DE.

  • You are sure your greeter is not set to “Gnome on Wayland”? I have read of users running Wayland without knowing it.
    Something else then (since you re with Gnome). Have you tried GDM instead of lightdm? I have also met machines too stubborn to login with lightdm.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Unfortunately that also didn’t work. With GDM I didn’t get to the login screen.

    when I type startx I get the following

    fglrx: No matching Device section for instance
    Fatal server error: (EE) no screens found (EE)

    I also use Xorg version 1.16 https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_crashes

  • Did you check that you are not in Wayland session by accident?
    As I told you before, I had a machine with AMD drives which when we switched to Wayland it behaved just as yours/ .
    Login screen-> password> back to login screen.
    Sorry, but this is the last thing I can come up with.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Not on wayland, I checked it. I installed the opensource AMD drivers and replaced lightdm with GDM. I can login now but I cant see my applications and when I right click and click settings nothing happens.

  • Back to the proprietary drivers since AMDGPU does not work with steam. Still the same problem… Probably gonna re-install antergos, I am wasting too much time on this problem.

  • Just tried the catalyst install script, unfortunately this didn’t fix the problem either.

  • Not going to re-install antergos yet, maybe someone has a solution.

  • fglrx, just went over our discussion. As an Ubuntu user as well, I recalled the problem with fglrx and the coming Ubuntu new version. They have dropped it because AMD no longer supported it.
    This might be relevant
    http://askubuntu.com/questions/744050/im-using-ubuntu-16-04-beta-1-and-theres-no-fglrx-is-it-a-common-problem-relat

    http://www.omgubuntu.co.uk/2016/03/ubuntu-drops-amd-catalyst-fglrx-driver-16-04

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Just re-installed antergos, everything is back to normal. Thanks for your help.

  • Glad you restored it. Though I don t think I was much of a help…:clap:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

Posts 20Views 749
Log in to reply