• How do I downgrade Gnome 3.20 to 3.18?


    I just installed gnome 3.20, since I had read that it includes bug fixes and some interesting new features. However, the update killed many of my extensions (including the antergos theme), my touchpad is no longer recognized unless I run wayland (which has weird cursor movement dynamics), and I have severe graphical glitches when switching between windows (the window blinks and resizes).

    I want to go back to gnome 3.18, is this possible by maybe enabling/disabling some repositories using pacman or do I have to install from source? How do I go about this?

  • Just a few suggestions.
    Are you running Wayland under gdm? If no, give it a try to see if it gets any better. Also, give standard gnome a try with gdm.
    Extentions are coming back day after day. There s a couple of them not working for me, yet.
    For the Antergos theme. Isn t it in the tweak tool to change?
    For the touchpad. Maybe you need to set it from the System Settings?
    *Though it could be hardware-related, to me, it was one of the smoothest transitions ever, to either Gnome or Gnome on Wayland sessions.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Yeah, I was running wayland under GDM. I am back to X under GDM now. Thanks to this thread, I have worked around the touchpad issues. I also found out that I can simply change the metadata.json for most extensions in ~/.local/share/gnome-shell/extensions/ and include 3.20 in the allowed version and the extensions works again. For the Antergos user theme, that extension was still enabled, but for some reason the theme was unselected in the tweak menu, so I just went there and reselected Numix-Frost for the shell theme and the default looks are back.

    My tweaks for smaller titlebars was also reset and required updating. So most of the issues are fixed now. Unfortunately, I am still having troubles with Nautilus, both with the graphical glitches and the titlebar tweak not applying to the nautilus window. Any ideas?

  • I guess we need to be patient. Such “inconveniences” are normal after major releases. That goes for both the 2 “advanced” DEs (gnome, plasma). 3.20-1 was just released, 3.20-2 is scheduled for May 11.
    *Could you please take care of your link to solving the touchpad issue? It doesn t work…
    Thanks!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch The link is working for me.

    I have gnome-shell 3.20.1, but I haven’t seen the graphical glitch reported elsewhere, so I am afraid that it is specific to my/some machine and not everyone running gnome. So, it might be difficult to find help for it =/ I’ll post on SuperUser and the file a bug with gnome.

  • @cheflo before posting your issue upstream (gnome), please check that with the Adwaita theme doesn’t work either.

    Thanks.

  • I disabled all plugins (including the usertheme one) when I tested the behavior, which I thought would reset all themes to the Gnome deafults. However, I tested your tip and when I change the GTK+ theme to Adwaita, the issue went away. Thanks for pointing that out.

    So this seems to be a problem unique to the Numix Frost and Numix Frost Light themes, that Antergos use by default. Should I report this issue with Numix or open a new post on the Antergos forums?

    Here is a video for a better understanding of the glitches.

  • Thanks @cheflo , that’s how it is done ;)

    Long explanation: With each GTK release, backwards compatibility is always broken. This means that all themes cease to work and they need fixing. As adwaita is the GTK default theme, it is always fixed first. If, when changing Gnome version, issues arise, the first thing to do is test Adwaita theme. If it works, then it means that the theme needs an update.

    Cheers!

  • @karasu Thanks for the explanation! It sounds like a lot of additional work to break backwards compatibility in every release of GTK. But now I know where to start troubleshooting next time!

Posts 10Views 3337
Log in to reply