• Antergos Running in VirtualBox Blank Screen


    I’ve run Antergos in the past on my hardware. Currently, I’m running Fedora 23 and was trying to run the latest Antergos under VirtualBox. I’m able to boot the live media and install it in a virtual drive, however, when I go to boot the installed system I arrive at a blank screen with a blink cursor. No amount of time has produced a graphical interface. Booting with systemd.unit=multi-user.target I’m able to get a login prompt and issue commands so the system does work at the command line level. I got this result on two different Fedora 23 systems and I’m unsure if it’s my setup or a bug in Antergos. I’ve looked around Google and the forums, but didn’t find anything that seemed to pertain to my problem. Any help is much appreciated.

  • I have this issue as well this morning. I guess it’s an issue with the latest kernel. Will try and get mine working and post back.

  • Hi,

    This appears to be a VirtualBox issue that should be fixed in the next release. In the meantime adding the kernel parameter iomem=relaxed at boot up should fix the issue.

    Press ‘E’ to edit the kernel parameters when the boot up screen appears and insert iomem=relaxed at the end of the linux line (you may need to scroll down) after it says ‘quiet’. The system should boot normally.

    To make the change permanent - at least until VirtualBox is updated - edit the file /etc/default/grub and add the iomem=relaxed to the line GRUB_CMDLINE_LINUX_DEFAULT within the quotes. Then run
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Once VirtualBox gets to the next version this problem should be fixed and you’ll be able to remove that option.

  • @gavmassingham No it was not running before this. I did a brand new install and arrived at this. In the past I’ve done the downgrade, but since I don’t have a previous version to downgrade to, I’ll just wait for a fix to roll out. Thanks.

  • I’ve changed my answer - the work around I’ve posted now doesn’t need a kernel downgrade and should work for you.

  • @gavmassingham It works with your suggestion without having to downgrade the kernel. Thank you.

  • @matt.mccann.8 Thanks!! I just signed for this forum to thank you!

  • Glad it was helpful.

  • Latest version of VirtualBox 5.0.18 has been released and the Antergos packages updated and this issue no longer occurs for me - the iomem=relaxed kernel parameter is no longer needed.

  • Latest Version:

    pacman -Qi virtualbox
    Name : virtualbox
    Version : 5.0.18-1

    Still have to use iomem=relaxed to boot Live CD, then again on the first boot.

    Install linux-headers, because without dkms will not work:

    sudo pacman -S linux-headers

    dkms will start to build virtualbox modules, then reboot without iomem=relaxed

    I made this video, but it is in German:

    https://youtu.be/R3fPY11bUdo

    Regards Nick

  • Yep, if you haven’t already got Linux headers installed you need them.

Posts 11Views 3847
Log in to reply