• Just run updates - can't log in graphically or start xorg

    I’ve just run an update for the first time in 2 weeks. On booting afterwards, I’m greeted with this. The second picture shows the result of pressing the menu button in the top right.


    I can go to the command line by Ctrl-Alt-F5. There I can log in. Then I tried to run startx, and I get the following result (image at this link - I couldn’t put it in directly because the file’s too big):


    I’m totally at a loss for what to do now. I could try downgrading packages, but there are around 150 that have just been updated so I haven’t got a clue which one I should downgrade. Thanks for any help.

  • X is already running, that’s why you can’t run startx

    Please, log in as you do (CTRL+F5) and try to update your system again (there has been a fix for lightdm-webkit2-greeter, that’s what is failing you).

    sudo pacman -Syyuu

    If it still does not work, as a last resort, you can try to stop lightdm and install and use gdm as a replacement:

    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo systemctl stop lightdm
    sudo systemctl start gdm
  • Thank you very much for your swift response!

    I had to resort to using gdm. I did run some more updates but they don’t seem to have helped. I will continue to check lightdm’s functionality after updates. Is there any further advice you have in the mean time?

  • Yeah I had the same problem earlier today, still pretty new to Linux but I resolved this issue by removing the lightdm package and doing a fresh install of the upgraded package after updating my packages.

  • Sorry forgot to mention I did all this through tty,

  • @destro Thanks for this advice everything’s sorted and back to normal now :)

  • @karasu Thanks my friend!
    I had also this problem after updating so I installed gdm and it worked! 👏🏻

  • @karasu said in Just run updates - can't log in graphically or start xorg:

    Is there a way to start gdm automatically after turn on or restart?
    I have to write sudo systemctl start gdm for log in. 😕

  • @edconocerte

    I had also this problem after updating so I installed gdm and it worked!

    Did you remember to disable lightdm when enabled gdm?
    sudo systemctl disable lightdm

  • @edconocerte , as @anarch says, you can use enable/disable to make a service start when your computer boots.

    sudo systemctl enable gdm


update57 xorg29 login manager10 Posts 10Views 2813
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.