• Cant install xen hypervisor, build fails


    Hello guys. Its my first post and iam not quite sure whether this belongs in this category and not to newbie corner.
    But i try to explain my problem as accurate as i can.
    I have been trying to install xen hypervisor in order to use Pci passthrough, but I have some problems installing it.
    I first tried to install it via AUR ( “xen”) although its marked as outdated, which didnt work. Building always fails.
    It gives me this error (avoiding to make this post unnecessary long, i post everything the terminal is putting out to pastebin) : http://pastebin.com/327J22ay

    I had no luck in downloading the latest package from the xen-project Website and installing it manually either.
    I checked every dependency described in the Readme file, but it still complains about some missing python-development libraries. There aren’t any python-dev packages in the arch distros though. I’m relatively new to arch, but I remember reading that the dev-packages are installed along with the actual packages in arch. However, i am given this this error: http://pastebin.com/VWGHtA3Q

    obviously i cant do the make and make install commands then.
    I even tried what https://bbs.archlinux.org/viewtopic.php?id=210846 suggested, it didnt work either.
    It does stuff for a while and still gives me an error . The terminal output ist extremely long, but told me to look into config.log :
    http://pastebin.com/M6HNStAd

    Of course my packages are all updated, even after the lightdm issue. Using the latest Antergos release. (freshly installed it 2 days ago)

    I would greatly appreciate some ideas for convincing xen to build/install. Thanks : )

    I may ask some questions, i'm very curious.

  • @Sarimon
    hi i just tried to install and got the same errors. I know the topic is old, but did you manage to fix it?

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

  • Hi,

    checking for python... /usr/sbin/python
    checking for python version >= 2.3 ... yes
    

    I think it’s a python2 vs python3 version problem. That build thinks that /usr/bin/python is version 2 python binary, which is not. It should use /usr/sbin/python2

  • well, all the packages from AUR failed, but it’s ok, xen is a strange world for begginers. I’ll keep on testing on virtualbox and gnome boxes.

    Portergos site
    https://github.com/Portergos/portergos-iso

    Still in love with Antergos (default OS)
    I3wm

    Linux newbie since 06/2016

install81 fail18 build2 xen1 Posts 4Views 1139
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.