• Gnome 3.20 Natural Scrolling only working in Wayland


    Anybody else with the problem described in the title? I’m on a 2011 MacBook Pro if that matters?!?

    Thanks

  • Same here. and 2 finger tap is recognized as middle click while 3 finger tap is recognized as secondary click… very disturbing…

    i think that something is wrong with synaptics driver.
    Under Wayland i thinl it is using libinput insted…

    need a fix - wayland is not as smooth as X

    Thanks

  • Same problems here, no natural scrolling and no two-fingers secondary click.

  • yeah, I have the same behaviour. I edited the synaptics conf file in /etc/X11/xconf.d. You can enable natural scrolling there (see Arch Wiki), but I had to change

    Option "TapButton2" "2"
    Option "TapButton3" "3"
    

    to the opposite (changing “2” to “3” and vice versa) :astonished:

  • @vincent-clausing Thanks!
    I have done that and it worked. just thought there might be a different approach to solve this issue… just seems like a workaround and not the right way to do so.
    after all “2” is the secondary click, and not “3”.

    but it works now, so mehh :)

    thanks!

  • Great thanks! I’ve done that and it works, the natural scrolling part also with:

    Section "InputClass"
            ...
            Option "VertScrollDelta" "-111"
            Option "HorizScrollDelta" "-111"
            ...
    EndSection
    
  • I though I’d forgot what natural scrolling is. I was randomly changing options :stuck_out_tongue_closed_eyes:

    Thanks

    BTW, why wayland is so “laggy”? is it about hardware requirements or just not fine tuned/developed?

  • It should be hardware compatibility. I m on Wayland since before Xmas and so far, I find it smoother. With the launch of 3.20 it s become even better. The only “problem” I have is apps not ported to it yet…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Thanks for this guys, I was quite frustrated that Gnome 3.20 stopped recognizing my touchpad, but at least this provides an easy workaround. I also had to set

            Option "HorizTwoFingerScroll" "on"
    

    Btw, in the file 50-synaptics.conf it says to create a new file rather than modifying the original. However, when I copy the content to 49-synaptics.conf or 51-synaptics.conf, I am unable to login since my default screen cannot be found. So for now, I have just modified the original 50-synaptics.conf (I realize this might be overwritten if I make changes in the GUI).

  • After the update to Gnome 3.20, I had the problem of my Asus laptop’s touchpad losing features like disabling tap-to-click and it no longer showed up as configurable under Settings > Touchpad.

    I was able to fix it this way…

    sudo pacman -S xf86-input-libinput
    sudo pacman -R xf86-input-synaptics
    sudo mv /etc/X11/xorg.conf.d/50-synaptics.conf ~/
    

    Reboot.

    The Gnome team has moved support to libinput and dropped synaptics. Until I removed/moved the 50-synaptics.conf file my touchpad would not work at all. Now it all works again as desired and palm detection and other things seem to work better too.

  • @brainlid Thank you! This works for me also. Pointer acceleration feels a bit different, but I guess I will get used to it, decreasing the touchpad speed helped somewhat.

  • Thanks a lot for the info @brainlid that was awesome, removed the hacks and now everything’s working smoothly.

  • Just a heads up, with libinput, flick scrolling is not working (or technically, I think it is working, but not currently available, at least not in application such as Chromium). The minimum mouse pointer speed is also different from synaptics, so moving the pointer small distances was tricky for me, it kept stopping and jumping to a new positions. With the synaptics drivers, this is ameliorated by setting a lower MinSpeed option (and then also higher AccelFactor). Sooooo… I’m back on the synaptics drivers now =) (On the other side, trackpoint scrolling works out of the box with libinput, but I prefer flick scrolling with the touchpad)

  • @brainlid Perfect. Touchpad is working as i want it to work :) Thank you

Posts 14Views 6010
Log in to reply