• Antergos Installer error - metalinks


    Hello

    Today I tried to reinstall system but Cnchi seems to be broken.
    For now I can’t install Antergos again and I’m without system…

    Is there any workaround or I have to wait for Cnchi update?

    0_1460216946196_Screenshot from 2016-04-09 15-45-42.png

  • Hello everyone,

    I encountered the same problem. I tried to install on 2 different machines (vbox and laptop). Here is the bottom part of /tmp/cnchi.log

    2016-04-09 18:16:15 [INFO] slides.py(242) manage_events_from_cb_queue(): Creating the list of packages to download...
    2016-04-09 18:16:16 [ERROR] metalink.py(131) create(): Can't resolve these dependencies: gtk3<3.20 webkit2gtk<2.12 
    2016-04-09 18:16:16 [ERROR] download.py(145) create_metalinks_list(): Error creating metalink for package lightdm-webkit2-greeter. Installation will stop
    2016-04-09 18:16:16 [ERROR] download.py(177) create_metalinks_list(): Can't create download set. An exception of type InstallError occured. Arguments:
    ('Error creating metalink for package lightdm-webkit2-greeter. Installation will stop',)
    2016-04-09 18:16:16 [ERROR] process.py(129) run(): 'Cannot create download package list (metalinks). Check log output for details.'
    2016-04-09 18:16:16 [ERROR] process.py(133) run(): Traceback (most recent call last):
    2016-04-09 18:16:16 [ERROR] process.py(133) run():   File "/usr/share/cnchi/cnchi/installation/process.py", line 94, in run
        self.create_metalinks_list()
    2016-04-09 18:16:16 [ERROR] process.py(133) run():   File "/usr/share/cnchi/cnchi/installation/process.py", line 84, in create_metalinks_list
        raise misc.InstallError(txt)
    2016-04-09 18:16:16 [ERROR] process.py(133) run(): misc.extra.InstallError: 'Cannot create download package list (metalinks). Check log output for details.'
    2016-04-09 18:16:17 [INFO] connectionpool.py(207) _new_conn(): Starting new HTTP connection (1): build.antergos.com
    2016-04-09 18:16:17 [DEBUG] connectionpool.py(386) _make_request(): "GET /hook?cnchi=2580656b5c7be34e4144a3129a95e421&install_id=79060&result=False HTTP/1.1" 200 None
    
    When i run **pacman -Syu** it gives me this:
    looking for conflicting packages...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: light-locker-settings: installing python-gobject (3.20.0-1) breaks dependency 'python-gobject<3.20'
    :: lightdm-webkit2-greeter: installing webkit2gtk (2.12.0-2) breaks dependency 'webkit2gtk<2.12'
    :: lightdm-webkit2-greeter: installing gtk3 (3.20.2-1) breaks dependency 'gtk3<3.20'
    

    I guess when I remove individual packages it will break dependencies of cnchi.

  • @voepew Cnchi, by nature, can not breake anything. It is merely an Arch installer.

    Arch mirrors are experiencing some difficulties right now. Retry later.

  • But it’s not a problem with Arch mirrors. It’s problem with Antergos. For now it’s not possible to install system with DE and update already installed systems.

  • Is it possible to modify the list of packages that are about to be installed? I want to use gnome so I would replace lightdm with gdm anyway.

  • The same to me, I got the same error during installation (x64, XFCE with extra packages).

  • It will fail with all DE in installer except BASE installation.

  • I tried once again, this time without any extra packages - the same result. I am providing the log

    2016-04-09 22:38:39 [DEBUG] select_packages.py(109) create_package_list(): Packages selected
    2016-04-09 22:38:39 [DEBUG] pac.py(113) initialize_alpm(): ALPM initialised with root dir / and db path /var/lib/pacman
    2016-04-09 22:38:40 [INFO] slides.py(242) manage_events_from_cb_queue(): Aktualizowanie multilib bazy danych
    2016-04-09 22:38:40 [INFO] slides.py(242) manage_events_from_cb_queue(): Pobieranie listy pakietów...
    2016-04-09 22:38:40 [INFO] slides.py(242) manage_events_from_cb_queue(): Tworzę listę pakietów do pobrania
    2016-04-09 22:38:42 [ERROR] metalink.py(131) create(): Can't resolve these dependencies: gtk3<3.20 webkit2gtk<2.12 
    2016-04-09 22:38:42 [ERROR] download.py(145) create_metalinks_list(): Error creating metalink for package lightdm-webkit2-greeter. Installation will stop
    2016-04-09 22:38:42 [ERROR] download.py(177) create_metalinks_list(): Can't create download set. An exception of type InstallError occured. Arguments:
    ('Błąd podczas tworzenia metalinku dla pakietu lightdm-webkit2-greeter. Instalacja nie będzie kontynuowana.',)
    2016-04-09 22:38:42 [ERROR] process.py(129) run(): 'Nie można utworzyć listy pakietów do pobrania. Sprawdź plik dziennika, aby uzyskać szczegółowe informacje.'
    2016-04-09 22:38:42 [ERROR] process.py(133) run(): Traceback (most recent call last):
    2016-04-09 22:38:42 [ERROR] process.py(133) run():   File "/usr/share/cnchi/cnchi/installation/process.py", line 94, in run
        self.create_metalinks_list()
    2016-04-09 22:38:42 [ERROR] process.py(133) run():   File "/usr/share/cnchi/cnchi/installation/process.py", line 84, in create_metalinks_list
        raise misc.InstallError(txt)
    2016-04-09 22:38:42 [ERROR] process.py(133) run(): misc.extra.InstallError: 'Nie można utworzyć listy pakietów do pobrania. Sprawdź plik dziennika, aby uzyskać szczegółowe informacje.'
    2016-04-09 22:38:43 [INFO] connectionpool.py(207) _new_conn(): Starting new HTTP connection (1): build.antergos.com
    2016-04-09 22:38:43 [DEBUG] connectionpool.py(386) _make_request(): "GET /hook?cnchi=2580656b5c7be34e4144a3129a95e421&install_id=80164&result=False HTTP/1.1" 200 None
    
    
  • This problem is because gnome 3.20 was released on stable repository from arch, and the lightdm don’t was updated yet, to get support for the new gtk3.20, soon it will be fixed.
    Any installation with a DE that is gtk based will have this problem.

  • KDE isn’t GTK based and also can’t be installed.

  • Update: Try vanilla install with bash (don’t select any presets after DE selection). Works for me.

    Update 2: Just tried reinstalling with the same installer I made a few weeks ago: no problems with metalinks (devs fixed the wonky lightdm/other packages that were giving grief. Be free and install! Make the Antergos!

  • I hosed my gnome system, Could someone send me a heads up when it:s ok to do a complete reinstall.

    Thanks in advance
    Montana

  • Same here, I got the same error during installation whit KDE, XFCE and GNOME, whit and without extras…

  • you can still install the base ,and after that install the desired desktop via console

  • Yes, it’s fixed but it’s still not possible to install Antergos with DE. Reinstalling lightdm-webkit2-greeter didn’t help.

  • Just tried again, still could not install.
    I got a conflict for light-locker-settings, namely python-gobject<3.20

  • https://aur.archlinux.org/packages/lightdm-webkit2-greeter/
    Finally new version is visible in repository so soon we will be able to install it - hope so!

  • This post is deleted!
  • @ehraan said in Antergos Installer error - metalinks:

    you can still install the base ,and after that install the desired desktop via console

    Thanks for the advice, Now in the process of reinstalling everything.
    Thanks Again
    Montana

Posts 31Views 9899
Log in to reply