• Impossible update for dependencies issues with lightdm-webkit2-greeter


    @dtschmitz try to remove the conflicting packages, be sure to stop and disable lightdm and then enable gdm via systemctl. Not elegant but worked so far for me.

  • It was the same with me, I unchecked ‘webkit2gtk’ and ‘gtk3’ and proceeded with the upgrade. My mistake was in restarting, and as you can guess with no lightdm-webkit2-greeter no way to access Antergos. I am using Manjaro to post this. Going to try to install ‘lightdm-webkit2-greeter’ via tty?

  • @vincent.clausing Hi Vincent, please, can you post your solution like a step by step method? I thank you.

  • @humboldt please, why you couldn’t wait a few to get it solved by developers?

  • Ok. Sorry.

  • We don’t break this masterpiece of distro ☺

  • I would just wait a few days. Also gdm did really break my installation. I could only boot every 10th time into desktop with it. don’t know why. don’t want to reproduce.

  • @albert Hi albert, what I posted was no solution for the problem, just hoped that the other guy can avoid crashing. Just a bit of patience…

  • For those who need to access and cannot wait for the ultimate solution , you can install thru tty terminal sddm , steps :

    sudo pacman -S sddm
    systemctl disable lightdm.service
    systemctl enable sddm.service
    systemctl start sddm.service
    
    

    yeah it’s ugly to see but it works.
    Cheers

  • @vincent.clausing Ok, Vincent, I thank you. We hope in the good work of the developers.

  • @beefeeb It doesn’t work for me 😟
    It continues the same dependency problem

  • Hi guys,
    got stuck with the same problem.
    i removed (dumb me :) ) the lightdm-webkit2greeter and updated the system. after that i could not reinstall it ( also dumb i know :D )
    so i need my notebook tonight so i tried around a bit.
    1 workaround that worked (for me except!):
    after removing lightdm-webkit2-greeter i updated the system, then i tried installing the lightdm-webkit2-greeter from the AUR (ver 2.0.0.2)
    that didn’t worked also.
    so edit the PKGBUILD file as follows:
    change the following line

    depends=('lightdm' 'webkit2gtk>=2.10' 'webkit2gtk<2.12' 'gtk3>=3.18' 'gtk3<3.20')
    
    

    to

    depends=('lightdm' 'webkit2gtk>=2.10' 'webkit2gtk<2.13' 'gtk3>=3.18' 'gtk3<3.21')
    

    after that i could update and start my system with a working X-Server ;)

    cheers
    m0e

  • @anderson.felix83
    that doesn’t solve the dependencies problem rather it gives you a way to access your system bypassing lightdm , and using sddm until the bug is solved. On github , wyn10 said a solution is already shipped .

  • @beefeeb Sorry and thanks!

  • I think this is the same problem that is preventing me from installing Antergos. I checked the log and got this

    [ERROR] pac.py(155) finalize_transaction(): Can't finalize alpm transaction: transaction preparation failed, pm_errno 47 (could not satisfy dependencies), [('lightdm-webkit2-greeter', 'webkit2gtk<2.12', None), ('lightdm-webkit2-greeter', 'gtk3<3.20', None)]
    
  • @m0e
    I have the same problem.

    I unistalled lightdm-webkit-greeter (with yaourt), then after rebooting login in graphical mode wasn’t possible.
    I’ve tried this: I changed in the file /etc/lightdm/lightdm.conf

    the line:

    greeter-session=lightdm-webkit2-greeter
    

    into the line:

    greeter-session=lightdm-webkit-greeter
    

    Now I can login in the graphical mode (MATE) but it doesn’t looks well (because of lightdm-webkit).


    So I’m waiting for a/the real solution too.

  • @ron thats what i tried first but didn’t worked for me so i figured out my silly “hack”

  • Confirm this, with my Antergos mate. Unchecked both of the “problematic” updates and proceed with all the upgrade.

  • Hi ! how many time takes this type of problems actually ? i installed AntergOS to try linux world and during the first install (from pacman-boot.log) :

    "2016-04-09 18:28:47 [DEBUG] pac.py(113) initialize_alpm(): ALPM initialised with root dir / and db path /var/lib/pacman
    2016-04-09 18:28:48 [INFO] slides.py(242) manage_events_from_cb_queue(): Crée la liste de paquets à télécharger...
    2016-04-09 18:29:40 [ERROR] metalink.py(131) create(): Can't resolve these dependencies: python-gobject<3.20 
    2016-04-09 18:29:40 [ERROR] download.py(145) create_metalinks_list(): Error creating metalink for package light-locker-settings. Installation will stop
    2016-04-09 18:29:40 [ERROR] download.py(177) create_metalinks_list(): Can't create download set. An exception of type InstallError occured. Arguments:
    ("Erreur à la création d'un métalien pour le paquet light-locker-settings. L'installation va s'arrêter",)
    2016-04-09 18:29:40 [ERROR] process.py(129) run(): 'Cannot create download package list (metalinks). Check log output for details.'"
    

    AntergOS tell us that is a stable system, perfect for noobs but 10 minutes after the first boot (in USB live) i have this message lol ^^! Am I unlucky or is it same often ?

    Regards.

  • @julien.baylet said:

    i installed AntergOS to try linux world

    Cheers for jumping in.

    AntergOS tell us that is a stable system, perfect for noobs but 10 minutes after the first boot (in USB live) i have this message lol ^^! Am I unlucky or is it same often ?

    No you’re not unlucky, a package was upgraded and caused breakage for it’s missing dependencies . Antergos follows Arch Linux for updates, which means for you as the end user to be able to read the Arch Wiki and apply it’s documentation to maintain your system and work around issues like this one. I do suggest something Ubuntu and it’s derivatives if you want to get a hang with Linux without reading a big wiki.

Posts 84Views 41100
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.