• Like 8

    Impossible update for dependencies issues with lightdm-webkit2-greeter


    Today I happen to upgrade the system by yakuake, but I got the following error and can’t update anything.
    On pamac the same, at pc switch on there were over 60 updates available.
    It’s italian but I suppose very easy to understand.

    //:: Aggiornamento del sistema in corso...
    risoluzione delle dipendenze in corso...
    ricerca dei pacchetti in conflitto in corso...
    errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
    :: lightdm-webkit2-greeter: l'installazione di webkit2gtk (2.12.0-2) interrompe la dipendenza 'webkit2gtk<2.12'
    :: lightdm-webkit2-greeter: l'installazione di gtk3 (3.20.2-1) interrompe la dipendenza 'gtk3<3.20'```
    

    Any suggestion?

    Antergos KDE + Antergos Gnome + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • Like 3

    Same here, but XFCE install. Here’s what I get:

    could not satisfy dependencies:
    light-locker-settings: requires python-gobject<3.20
    lightdm-webkit2-greeter: requires webkit2gtk<2.12
    lightdm-webkit2-greeter: requires gtk3<3.20

    Any help will be appreciated. And shouldn’t the update manager handle these problems automatically?

    Thanks.

  • Like 1

    @Jeffrey-Needle yes, me on kde

    Antergos KDE + Antergos Gnome + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • Like 0

    Well it seems lightdm needs somewhere an old package version. But why? Also i dont want to switch to gdm on gnome. Because i did this last week. And because of it my system did not start anymore. Could never get into the loginscreen.

  • Like 2

    Don’t do this, ldm broke.
    If you want to upgrade the other packages before the dependencies are fixed, you can use the --ignore options for the three packages in question.

  • Like 1

    Same here, antergos gnome, we I get upgrade with pacman -Syu, light-locker just break here.

  • Like 1

    I have the same pacman error message… any help will be appreciated…


    Fer

  • Like 1

    error: failed to prepare transaction (could not satisfy dependencies)
    :: light-locker-settings: installing python-gobject (3.20.0-1) breaks dependency ‘python-gobject<3.20’

    ditto ^^ will install other packages with --ignore

  • Like 1

    Same problem here, can’t update anything even on Live DVD.

    Edit: Switching to gdm and removing lightdm is a workaround.

  • Like 1

    same here on antergos gnome :(

  • Like 1

    also I have the same problem when trying to update the system

  • Like 1

    subscribing and awaiting further instructions.

    Yeah, i thought it odd to suddenly have 129 packages in my upgrade queue ;)

  • Like 3

    https://github.com/Antergos/antergos-packages/issues/94

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Like 1

    I have the same problem as well, I’m on gnome using gdm and even when I try to uninstall lightdm (which I should have done before), it crashes too.

  • Like 1

    Same problem here on XFCE. I unticked all and then installed all the updates that worked and now Package Manager and Update Manager crashes. I have tried through terminal with same issues on remaining updates having dependency issues.

  • Like 0

    @pedro.a.1smr it lets me install gdm; but systemctl enable gdm crashes
    ideas?

  • Like 0

    same here on antergos gnome

  • Like 0

    same here with example

    Error

    Failed to prepare transaction

    could not satisfy dependencies:
    light-locker-settings: requires python-gobject<3.20
    lightdm-webkit2-greeter: requires webkit2gtk<2.12
    lightdm-webkit2-greeter: requires gtk3<3.20

    **How to fix in layman terms? thanks in advance!
    **

  • Like 1

    Please add likes(hearts) to the post to avoid the need to make a new response for just confirming it.

  • Like 2

    I suppose it’s a problem developers can easily solve. Just need to wait and let them know, and @Wyn already did it ;)

    Antergos KDE + Antergos Gnome + Windows 10
    Motherboard Asus P8H67-M LE - CPU: Intel Core™ i5-2400 CPU @ 3.10GHz - RAM 10 Gb
    Samsung EVO 250 Gb Ssd + WD HDD 2 Tb

  • Like 2

    @dtschmitz try to remove the conflicting packages, be sure to stop and disable lightdm and then enable gdm via systemctl. Not elegant but worked so far for me.

Posts 84Views 15256
Log in to reply