• Grub issue


    Hello new to arch linux and i gotta say i love it so far

    My problem is with grub i successfully installed antergos but the only way to boot is if i manually select to boot from it going into bios/boot options i have read and read here but havent found a good answer plus i have tried some suggestions already i just dont wanna have to install again is there a guide or something addressing this problem already thanks

  • So if I understand you correctly, your saying that in order to boot into the system, you have to boot into BIOS, then choose from within BIOS to boot to your system?

    So I guess one of the ways that your going to have to find out if you have GPT or not is with
    sudo su
    then
    parted /dev/sda print
    and that will also help tell you where your flags are.

    Dual boot or not?
    You mentioned BIOS (but not UEFI), therefore, https://wiki.archlinux.org/index.php/Grub#BIOS_systems

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I think this might be helpful (hopefully)

    grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub --recheck
    then
    grub-mkconfig -o /boot/grub/grub.cfg
    then
    mkinitcpio -p linux

    By the way, try to use the correct coding for input.
    No need to use pictures as pictures don’t really provide all that could be seen.
    On the TOP RIGHT corner of you dialogue box, there is a COMPOSE with ?
    There is information that will tell you what to use for code tags.
    Scroll to Inline code with backticks

    PS: If the above code to input has not helped to install grub to the correct location, post here again.
    I will help as far as I am knowledgeably able to.

    Instead of the parted output (sorry, that’s my bad), can you put the output of
    ls -l /dev/disk/by-path
    and / or maybe even
    ls -l /dev/disk/by-label

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • this is what i get with the first line of command:

    $ sudo grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=grub --recheck
    Installing for x86_64-efi platform.
    grub-install: error: /boot doesn't look like an EFI partition.
    
    Disk /dev/sda: 698.7 GiB, 750156374016 bytes, 1465149168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: F6691AF3-10B2-4394-B3E3-60BCAAAF54A8
    
    Device          Start        End   Sectors   Size Type
    /dev/sda1        2048     821247    819200   400M Windows recovery environment
    /dev/sda2      821248    1353727    532480   260M EFI System
    /dev/sda3     1353728    1615871    262144   128M Microsoft reserved
    /dev/sda4     1615872  708352616 706736745   337G Microsoft basic data
    /dev/sda5  1408768000 1410424831   1656832   809M Windows recovery environment
    /dev/sda6  1410424832 1411141631    716800   350M Windows recovery environment
    /dev/sda7  1411141632 1465137151  53995520  25.8G Microsoft basic data
    /dev/sda8   708352617  727883866  19531250   9.3G Linux filesystem
    /dev/sda9   727883867 1408767999 680884133 324.7G Linux filesystem
    
    Partition 8 does not start on physical sector boundary.
    Partition 9 does not start on physical sector boundary.
    Partition table entries are not in disk order.
    
    
    
    
    Disk /dev/sdb: 3.8 GiB, 4051697664 bytes, 7913472 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x77838fbe
    
    Device     Boot Start     End Sectors  Size Id Type
    /dev/sdb1  *        0 3511295 3511296  1.7G  0 Empty
    /dev/sdb2         224   63711   63488   31M ef EFI (FAT-12/16/32)
    

    ran the command again but with path to /boot/efi this is what i got

    [[email protected] ~]$ sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=grub --recheck
    [sudo] password for quechon: 
    Installing for x86_64-efi platform.
    grub-install: error: efibootmgr: not found.
    
  • let me try to explain a little better i can boot in antergos it installs successfully
    my problem is that when im booting my laptop it goes straight to booting windows, now if i want to get to antergos i have to press f9 to see the boot point menu the i see the options of os boot manager which is windows and antergos_grub

    grub is installed it just doesnt display at boot just when going in to boot menu in bios

  • solved the problem thanks for the help

  • I see it’s been resolved, but I want to add some extra info that could help in the future:

    Sometimes you need to go into your BIOS and change the boot order, depending on how your system is set up. Happy Linuxing.

  • It has nothing to do with bios here a link for future reference http://askubuntu.com/questions/244261/how-do-i-get-my-hp-laptop-to-boot-into-grub-from-my-new-efi-file

    That solve my problem thanks for the help

  • @quechon it was very hard to find a solution to change boot order in my very clean antergos intsll with an W10, anyways, i had to cmpile grub customizer but what i was trying to find was a commandline order to do so…

boot155 Posts 10Views 1504
Log in to reply