• \[SOLVED\] Wi-Fi problem - Hardware Disabled


    You are very welcome, but don’t speak too soon, it’s not fixed yet.

    And this may require more help than I have expertise for, especially for Gnome, since I use KDE.

    One of the Antergos experts should be online soon, Dustin, and may have more answers.

    And I see @pseudonym is online and has some answers for you too. I was also looking at the link he is recommending, but I couldn’t find the related info for ASUS.

    Might need to look for Dustin as well.

    edit: At second glance, since your network adapter is: Qualcomm Atheros AR9485 Wireless Network Adapter
    that information on that link may help afterall.

    As @pseudonym suggested, give it a try.

    >>The difference would be ASUS instead of ACER:

    [~]# sudo modprobe -r asus-wmi
    [~]# sudo nano /etc/modprobe.d/ath9.conf

    #Thereafter I just went ahead and added:

    options ath9k nohwcrypt=1

  • @“pseudonym”:3v367ekg said:

    could you try the solution on that link?

    [https://bbs.archlinux.org/viewtopic.php?pid=1230162][0]">[https://bbs.archlinux.org/viewtopic.php?pid=1230162][1][/quote:3v367ekg]

    This doesn’t work for me - created file /etc/modprobe.d/ath9.conf and its content but after reboot nothing hasn’t changed.

    [0]: <a href=
    [1]: https://bbs.archlinux.org/viewtopic.php?pid=1230162

  • Thanks all again. I solved this problem (well, for now everything is working fine - I can connect and use wireless) by reviewing Arch Wiki: [https://wiki.archlinux.org/index.php/Wireless_Setup#ASUS][0]">[https://wiki.archlinux.org/index.php/Wi][1] … Setup#ASUS

    Created new file [b:1m8v9una]/etc/modprobe.d/asus_nb_wmi.conf[/b:1m8v9una] and added line:

    options asus\_nb\_wmi wapf=1
    

    By the way, how do I mark this post as SOLVED?

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Wi

  • Well, praise God! I was praying!

    To mark it solved, go back to your original post and edit it. The top of the edit screen says subject. Type in solved there.

  • @“arvislacis”:2joh4f17 said:

    …I solved this problem (well, for now everything is working fine - I can connect and use wireless) by reviewing Arch Wiki: [https://wiki.archlinux.org/index.php/Wireless_Setup#ASUS][0]">[https://wiki.archlinux.org/index.php/Wi][1] … Setup#ASUS

    Created new file [b:2joh4f17]/etc/modprobe.d/asus_nb_wmi.conf[/b:2joh4f17] and added line:

    options asus\_nb\_wmi wapf=1
    

    [/quote:2joh4f17]

    Hey guys this one worked for me too, since I’ve installed Antergos with Gnome, the WiFi didn’t work without this.
    Thanks!!!
    On my way becoming an

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Wi

  • By the way if WiFi hardware doesn’t start, try to shutdown the laptop, remove the battery for a while, replace the battery and boot the laptop, then the WiFi should/could start again…

Posts 26Views 21201
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.