Installed Antergos using 2016.03.20 ISO with GNOME DE

  • LightDM:

    • Issue: LightDM does not remember default session
    • Description: After first installation I tried to use GNOME on Wayland session to see if it worked by default; it didn’t so I switched to standard GNOME session. On subsequent logins/reboots it would always default to GNOME on Wayland despite GNOME now being default.
    • What have you tried?: Confirming ~/.dmrc and /var/lib/AccountsService/users/username are set to gnome. Tried user_xsession.py
    • Workaround: Enable GDM
  • GRUB:

    • Issue: GRUB_DEFAULT=n is not respected
    • Description: Installed linux-zen and wished for GRUB to use it as the default menu entry, so I changed GRUB_DEFAULT to the correct menu entry but it continued using the default kernel(first menu entry?).
    • What have you tried?: Attempted changing GRUB_DEFAULT to the correct entry and even specified the menu title but GRUB continued using the default kernel(first menu entry?).
    • Workaround: Disabled /etc/grub.d/10_antergos and enabled /etc/grub.d/10_linux with
      sudo chmod -x /etc/grub.d/10_antergos ; sudo chmod +x /etc/grub.d/10_linux
      GRUB_DEFAULT works as expected afterwards

Just thought I’d mention these in case anyone else experiences these issues, if I missed something or if anyone knows the proper fix. I’m perfectly fine with the workarounds.