• Like 0

    Installing Plymouth - syntax error: unexpected end of file


    Hello all. I’m trying to install plymouth and I keep getting this error. Is there actually something wrong with the package in the repo or what? I’m not sure how this particular error would leave my machine or configuration at fault as it appears something is wrong with the installation script itself. I’ve tried searching both Google and the forums and can’t find anything similar to this problem.

    I’m just looking to make the interface more user friendly for myself, and a good looking boot screen was one of the things I wanted to try and install, hence plymouth. If we can’t figure this out, it’s not a huge deal. I rarely restart my machine anyways. I would like to try and fix this problem if possible though so I can give plymouth a try.

    Thanks in advance for any input you have regarding this issue, and please let me know if you need any other logs. I did not see anything relevant in my system logs/journal to post.

    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) plymouth-0.9.2-4
    
    Total Installed Size:  2.01 MiB
    
    :: Proceed with installation? [Y/n] Y
    (1/1) checking keys in keyring                     [######################] 100%
    (1/1) checking package integrity                   [######################] 100%
    (1/1) loading package files                        [######################] 100%
    (1/1) checking for file conflicts                  [######################] 100%
    (1/1) checking available disk space                [######################] 100%
    :: Processing package changes...
    (1/1) installing plymouth                          [######################] 100%
    /tmp/alpm_3yfYnX/.INSTALL: line 6: syntax error: unexpected end of file
    /usr/bin/bash: post_install: command not found
    error: command failed to execute correctly
    Optional dependencies for plymouth
        ttf-dejavu [installed]
    
    
  • Like 0

    so what does
    /tmp/alpm_3yfYnX/.INSTALL say at line 6?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Like 0

    Sorry. I was able to fix this last night. It turns out there was a more up-to-date version of the package in the AUR repos and it installed fine through yaourt. I could have sworn I tried that before I posted here, but apparently not.

    I haven’t gotten plymouth to actually work yet but if I can’t get it by tonight that’ll be a separate topic.

  • Like 0

    no problem. :)

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

Posts 4Views 598
Log in to reply