• Monitor no longer power's off with screen saver.


    I used to have a DVI attached monitor which correctly blanked and powered off from inactivity.

    I recently upgraded my monitor and switch to DisplayPort. I now observe this:

    1. The screen blanks as expected.
    2. The monitor powers off for about 2 seconds.
    3. The monitor powers back on but stays blank with just the mouse cursor showing… it will stay like this for hours until I log back in.

    I have been just turning the monitor off when I leave. Yesterday I did a full clean reinstall of Antergos and GNOME and still have the same problem.

    If the hardware matters:
    Monitor: BENQ 27" GW2765HT 2560x1440 WQHD Resolution.
    Card: GIGABYTE GeForce GTX 970 4GB G1 card
    Driver: Proprietary Nvidia drivers - nvidia 361.28-4

  • Supposing you re under lightDM, i d look into 3 things.

    1. Is the screensaver disabled in the Power Settings in Gnome s System Settings?
      If yes, is the Light Locker configured correctly and enabled?
    2. If I wasn t successful, I d try to see if the problem is solved using the GDM instead. In this case you can use the native Gnome Power Settings and disable Lightlocker.
    3. Install theTurn off Displayand switch the monitor off manually (unfortunatelly not compatible under Wayland).
      https://extensions.gnome.org/extension/897/turn-off-display/

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Thanks for the suggestions… last week I was using GDM when I replaced the monitor originally, since I reinstalled yesterday I’m using LightDM (just because it works again).

    I’ll start with Gnome Power Settings first and see how that goes.

  • That s all right:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Setting Gnome Power Settings “Blank Screen” to 15 minutes… did nothing. After an hour the desktop was still showing. I assume set that back to “Never”

    I try to fiddle with Light Locker again before switching to GDM.

  • Under lightDM, the native Gnome s power settings don t work, anyway. So, it is normal that your screen didn t go blank after 15 mins. You should just make sure that they are disabled (set to NEVER) so they don t interfere with light locker.
    Since it was already set to NEVER, I don t think you will have much luck fiddling with Light Locker again (I can see a note saying “depends on hardware support”) .
    Personally, I was happier when i was using LightDM+Turn off display extention. Unfortunatelly, Wayland doesn t support the latter. So, GDM is a must for me, though uglier, heavier, needing Caffeine to disable screensaver.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

Posts 6Views 977
Log in to reply