• nvidia-installer [ALPHA]


    Hi,
    Yes, you’re right. As you can see here
    https://www.archlinux.org/packages/community/x86_64/bumblebee/files/
    /etc/bumblebee/xorg.conf.nvidia is from the bumblebee package.

    But here
    https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/bumblebee
    you can see how that file is added in the backup array of the pkgbuild.

    From https://wiki.archlinux.org/index.php/PKGBUILD#backup

    backup

    An array of files that can contain user-made changes and should be preserved during upgrade or removal of a package, primarily intended for configuration files in /etc.

    Files in this array should use relative paths without the leading slash (/) (e.g. etc/pacman.conf, instead of /etc/pacman.conf).

    When updating, new versions may be saved as file.pacnew to avoid overwriting a file which already exists and was previously modified by the user. Similarly, when the package is removed, user-modified files will be preserved as file.pacsave unless the package was removed with the pacman -Rn command.

    See also Pacnew and Pacsave files.

    That’s why the package didn’t overwrite your changes. ;)

  • @karasu said in nvidia-installer [ALPHA]:


    That’s why the package didn’t overwrite your changes. ;)

    Got it. Everything is clear now. Thanks for exhaustive info.

  • @karasu said in nvidia-installer [ALPHA]:


    I will use your pipes solution, thank you!

    I saw adjusted source on Github. It’s midnight here, will test it tomorrow.

    G’night

  • @karasu

    nvidia-installer 0.0.8

    All tests and checks passed successfully, without any exclusion. The full report is on Paste2 here.

    For me, it is ready for Production.

  • I tested nvidia-installer 1.0.0 in three other freshly installed distros - vanilla Arch, Bluestar, Apricity. The last two are true derivatives of Arch Linux - they directly use unmodified Arch repos.

    As expected, nvidia-installer smoothly works in all three. Installs, configures, repairs Bumblebee and proprietary Nvidia driver everywhere. It’s a reliable, universal, useful tool.

    Regards

  • @just I was reading up on Bumblebee and Nvidia-Prime for Ubuntu a little while back. Does this tool take into account that some people are using GDM over the stock lighdm that Antergos uses, or is it not important?

  • @stefanoume12 said in nvidia-installer [ALPHA]:

    …Does this tool take into account that some people are using GDM over the stock lighdm that Antergos uses, or is it not important?

    No, nvidia-installer doesn’t take into account the display manager in use - because it does not important. It is not important not only in Arch, but also on any other platform - Debian, Fedora, Suse, Mandriva, Gentoo. I install Bumblebee on all of them without even thinking about display manager.

    Bumblebee and proprietary Nvidia driver (or nouveau) work inside a running X session. When you’re at display manager login screen, there’s no active X session.

    Bumblebee is independent from display manager and is not related to it in any mode.

  • I’d advise you to put some sort of readme of the arguments to pass when executing the nvidia-installer file because I forgot to do that and ended up with a black screen.

    I have since fixed it by finding out the bumblebee argument to pass. Now GDM will not let me login to a GNOME X11 environment, just Wayland. As in, after logging in… It sends me back.

    EDIT: Scratch that, now Wayland completely freezes my system.

  • That’s why its testing was discussed publicly, in the forum - to involve as much testers as possible. I tested it on Dell and Acer laptops, with GT 555M, 650M, 750M cards.

    Installer can’t check or modify BIOS settings. If the BIOS controls two GPUs, it’s up to user to set it in the correct state prior to installing Bumblebee.

    Installer doesn’t check that the card is actually of the Optimus type. It’s to user to know it.

    The job done by nvidia-installer is described in AnteWiki Bumblebee article. Read it for more info.

    To get a generic help:

    nvidia-installer --help
    

    Once the BIOS is in the correct state, and you’re sure to have the Optimus card, make a dry run:

    sudo nvidia-installer --test --bumblebee
    

    Nothing will be changed in the system. Installer will display all changes it would apply. Check the packages it is about to install. If you’re satisfied, install Bumblebee:

    sudo nvidia-installer --bumblebee
    

    It works in different distros and on all my hardware. I can’t test it on hardware that I don’t have.

  • I totally knew it was testing, It looked like it actually worked when I was able to login to a wayland session and my dmesg displayed that the correct driver loaded and I was very pleased with that result.

    I think we can keep this in mind on my Asus Laptop.

  • @stefanoume12 said in nvidia-installer [ALPHA]:

    …on my Asus Laptop.

    Oh no! I avoid Asus at all costs. They don’t accept any rational approach, live on their own, and refuse any control from a human side. I don’t work with Asus, sorry.

  • @just No problem, I am able to get back to a working state where I can work as normal without the GPU.

    Oddly enough, it works for a little bit before going kaput.

    Do you mind sending a Dell/Acer Model number where the tool actually worked? Just to keep my eye out for them.

  • @stefanoume12 said in nvidia-installer [ALPHA]:

    …I was able to login to a wayland session…

    Wayland may be a root of the problem. Bumblebee was developed and is supposed to run on X window server, not on Wayland. AFAIK, it is not ported to Wayland (yet?). I tested nvidia-installer on pure X only, and never on Wayland.

  • For a time, I was only able to login to wayland because the X server would crash and throw me back into GDM (aka login loop).

    Oddly enough, I am now loaded in a GNOME session on X and the GPU is working just fine. Sensors were detected in the Nvidia X server settings (also run with optirun)

    By the way, thanks for sticking around here.

    Edit: We’ve got success. Hopefully this will continue to work across reboots0_1485382324714_Screenshot from 2017-01-25 17-11-10.png

  • I bought a new Clevo laptop P650, kaby lake, GTX 1060.
    When I do “nvidia-installer -test”, it says my GPU isn’t supported.
    But I was able to do “nvidia-installer -b” and it installs the driver and bumblebee.
    The problem is that I can’t boot anymore, I’m stuck at the loading screen in text mode.

    Is there a way to revert to the previous config ?
    I think the installer removed conflicting drivers (nouveau), is there a way to boot in console mode and run the installer to install nouveau back?

    I was also wondering what about bios settings. I only have 2 settings: MSHybrid and Discrete. By default it was MSHybrid, so I guess Optimus is enabled. Should I keep it this way?

  • Hi,

    nvidia-installer -n restores nouveau drivers.

    Sadly, as you can’t boot into your installation, you’ll have to use a livecd/usb, then mount your root filesystem and finally chroot to your installation with arch-chroot. Then you’ll be able to run nvidia-installer -n

    https://wiki.archlinux.org/index.php/change_root

    If you have any doubts please ask.

  • @Syl If the computer is not completely dead, and you’re comfortable with terminal, it should be possible to boot into the pure bash shell, without DE | GUI.

    Simply add to the boot line

    systemd.unit=multi-user.target
    

    These strange wording is similar to the good old run level 3 in Arch. Instead of trying to recall and to type them in, it is still possible to simply add 3 to the boot parameters.

    Login to bash with the user name and password. Network connection will be functional. nouveau may be installed with:

    sudo pacman -Syu xf86-video-nouveau
    
  • ok, thanks to both of you, I’ll try that this evening.

  • @Syl said in nvidia-installer [ALPHA]:

    I bought a new Clevo laptop…

    I’m unfamiliar with Clevo hardware. Two months ago another person was experiencing a strange behaviour on it. It even seemed that his Clevo computer has two Nvidia cards, and no Intel GPU. I never seen such unusual hardware configuration.

  • @just SLi maybe?

    I’d say mine is pretty “standard”.
    https://www.pcspecialist.co.uk/notebooks/defianceIII-15/

    It has an integrated intel GPU and a nvidia GTX 1060. I wasn’t sure if the nvidia was used during the install (I couldn’t install Manjaro, and could install Fedora, and someone mentioned Antergos was working).
    After my second failed attempt to install bumblebee manually, I reinstalled Antergos and tried nvidia-installer (because I didn’t uninstall nouveau the first time). I checked the second time and nouveau seemed to be used. Not sure about intel, but I’ll check that as well.

Posts 46Views 14840
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.