• nvidia-installer [ALPHA]


    Version 1.0 of nvidia-installer didn’t remove “nouveau” from the MODULES line in mkinitcpio.conf if present when installing nvidia or bumblebee(nvidia+intel). This has been fixed in version 1.1 (released a few minutes ago).

    Maybe that was your problem… don’t know.

  • ok, I’ll try again when AUR is updated.

    booting into a console and using “nvidia-installer -n” fixed the problem, I was able to boot again.
    even if it didn’t remove nouveau, reinstalling it seemed to have removed the proprietary drivers.

    as for the intel GPU, it uses the i915 module.

  • Hi,

    yes, nvidia-installer -n removes the proprietary drivers indeed.

    So now you must be using the Intel card.

    What I do not understand is why bumblebee is not working for you.

    Did you have the line MODULES="nouveau" in /etc/mkinitcpio.conf ? If you have it, change it to MODULES="" and then if you feel adventurous run sudo nvidia-installer -b again.

    Cheers!

  • @karasu I felt adventurous :)
    I cloned your repo and tried it again. Same error.
    “nouveau” isn’t in the file you mentioned.
    Do you need me to provide more logs?

    edit: are you sure I’m using the intel GPU with “nvidia-installer -n”, since it will install nouveau again?
    it doesn’t use the dGPU if it is installed with nouveau?
    or should I use PRIME to switch it?

    edit2: xrandr --listproviders shows only intel.

  • In bumblebee, you can use intel+nvidia or intel+nouveau.

    nvidia-installer only supports intel+nvidia, as I had many reports that it was the combination that worked most of the time.

    If you’re not planning gaming, I’d stick with only intel (restore nouveau with nvidia-installer -n).

    Then you can try to install bumblebee manually to use intel+nouveau (as intel+nvidia is not working for you).

    https://github.com/Bumblebee-Project/Bumblebee/wiki/Supported-drivers

    I have no idea how PRIME works ;)

  • thanks, I’ll stick with intel for now then. I’ll try again in a few months.

Posts 46Views 14853
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.