• Mini.iso/Xfce missing .xsession-errors


    Hi,

    First of all, thanks to the antergos team for the work and the given opportunity to install Arch without hassle.

    I have installed the mini iso (UEFI mode), then xfce4 and the wanted sotfs without any problems. I startx with xinit but the .xsession-errors is not generated. Here the ~/.xinitrc

    #!/bin/sh
    
    userresources=$HOME/.Xresources
    usermodmap=$HOME/.Xmodmap
    sysresources=/etc/X11/xinit/.Xresources
    sysmodmap=/etc/X11/xinit/.Xmodmap
    
    # merge in defaults and keymaps
    
    if [ -f $sysresources ]; then
    
    
    
    
    
    
    
        xrdb -merge $sysresources
    
    fi
    
    if [ -f $sysmodmap ]; then
        xmodmap $sysmodmap
    fi
    
    if [ -f "$userresources" ]; then
    
    
    
    
    
    
    
        xrdb -merge "$userresources"
    
    fi
    
    if [ -f "$usermodmap" ]; then
        xmodmap "$usermodmap"
    fi
    
    # start some nice programs
    
    if [ -d /etc/X11/xinit/xinitrc.d ] ; then
     for f in /etc/X11/xinit/xinitrc.d/?*.sh; do
      [ -x "$f" ] && . "$f"
     done
     unset f
    fi
    
    #twm &
    #xclock -geometry 50x50-1+1 &
    #xterm -geometry 80x50+494+51 &
    #xterm -geometry 80x20+494-0 &
    #exec xterm -geometry 80x66+0+0 -name login
    exec startxfce4
    

    And the bash_profile command :

    #
    # ~/.bash_profile
    #
    
    [[ -f ~/.bashrc ]] && . ~/.bashrc
    
    [[ -z $DISPLAY && $XDG_VTNR -eq 1 ]] && startx
    

    Any idee why ?

    On Buntu theyr’s a script /etc/X11/Xsession launched by /etc/X11/xinit/xinitrc where the command to generate .xsession-errors is but not on Arch.

    Thanks.

  • I found the reason of the problem = broken redirection :

    https://wiki.archlinux.org/index.php/Xorg#Broken_redirection

    https://bbs.archlinux.org/viewtopic.php?pid=1446402#p1446402

    I will try the given solution and post the result.

  • I could get the logs back by adding the keeptty option, like that :

    startx – -keeptty -nolisten tcp > ~/.xsession-errors 2>&1

    But if you logout/login it’s not working anymore.

    Anyway, better then nothing.

Posts 3Views 706
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.