Hi, I bought the 4th gen X1 Carbon, and planned to dual boot Windows 10 with Antergos. I need some help with the installation. I have done nothing to the computer except shrinking the C drive to create one more partition.

I disabled both fast boot and secure boot, followed the instructions in the Create a working Live USB (I tried both the dd and USBWriter ones) to create a bootable USB disk.

I changed the BIOS boot order to boot from the USB HDD. I selected Antergos UEFI USB. But then it says

Error loading \arch\boot\vmlinuz: Not Found

followed by

Failed to exectue Antergos UEFI USB (\arch\boot\vmlinuz): Not Found.

Then it shows a blue screen saying

Failed to start loader.efi: (14) Not Found

I’ve read this thread on the same forum and I once tried selecting the “Antergos CD/DVD” option. But the screen became black and blank and stuck there. And I had to press and hold the power button to power off the computer.

Finally, when I look at the contents of the USB drive from Windows, I found vmlinuz.efi under D:\EFI\archiso, where D is the USB drive.

Thanks for helping. I used Ubuntu before but I like the rolling release model of Antergos and to me it seems to be much more friendly than Arch.