• Like 1

    Conky-lua upgrade


    The conky-lua package, if it is installed from AUR, currently doesn’t upgrade smoothly from the old 1.9.0-2 to the new 1.10.1-3:

    $ yaourt -Syyua
    ...
    then
    ...
    ==> Software upgrade (new version) :
    aur/conky-lua 1.9.0-2  -> 1.10.1-3
    ...
    and finally
    ...
    -- Configuring incomplete, errors occurred!
    See also "/tmp/yaourt-tmp-just/aur-conky-lua/src/conky-1.10.1/CMakeFiles/CMakeOutput.log".
    See also "/tmp/yaourt-tmp-just/aur-conky-lua/src/conky-1.10.1/CMakeFiles/CMakeError.log".
    ==> ERROR: A failure occurred in build().
        Aborting...
    ==> ERROR: Makepkg was unable to build conky-lua.
    ==> Restart building conky-lua ? [y/N]
    ==> ----------------------------------
    ==> No, thanks
    ...
    

    Nothing serious, the old conky-lua 1.9.0-2 works nicely in Antergos (Kde):

    alt text

    Conky-lua upgrade fails only in Arch-based systems where the git package is not installed. If git is present conky-lua upgrades smoothly.

    If git is installed, pacman returns its name, version and build numbers:

    $ pacman -Q git
    git 2.7.4-1
    $
    

    If git is not installed, pacman returns the error:

    $ pacman -Q git
    error: package 'git' was not found
    $
    

    Git may be added at any moment with:

    $ sudo pacman -Syyu extra/git
    

    Briefly:

    • with git installed conky-lua upgrade succeeds
    • without git it fails

    The issue is known:

    https://aur.archlinux.org/packages/conky-lua/

    AUR usually solves them quickly.

    Again, there’s nothing to worry about. The post may be safely ignored.

    Regards

  • Like 0

    The situation changes. @moonarch, conky-lua package maintainer, says he’s not on Arch anymore so can’t generate a new .SRCINFO for the package. In simple words it means that the package won’t build anymore from AUR. Even simpler, installation impossible.

    Most probably it affects Nvidia owners only.

    conky-lua package behaves differently in various Arch with addedd Antergos repo DEs:

    • Mate: continues to work and upgrades nicely
    • Cinnamon: continues to work but refuses to upgrade
    • Gnome 3: upgraded and stopped working after it, conky doesn’t show up, segfault on startup
    • Kde: upgraded and stopped working after it, conky doesn’t show up, segfault on startup

    Solution: install conky-lua-nv instead of conky-lua. Two packages are fortunately in conflict, so conky-lua-nv will ask if you want to remove conky-lua. Reply explicitely with y. Be aware, the default answer is N. Reply with y.

    In Cinnamon yaourt was not able to remove conky-lua contextually with conky-lua-nv installation. Uninstall conky-lua first:

    yaourt -Rc conky-lua
    

    Then install conky-lua-nv:

    yaourt -S conky-lua-nv
    

    -nv in the package name means nvidia support, not nouveau. There are no nouveau drivers here, nowhere. conky-lua-nv works flawlessly in all DEs now. It has solved the problem with missing or unupgradeable conky.

    Seems like git package is still needed. Didn’t check it.

    Good luck

conky8 git4 Posts 2Views 985
Log in to reply