• Catalyst Installation: Dependency conflict


    I recently installed Antergos. Then installed the softwares I needed and at the end I headed to install the driver for my R9 270. From this post, I tried to install catalyst driver using this:

    yaourt -S catalyst
    

    Executing the above line, I get this:

    0_1459074087440_Screenshot from 2016-03-27 15-20-52.png

    Please help me… I’m stuck…

  • Force your mirrors to resync and run an upgrade first: sudo pacman -Syyu

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Wyn, I did what you said. As a result I proceeded forward. After that I got this when i tried to install catalyst package.

    :: There are 2 providers available for catalyst:
    :: Repository catalyst
       1) catalyst-generator  2) catalyst-hook
    
    Enter a number (default=1): 1
    resolving dependencies...
    looking for conflicting packages...
    :: xorg-server and xf86-input-evdev are in conflict. Remove xf86-input-evdev? [y/N] y
    :: xorg-server and xf86-video-ati are in conflict. Remove xf86-video-ati? [y/N] y
    :: xorg-server and xf86-video-fbdev are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-fbdev? [y/N] y
    :: xorg-server and xf86-video-intel are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-intel? [y/N] y
    :: xorg-server and xf86-video-vesa are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-vesa? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: xorg-server: requires xf86-input-evdev
    
    

    And then it terminated. No matter what I choose: catalyst-hook or catalyst-generator. I get the same error. What should I do now?

  • @on_99

    You will need to downgrade your xorg. Considering Catalyst is a headache in itself I’m afraid to explain incorrectly; I would suggest to look at the Arch wiki as it’s all explained in depth: https://wiki.archlinux.org/index.php/AMD_Catalyst

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Wyn, I resorted to the driver available from the amd site. When I start installer and proceed forward it says this:

    0_1459217912556_Screenshot from 2016-03-29 07-18-12.png

    Do you have any idea what this means? What to do now?
    Also the log pointed by message is this:

    Supported adapter detected.
    Check if system has the tools required for installation.
    fglrx installation requires that the system have kernel headers for greater than 3.6 release.  /lib/modules/4.4.5-1-ARCH/build/include/generated/uapi/linux/version.h cannot be found on this system.
    One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
    Optionally, run the installer with --force option to install without the tools.
    Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.
    
  • @on_99 Please look into the link for Catalyst I linked yu in the Arch wiki. If you install it that way you will mess your system up beyond recovery. Because Catalyst is very slow at updating you will need to do extra steps provided in the Arch wiki.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • @Wyn Thanks. You just saved me. I did what you said and read the arch Wiki. I solved the problem. Now, antergos is going awesome. Thanks for your kind and passionate help.

  • @on_99 No problem. Glad to help :+1: .

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

catalyst8 amd23 catalyst xorg3 ati8 Posts 8Views 1912
Log in to reply