• Touchpad scrolling inverted


    Hello

    It is not that big of a deal, but it is frustrating at some points.

    Since I installed it (also when I tried it live), when I scroll vertically with my touchpad at the right edge, it does it inversely. (Up is down and down is up)

    I tried xinput set button map, and inverted 4 and 5… but that does not work in all windows and well, I should set it as a bash startup bash, too much work for semi functionality. I can’t find any “natural scroll” settings either.

    Can you guide me on how to fix it?

    P.S. I’m in Gnome. I don’t know if I have to edit some Xorg files, which I don’t feel that prepared to do it blindly.

  • @UlisesFrank said:


    P.S. I’m in Gnome…

    Open Gnome Control Center (aka System Settings), click the Mouse & Touchpad applet and disable (remove the check mark) from the Natural scrollling field:

    0_1458621739832_antergos-touchpad.png

    If you can’t find Gnome Control Center in menu, it can be launched from terminal:

    gnome-control-center
    
  • @just Thanks.

    I should have said that I tried all the “normal” things xD … I don’t have options there (which I don’t know why), I install after viewing that a libsynaptics package, but did nothing.

    0_1458622952194_Screenshot from 2016-03-21 22-01-11.png

  • @UlisesFrank Hmm. Looks like the touchpad is not recognized, as a hardware. Some computers have a functional keys combinations that disable and enable touchpad. For example, on Dell XPS 17 it is the Fn+F3 combination.

    Make sure that the touchpad is not disabled.

  • I’m not a Gnome 3 user, and probably may say a wrong thing, but the libsynaptics package is not installed in a normal, default Antergos Gnome system:

    $ pacman -Q libsynaptics
    error: package 'libsynaptics' was not found
    $
    
    $ pacman -Sii libsynaptics
    Repository      : community
    Name            : libsynaptics
    Version         : 0.14.6c-7
    Description     : Library for accessing synaptics touchpads
    Architecture    : x86_64
    URL             : http://qsynaptics.sourceforge.net
    Licenses        : GPL
    Groups          : None
    Provides        : None
    Depends On      : gcc-libs
    Optional Deps   : None
    Required By     : None
    Optional For    : None
    Conflicts With  : None
    Replaces        : None
    Download Size   : 31.46 KiB
    Installed Size  : 123.00 KiB
    Packager        : Bartłomiej Piotrowski <[email protected]>
    Build Date      : Sat 05 Dec 2015 18:40:30 MSK
    MD5 Sum         : 8735c01185c671c7019e56fe07df962b
    SHA-256 Sum     : 388eeae2301c6c4bbec340d9065de3f0dc518fd09e18e8319265cd9d6d73f6c1
    Signatures      : BBE43771487328A9
    
    $
    

    Touchpads have no problem to work on three different computers here, without libsynaptics installed.

  • Yep, I don’t know why I installed it if my touchpad does work, but the scrolling is just inverted.

    And I don’t use GNOME either, this is my first distro with that DE, I’m usually more of a XFCE or MATE guy, but oh well.

    Also, I don’t know how to “enable” my touchpad, if I’m using it, it is enabled, isn’t it?

    This is my synclient. I don’t know if it serves you a purpose. I saw the TouchpadOff=2, and that means it is disabled for scrolling and tapping (I don’t know what else is there xD my laptop is kind of old). I don’t know where the file is for the synclient.

    synclient
    Parameter settings:
        LeftEdge                = 1767
        RightEdge               = 5401
        TopEdge                 = 1675
        BottomEdge              = 4965
        FingerLow               = 25
        FingerHigh              = 30
        MaxTapTime              = 180
        MaxTapMove              = 250
        MaxDoubleTapTime        = 100
        SingleTapTimeout        = 180
        ClickTime               = 100
        EmulateMidButtonTime    = 75
        EmulateTwoFingerMinZ    = 282
        EmulateTwoFingerMinW    = 7
        VertScrollDelta         = -133
        HorizScrollDelta        = -113
        VertEdgeScroll          = 1
        HorizEdgeScroll         = 1
        CornerCoasting          = 0
        VertTwoFingerScroll     = 0
        HorizTwoFingerScroll    = 0
        MinSpeed                = 1
        MaxSpeed                = 1.75
        AccelFactor             = 0.0351062
        TouchpadOff             = 2
        LockedDrags             = 0
        LockedDragTimeout       = 5000
        RTCornerButton          = 0
        RBCornerButton          = 0
        LTCornerButton          = 0
        LBCornerButton          = 0
        TapButton1              = 1
        TapButton2              = 3
        TapButton3              = 2
        ClickFinger1            = 1
        ClickFinger2            = 1
        ClickFinger3            = 1
        CircularScrolling       = 0
        CircScrollDelta         = 0.1
        CircScrollTrigger       = 0
        CircularPad             = 0
        PalmDetect              = 0
        PalmMinWidth            = 10
        PalmMinZ                = 200
        CoastingSpeed           = 20
        CoastingFriction        = 50
        PressureMotionMinZ      = 30
        PressureMotionMaxZ      = 160
        PressureMotionMinFactor = 1
        PressureMotionMaxFactor = 1
        GrabEventDevice         = 0
        TapAndDragGesture       = 1
        AreaLeftEdge            = 0
        AreaRightEdge           = 0
        AreaTopEdge             = 0
        AreaBottomEdge          = 0
        HorizHysteresis         = 28
        VertHysteresis          = 28
        ClickPad                = 0
    

    I also found strange that my Delta values are negative, meanwhile my scrolling acts the opposite.

    dmesg
    [   10.013920] psmouse serio1: synaptics: queried max coordinates: x [..5696], y [..5232]
    [   10.049239] psmouse serio1: synaptics: Touchpad model: 1, fw: 7.0, id: 0x1c0b1, caps: 0xd04711/0xa00000/0x20000/0x0, board id: 0, fw id: 474059
    [   10.094294] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input6
    

    The only file I keep editing to see if something changes is the 50-synaptics.conf. But no change at the moment.

  • @UlisesFrank Probably you have already checked that, but does the touchpad work in the live Antergos session? If yes, than it could be a configuration problem in the installed system. If no, than it could be a hardware (touchpad) problem.

  • @just It works, but has the same scrolling problem.

    It can’t be a hardware problem. I have a Deepin partition installed, and there works just fine. Also, today I erased a Manjaro partition to install this Antergos, and in Manjaro worked fine also.

    It must be some config file in the system, which I’m not aware of.

  • @UlisesFrank OK… I remember an option that I read a few hours ago and that solved it.

    I just installed “gpointing-device-settings” and modify from there. I hope it sticks after rebooting.

  • It all sounds rather unusual. Touchpads never have an issue in Antergos and work well without any tweaking or special configuration. It is the first time when a similar situation is reported.

    Edit

    It is assumed that there’s only one DE installed in the partition, so no other DE could interfer to touchpad’s configuration.

  • @just Yes, it is the only DE in Antergos.

    And it was very unusual this mistake. Linux distros usually fix the touchpad (because in Windows didn’t scroll). But well, I gotta get used to tweak it at the moment (even though it does not initiate at startup, don’t know how to do, so my settings persist).

    Apparently, when I use that program, it changed temporarily the Delta settings to positive, so, I decided to edit them in the 50-synaptics.conf, but they don’t change to positive (not with blank value, negative sign value or positive sign value).

    EDITED: I undone everything I did. Installed dconf-editor, go to /org/gnome/settings-daemon/plugins/mouse/ and unchecked the active sign as sudo. And everything works fine, even after reboot.

  • @UlisesFrank Sorry, I’m quite confused after the long discussion. Does the touchpad work well for you in live Antergos session?

    Can you simply reply with:

    • yes, it does
    • no, it does not

    Regards.

  • @just Yes it does.

Posts 13Views 2002
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.