• Like 0

    Error loading \arch\boot\vmlinux: Not found


    Hello all.

    I’ve been a linux user for about a decade and have installed just about every distribution under the sun with nary an issue. My old computer was tire so I bought a Dell Precision 5510 (pretty much an XPS15) which Dell sells preloaded with Unity. This is my first UEFI computer. Really hate Microsoft for the pointless cruelty. I really can’t stand Unity and would really like to install a Gnome distro.

    I made a live USB of the latest 64 bit Antergos. I powered on and selected the USB option, but here is what i get:

    Error loading \arch\boot\vmlinux: Not found
    Failed to execute Antergos UEFI USB (\arch\boot\vmlinux): Not Found

    Then it flashed to a blue screen and says:

    Failed to start loader.efi: (14) Not Found

    Any ideas? I just gotta get rid of Unity. I mean, it is pretty, but everything takes more clicks than it ought to in the environment.

    -Chris

  • Like 0

    I am not an expert at this but is there a way that you could post your /dev/sda on this system with a liveCD if that is what you need to do?

    Can use pastebin service or if possible copy directly to post. Please use the correct coding tags. There is a sticky in the newbie forum for how to do this.

    Before I forget, see if you can get the logs too. Again, another sticky.
    Stickies are not all where, in my opinion, they could/should be.
    It takes a bit of searching though.

    Some ideas to help answer:

    1. You possibly did not have the EFI System Partition mounted. In other words, you probably didn’t boot as EFI. To help further explain this, the kernel was NOT copied over to the EFI, but rather over to the root partition.
      That is just my guess, though. I could be wrong.
      But it sounds like it might be given the subject heading of your post.
    2. Not 100 percent sure at this point until you manage to display your /dev/sdaX layout, but it is possible that your config is /dev/sda1 rather than /dev/sda2, for example.
      Again, that’s just me guessing.
    3. Suppose that this is the case, what this means is that ESP should be mounted whenever you update the kernel.
      That should actually be automatic, though.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Like 0

    This is a known issue for UEFI by now (I hope!)

    @chris-g-ludwig I found a walk-around for the current problem however.

    Reference: https://forum.antergos.com/topic/4081/how-to-dual-boot-antergos-windows-uefi-expanded

    I have found with the current install process (2/2016) you are presented with Antergos USB for UEFI and Antergos CD/DVD. If you select USB you may get this error:
    “antergos error loading \arch\boot\vmlinuz not found”
    In which case selecting Antergos CD/DVD should fix the issue.

    Wow a decade. That’s impressive. Let me know if this fixes the issue!

  • Like 0

    @Modisc

    You are correct. I do not have the EFI System Partition mounted. It was wiped out and lost during one of my previous install attempts. So I guess we need to consider this as if it is a load to a completely blank slate. Is there any way to re-establish an EFI partition?

    I had tried selecting the CD option when booting into the live disk as well, but it also didn’t work. If I select that option in my current state, it just reboots the computer.

    I also tried switching to legacy boot and was able to get the live environment working that way. I was even able to install the OS without errors, but I get the same blinking white cursor as this recent post when I install in legacy mode:

    https://forum.antergos.com/topic/4168/cannot-boot-into-desktop-environment-post-installation

    I tried to get system logs per the sticky. The command journalctrl was not found so I couldn’t do anything with that. /var/log/journal is empty along with /var/log/lightdm. I ony have logs from the cnchi install. Will attach those. Here are my current partitions are below. I tried a previous install in the 1 TB platter so you will see those partitions there still.

    [[email protected] ~]$ sudo fdisk -l
    Disk /dev/loop0: 1.6 GiB, 1677877248 bytes, 3277104 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    [0_1458483484258_cnchi.tar.gz](Uploading 100%)

    Disk /dev/nvme0n1: 238.5 GiB, 256060514304 bytes, 500118192 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x064f1ff2

    Device Boot Start End Sectors Size Id Type
    /dev/nvme0n1p1 * 2048 524287 522240 255M 83 Linux
    /dev/nvme0n1p2 524288 61964287 61440000 29.3G 83 Linux
    /dev/nvme0n1p3 61964288 484141055 422176768 201.3G 83 Linux
    /dev/nvme0n1p4 484141056 500118191 15977136 7.6G f W95 Ext’d (LBA)
    /dev/nvme0n1p5 484143104 500118191 15975088 7.6G 82 Linux swap / Solaris

    Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 84D20829-1191-42C0-9B58-1AD4574F6234

    Device Start End Sectors Size Type
    /dev/sda1 34 1050815 1050782 513.1M EFI System
    /dev/sda2 1050816 1920289097 1919238282 915.2G Linux filesystem
    /dev/sda3 1920289098 1953525118 33236021 15.9G Linux swap

    Partition 1 does not start on physical sector boundary.
    Partition 3 does not start on physical sector boundary.

    Disk /dev/sdb: 3.8 GiB, 4063232000 bytes, 7936000 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x16558c82

    Device Boot Start End Sectors Size Id Type
    /dev/sdb1 * 0 3427199 3427200 1.6G 0 Empty
    /dev/sdb2 224 63711 63488 31M ef EFI (FAT-12/16/32)

    0_1458483520147_cnchi.tar

  • Like 0

    What method did you use to install Antergos onto your live media?

    I have used the CD option for both a clean install as well as dual-boot. The method I have used to install Antergos to a flash drive is as follows:
    sudo su
    cd Downloads (Downloads is where I saved my Antergos ISO)
    cat antergos.iso > /dev/sdX

    sdX is just a placeholder. Replace the X with your proper location for your flashdrive (in my case this was /dev/sdb) Also replace Antergos.iso with the name of your iso.

    Some people have also found success using Rufus in Windows to create the live media although I don’t have personal experience in the matter. Also not saying that this will necessarily fix your issue as there could be something in the BIOS causing problems or other areas, I just know this works for me.

  • Like 0

    @linuxhelmet

    I used dd under opensuse.

  • Like 0

    I’ve always had problems using dd and getting it to work personally. Also your live media is showing that it can’t find loader.efi. If I recall that file should be in your boot folder under EFI. Maybe something is corrupted? Never hurts to try installing it on the flashdrive again (possibly with cat)? If you do decide to try cat it does not finish copying until your [[email protected] ~]$_ line shows up again.

    If that still doesn’t work you can check BIOS to make sure secure boot is turned off and UEFI mode is on as well as check to see if your ISO is bad/corrupt. Aside from that as far as I know it SHOULD work.

    EDIT: Also with cat I’ve found sometimes I have to wipe the flash drive and then re-mount or soft reset the machine before everything works again. If cat takes only a few seconds to make a copy then it didn’t work right. Try wiping the drive then unplugging and re-plugging the flash drive and trying again.

  • Like 0

    @linuxhelmet

    I tried making a new USB with cat with and without sudo. In all cases, I get /dev/sdc: Permission denied. Any ideas?

    [[email protected] Downloads]$ sudo fdisk -l

    Disk /dev/sda: 223.6 GiB, 240057409536 bytes, 468862128 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0xdbcf4da1

    Device Boot Start End Sectors Size Id Type
    /dev/sda1 * 2048 97658877 97656830 46.6G 83 Linux
    /dev/sda2 97658878 105471377 7812500 3.7G 83 Linux
    /dev/sda3 105471378 468857024 363385647 173.3G 83 Linux

    Disk /dev/sdb: 465.8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: dos
    Disk identifier: 0xff0aff0a

    Device Boot Start End Sectors Size Id Type
    /dev/sdb1 * 63 78086629 78086567 37.2G 7 HPFS/NTFS/exFAT
    /dev/sdb2 78088190 976771071 898682882 428.5G 5 Extended
    /dev/sdb5 957241344 976771071 19529728 9.3G 82 Linux swap / Solaris
    /dev/sdb6 78088192 957241343 879153152 419.2G 83 Linux

    Partition table entries are not in disk order.

    Disk /dev/sdc: 3.8 GiB, 4063232000 bytes, 7936000 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x16558c82

    Device Boot Start End Sectors Size Id Type
    /dev/sdc1 * 0 3427199 3427200 1.6G 0 Empty
    /dev/sdc2 224 63711 63488 31M ef EFI (FAT-12/16/32)

    [[email protected] Downloads]$sudo cat antergos-2016.02.21-x86_64.iso > /dev/sdc
    bash: /dev/sdc: Permission denied

  • Like 0

    Looks like my problems are related to the live USB. I’ve ordered an external DVD drive and will give that much slower way a try tomorrow. Hopefully that will improve things.

  • Like 0

    curious to know but how are they related to USB? It’s different hearing that, hence the question.

    also, with trying to use dd, it’s very easy.
    First you have to cd into the directory where you ISO is.
    Then do this:
    dd if=/directory/of/the/EXACT-NAME-and-VERSION-of-Antergos.iso of=/dev/sdXX bs=2048 conv=sync,notrunc

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Like 0

    @chris.g.ludwig said:

    @linuxhelmet

    I tried making a new USB with cat with and without sudo. In all cases, I get /dev/sdc: Permission denied. Any ideas?

    [[email protected] Downloads]$ sudo fdisk -l

    Disk /dev/sda: 223.6 GiB, 240057409536 bytes, 468862128 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0xdbcf4da1

    Device Boot Start End Sectors Size Id Type
    /dev/sda1 * 2048 97658877 97656830 46.6G 83 Linux
    /dev/sda2 97658878 105471377 7812500 3.7G 83 Linux
    /dev/sda3 105471378 468857024 363385647 173.3G 83 Linux

    Disk /dev/sdb: 465.8 GiB, 500107862016 bytes, 976773168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: dos
    Disk identifier: 0xff0aff0a

    Device Boot Start End Sectors Size Id Type
    /dev/sdb1 * 63 78086629 78086567 37.2G 7 HPFS/NTFS/exFAT
    /dev/sdb2 78088190 976771071 898682882 428.5G 5 Extended
    /dev/sdb5 957241344 976771071 19529728 9.3G 82 Linux swap / Solaris
    /dev/sdb6 78088192 957241343 879153152 419.2G 83 Linux

    Partition table entries are not in disk order.

    Disk /dev/sdc: 3.8 GiB, 4063232000 bytes, 7936000 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x16558c82

    Device Boot Start End Sectors Size Id Type
    /dev/sdc1 * 0 3427199 3427200 1.6G 0 Empty
    /dev/sdc2 224 63711 63488 31M ef EFI (FAT-12/16/32)

    [[email protected] Downloads]$sudo cat antergos-2016.02.21-x86_64.iso > /dev/sdc
    bash: /dev/sdc: Permission denied

    if you would like to know why it said permission denied,

    when you use sudo is uses a differnt shell. So, what we need to do is.


    sudo -s

    cat isoimagehere.iso > /dev/sdx1


    How is it the usb?
    "If at first you don’t succeed, try, try again"
    That was your decision to make and I don’t judge that.
    But research is key. Especially for Linux.
    But what you should try if you have a windows machine nearby is win32diskimager.
    Or if you have a Mac then use Unetbootin (It actually works on a mac better than Linux)

  • Like 0

    Another tool to use for imaging USB drives, that I used for my install of Antergos, is MultiBootUSB. Greg

  • Like 1

    Cat didn’t work due to you using sudo as mentioned by @hawesboy . Also you must use cd to move to the directory that you want to use. Try this in ORDER this time if you still want to use the cat command.

    Step 1: sudo su OR sudo -s
    then type in your password.

    Step 2: cd Downloads
    (Downloads is where I saved my Antergos ISO, if you have it elsewhere then try cd Home or cd /usr/vm1 or where ever you have your file stored)

    Step 3: cat antergos.iso > /dev/sdX1 (or 2 or whichever drive is yours)

    OR If all this doesn’t work you can also try several of the other mentioned commands/gui tools to make a usb drive. This IS possible and this error isn’t the end of it all. If need be go get a disk and burn it. I’ve had to resort to that myself when I first started trying out new linux distros years ago. Also some REALLY old machines only take disk.

    Hope it helps!

  • Like 0

    @linuxhelmet said:

    Cat didn’t work due to you using sudo. Also you must use cd to move to the directory that you want to use. Try this in ORDER this time if you still want to use the cat command.

    Step 1: sudo su OR sudo -s
    then type in your password.

    Step 2: cd Downloads
    (Downloads is where I saved my Antergos ISO, if you have it elsewhere then try cd Home or cd /usr/vm1 or where ever you have your file stored)

    Step 3: cat antergos.iso > /dev/sdX1 (or 2 or whichever drive is yours)

    OR If all this doesn’t work you can also try several of the other mentioned commands/gui tools to make a usb drive. This IS possible and this error isn’t the end of it all. If need be go get a disk and burn it. I’ve had to resort to that myself when I first started trying out new linux distros years ago. Also some REALLY old machines only take disk.

    Hope it helps!

    I literally just said that. You physically just copied me and don’t care. That is called plagiarism because you copied my idea that you had saw and changed a few words.
    ***I DO NOT ACCEPT STEALING. I DON’T REALLY MIND BUT FOR OTHERS THIS WILL GET YOU SUED! ***

    I literl

  • Like 0

    Do you have nvme drive?

    Go to bios settings:
    -> General -> Boot Sequence -> Boot List Option -> UEFI
    -> System Configuration -> SATA Operation -> Disabled

    Reboot, go with UEFI option, in boot menu select CD/DVD and you are okay. during installation allow automatic partitioning, choose nvme drive and select systemd-boot.
    Reboot and it should work(at least worked for me)

  • Like 0

    @hawesboy Forgive me for restating something you said. I was merely doing so for clarity NOT for plagiarism purposes. I simply posted what I thought would fix the OP problem. Just so happens that involved the use of sudo su. Also if I remember correctly this is not plagiarism as anything posted online without proper copyright is considered public domain, especially in a forum post. Another note is that I DID say in an earlier post to use sudo su which sudo -s is a variation of that as well as I mentioned earlier to use cat antergos.iso > /dev/sdx. So then you just copied what I said and changed it a little :O so much plagiarism (not.)

    I did fix the post however to mention you so you understand I am not out to plagiarize you or anyone else.
    If you would like continue this conversation please message me in chats so not to clutter the forum.
    Sorry everyone!

  • Like 0

    Well dang, I hate UEFI. A class action lawsuit against Microsoft is in order. So the original complaint, loader.efi not found is a UEFI/bios problem. With UEFI on, you need to go into advanced boot options and configure a new boot option that points to a loader.efi file by drilling into the boot folder and showing bios where that file is. So, then I can get it to boot without that error. Of course, now I get the blue screen with an error saying the loader.efi config file is not compatible.

    This is frustrating. Unless I find a highly detailed guide of how to make UEFI work with this bios, well, this laptop will be just a brick and will have to go in to Dell for a re-image. To think how you could pop a live disk in a computer in 2006 and install anything, and now 10 years later, I have a linux laptop that I can’t install anything on. Linux on the desktop just got set back 12 years.

  • Like 0

    Sorry for your troubles @chris-g-ludwig. I’m currently running 2 laptops and a desktop all running in UEFI mode with Antergos on them (installed from a usb thumbdrive). Maybe you are running into a BIOS specific issue? The only advice I have left is to recommend looking into the Arch wiki as Antergos is based off Arch. Here is what I found, sorry if this doesn’t answer your question. :(

    https://wiki.archlinux.org/index.php/Unified_Extensible_Firmware_Interface
    Also maybe try from a DVD?

  • Like 0

    @chris-g-ludwig I managed to install antergos on dell precision 5510.

    Can you tell me regarding my previous post what bios settings do you have?
    And where it works different in your case?

  • Like 1

    I finally got it to work!!! I had even tried a DVD and that didn’t work either, but I finally got the USB to work.

    There was something wrong with my USB drive. It was giving gparted was giving errors and was not letting me delete partitions and reformat. Apparently the GPT header was invalid. So, while the dd command should have worked, the resulting USB was bad. So step one, clean up the USB with this:

    sudo gdisk /dev/sdX

    Then, I selected option 2 to create a blank GPT.
    Then X to enter expert mode
    Then z to zap it

    Then I was able to reformat my drive with the Gnome disk utility. Then I used dd to write the USB:
    sudo dd bs=4M if=antergos-2016.03.20-x86_64.iso of=/dev/sdc && sync
    Then when I rebooted, I got the menu that linuxhelmet said I would.

    I had selected UEFI with secure boot off, SATA off as kpbochenek said (I have the nvme drive). After installing, I turned SATA back on and can now see my second hard drive.

    Thanks everyone for sticking with me continuing to make suggestions. Don’t know what screwed up my USB to start, but I had two seperate USB sticks that I had botched in identical ways. Must have been from my earlier attempts to write the ISO to the USB.

  • Like 0

    I was having this same issue, and what fixed it was to select CD/DVD from the menu instead of USB, even though I was booting from a USB disk.

Posts 21Views 5838
Log in to reply