• No HDMI-Sound with my R9 380X


    Hello,

    does anyone know, how can I enable my hdmi-sound? I have connected my PC with my TV-Monitor, but I have no sound.

    Kernel is 4.4.5.

    Best Regards

    TemplateR

  • I don’t have a solution for this as I’ve been using a TV as a monitor since kernel 3.x-4.4 without a fix in ANY flavor of Linux so far. While I don’t have a solution I do have a work-around:
    Hook up some speakers into the desktop (for example I have surround sound) and let that serve as your audio.

    I know it’s not a fix but so far it’s the easiest solution I’ve found so far. I think it has to do with the lacking support in the graphics department as far as drivers go but I’m not 100% on that.

  • @linuxhelmet said:

    I don’t have a solution for this as I’ve been using a TV as a monitor since kernel 3.x-4.4 without a fix in ANY flavor of Linux so far. While I don’t have a solution I do have a work-around:
    Hook up some speakers into the desktop (for example I have surround sound) and let that serve as your audio.

    I know it’s not a fix but so far it’s the easiest solution I’ve found so far. I think it has to do with the lacking support in the graphics department as far as drivers go but I’m not 100% on that.

    I have 2 Monitors. One TFT-Monitor (DVI/VGA) and a TV-Monitor (HDMI)
    TV-Monitor only for films and some gaming. TFT-Monitor for all.

  • I don’t have Antergos installed yet (downloading now), but it sounds like we have a very similar set up. I have to use PulseAudio to get sound to the TV I use as a monitor (currently running Korora23). 0_1458238172744_Screenshot_2016-03-17_12-07-42.png

  • @wjeh0810 said:

    I don’t have Antergos installed yet (downloading now), but it sounds like we have a very similar set up. I have to use PulseAudio to get sound to the TV I use as a monitor (currently running Korora23). 0_1458238172744_Screenshot_2016-03-17_12-07-42.png

    My Setup isn´t the same as your picture, but I have tested it now. Nothing happens.

  • @templater

    I could only suggest to go into Volume Control as @wjeh0810 has said and go through all the HDMI outputs to find the TV. Which amd drivers are you using?

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • @Wyn said:

    @templater

    I could only suggest to go into Volume Control as @wjeh0810 has said and go through all the HDMI outputs to find the TV. Which amd drivers are you using?

    I already tested all HDMI-Outputs and nothing helps. Which AMD driver I´m using? I think it is AMDGPU, but I don´t know how to check it.

  • Assuming you have AMDGPU and are running opensource you should have the most current drivers especially if the graphics card is new. BUT if you still want to know driver info I posted the following steps, IF NOT then skip 1. and 2.

    There are two ways I know to check this.

    1. Depending on your desktop environment (Gnome,KDE,ect) you can check it in the “Graphical Information” section. I have KDE so I go to kinfo and find that data there. It varies from environment to environment.

    2. Install glxinfo
      This is a tool that will tell you which driver you may have.
      Open terminal and enter the following:

    yaourt -S glxinfo
    Once this is done execute the following:
    glxinfo | grep OpenGL

    Assuming you have AMDGPU this is the only thing I found on the matter, and unfortunately I found it under the older ATI cards so I’m not 100% that this will work for you but if you want you can try it. This was pulled directly from the arch wiki
    Reference:
    https://wiki.archlinux.org/index.php/ATI#HDMI_audio

    HDMI audio

    HDMI audio is supported in the xf86-video-ati video driver. By default HDMI audio is disabled in the driver kernel versions >=3.0 because it can be problematic. To enable HDMI audio add radeon.audio=1 to your kernel parameters. <hotlink
    If there is no video after boot up, the driver option has to be disabled.

    Note:
    If HDMI audio does not work after installing the driver, test your setup with the procedure at Advanced Linux Sound Architecture/Troubleshooting#HDMI Output does not work.
    If the sound is distorted in PulseAudio try setting tsched=0 as described in PulseAudio/Troubleshooting#Glitches, skips or crackling and make sure rtkit daemon is running.
    Your sound card might use the same module, since HDA compliant hardware is pretty common. Change the default sound card using one of the suggested methods, which include using the defaults node in alsa configuration.

    Sadly I don’t have time to test this myself or I would. TVs are very closed about their source code and other driver info so they really force linux to kinda “guess” about what your actually trying to hook up. I know back in early kernel 3 days I couldn’t even get some of my desktops to even see what the proper resolution on the TV was much less anything else. Hope this helps!

  • I used glxinfo and I get these informations:

    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD TONGA (DRM 3.1.0, LLVM 3.7.1)
    OpenGL core profile version string: 4.1 (Core Profile) Mesa 11.1.2
    OpenGL core profile shading language version string: 4.10
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 3.0 Mesa 11.1.2
    OpenGL shading language version string: 1.30
    OpenGL context flags: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.0 Mesa 11.1.2
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
    OpenGL ES profile extensions:

Posts 9Views 1406
Log in to reply