• Stuttering / lagging desktop animations after suspend.

    Hi everyone,
    I have been using Antergos for a few months now and I am greatly enjoying it. One problem that I have noticed is how the desktop animations start to lag after I resume working from a suspended session. This is most noticeable when opening the dash overlay, switching desktops, or mousing over the dock so that it slides out from hiding. It is also slightly noticeable when opening and closing windows. After a reboot, all animations are butter-smooth again and the problem does not occur after every suspend, only sometimes.

    Have anyone experienced something similar? What could be the cause for this behavior and how can I fix it?

  • Some basic questions to ask about your lagging animations.
    I am going to take a wild guess that you have Intel installed; however, you didn’t post anything specific to your computers’ design, DE, etc…etc… Hence the following questions:

    Do you have xf86-video installed?
    Do you have libva installed?
    If my guess is correct: https://wiki.archlinux.org/index.php/Intel_graphics

  • @Modisc Thanks for the reply Modisc. I wasn’t sure what was relevant, so I just posted in the Gnome forum, since that is the DE I am using, hoping for some pointers. I have the following packages installed:


    extra/xf86-video-fbdev 0.4.4-5 (xorg-drivers xorg) [installed]
    extra/xf86-video-intel 1:2.99.917+560+gd167280-1 (xorg-drivers xorg) [installed]
    extra/xf86-video-vesa 2.3.4-2 (xorg-drivers xorg) [installed]


    extra/libva 1.6.2-1 [installed]
    extra/libva-intel-driver 1.6.2-1 [installed]


    extra/glu 9.0.0-4 [installed]
    extra/libtxc_dxtn 1.0.1-6 [installed]
    extra/mesa 11.1.2-1 [installed]
    extra/mesa-libgl 11.1.2-1 [installed]
    extra/mesa-vdpau 11.1.2-1 [installed]
    multilib/lib32-glu 9.0.0-3 [installed]
    multilib/lib32-libtxc_dxtn 1.0.1-5 [installed]
    multilib/lib32-mesa 11.1.2-1 [installed]
    multilib/lib32-mesa-libgl 11.1.2-1 [installed]

    I can’t find anything on the Arch page specifc to the stuttering/lag i am experiencing. They said no configuration is needed to run Xorg and I alreaady thave the /etc/X11/xorg.conf.d/20-intel.conf config file.

  • hi.
    My bad. I was not even paying attention to the fact you posted in the Gnome section of the forum.
    Ok, so at least one question has the answer known to it.
    You mention lagging of the desktop animations from closing/opening windows, the dash, etc.

    1. Able to do top and keep it running on a separate window and checking to see about CPU?
      Can also do htop
      But do either/ or both PRE and POST suspend. Anything unusual?
      Press q to stop process, but do not stop process until after any lagging occurs again.
      When/if any unusual CPU occurrences happen, post output.

    2. Also, post free?
      Do both PRE and POST suspend. Anything unusual?

    3. Other question is what are you doing during the lagging activity? I know, you mention you are recovering from suspend. But I mean AFTER suspend.
      Moving large files from one drive to another? Anything specific or just general browsing/home work on computer/writing/ etc…etc…

    4. Does the same activity occur with your browser? For example, you might run Firefox, therefore uncheck the Acceleration in the Advanced Tab or go to about:config and search gfx.direct2d.disabled and layers.acceleration.disabled and set both to TRUE. Otherwise just leave be if no issue with this.

    5. Other question: What kernel are you using? The latest one, LTS, Linux-ck ?

    6. Is sound issue affected by this animation lagging?

    7. post output of journalctl -f if/when this lagging occurs. " -f " is for " follow". So the journal is going to follow your activity.

    8. You mention on open/close of windows. What about on moving windows?

    9. What does dmesg say after the resume?

    10. What are your powersaving settings set at?

    11. Post the graphics output of your Intel driver, too.

    12. Only do this if you have a laptop. You mention desktop so I am assuming no Laptop.
      But just in case it is laptop you have, you can try performing this procedure: Do a full power cycle by booting your laptop with no battery.
      Then shut it down.
      Then replace the battery.
      Then boot it up again.
      Again, and only if you have laptop.
      It’s extreme, I know, but try it.
      It will take some days to determine if doing this method has proved positive results. Otherwise just ignore.

  • Thanks for the detailed reply and sorry for the slow response. I have been trying to collect info from before and after the suspend sessions, but since it does not happen on every suspend, it is a bit cumbersome, I need to setup a few commands to automatically run and collect the info on every suspend and then I can compare before and after the stuttering starts. Anyways, the replies to most of your bullets (all commands run after a suspend that caused the stuttering to reoccur):

    1. There is no unusual activity, all 2 (2 real, 2 virtual) CPUs are on 0-2 %.
    2. I currently have a few browser windows opening taking up about half my RAM (but the stuttering remains if I close all window)
                   total        used        free      shared  buff/cache   available
    Mem:        8090768     3854668     1265800      526544     2970300     3615336
    Swap:       8298492        6356     8292136
    1. The lagging starts after the computer wakes up from suspend (but not every time). The lagging occurs for the dash, the dock, the window animation and the desktop switching, even if there are no other windows or programs running, so I am not doing anything special. Again, the lag is small and does nor prevent me from working, but it is definitely present, and easily noted when all animations are smooth again after rebooting the computer.
    2. The lagging does occur with the browser windows open and closed, so I don’t think it is realated to the browser.
    3. My kernel is 4.4.5-1-ARCH #1 SMP PREEMPT. I have not changed the kernel installed by Antergos, only updated it.
    4. No, sounds are not affected. The lagging only seems to affect the desktop-related animations I mentioned above and to some extend window opening and closing.
    5. journal -f does not give any specific error message, when I for example mouse over the dock so that it lags when it opens or open up the dash. Here are some of the general error messages I get:
    Mar 26 00:32:40 tpyoga pkexec[30007]: joel: Executing command [USER=root] [TTY=unknown] [CWD=/home/joel] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 1]
    Mar 26 00:32:41 tpyoga pkexec[30013]: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
    Mar 26 00:32:41 tpyoga pkexec[30013]: joel: Executing command [USER=root] [TTY=unknown] [CWD=/home/joel] [COMMAND=/usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 43]
    Mar 26 00:35:17 tpyoga gnome-session[877]: Window manager warning: Received a NET_CURRENT_DESKTOP message from a broken (outdated) client who sent a 0 timestamp
    Mar 26 00:35:17 tpyoga gnome-session[877]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1c000da ([Antergos )
    Mar 26 00:37:12 tpyoga gnome-session[877]: (gnome-shell:960): GLib-GObject-WARNING **: gsignal.c:2634: instance '0x6c77050' has no handler with id '1'
    Mar 26 00:37:58 tpyoga systemd-timesyncd[375]: Synchronized to time server (0.arch.pool.ntp.org).
    Mar 26 00:37:58 tpyoga systemd[856]: Time has been changed
    Mar 26 00:37:58 tpyoga systemd[624]: Time has been changed
    Mar 26 00:37:58 tpyoga systemd[1]: Time has been changed
    Mar 26 00:40:18 tpyoga wpa_supplicant[547]: wlp4s0: WPA: Group rekeying completed with e8:40:f2:9c:e5:39 [GTK=TKIP]
    Mar 26 00:41:15 tpyoga gnome-session[877]: Window manager warning: Received a NET_CURRENT_DESKTOP message from a broken (outdated) client who sent a 0 timestamp
    Mar 26 00:41:15 tpyoga gnome-session[877]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x2600007 (Home)
    Mar 26 00:41:23 tpyoga gnome-session[877]: (gnome-shell:960): GLib-GObject-WARNING **: gsignal.c:2634: instance '0x433f2e0' has no handler with id '512062'
    Mar 26 00:41:30 tpyoga gnome-session[877]: Error: found running process for 'nautilus', but found no window to jump to
    Mar 26 00:41:42 tpyoga gnome-session[877]: Launching: nautilus
    Mar 26 00:41:42 tpyoga dbus[394]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service'
    Mar 26 00:41:42 tpyoga systemd[1]: Starting Hostname Service...
    Mar 26 00:41:42 tpyoga dbus[394]: [system] Successfully activated service 'org.freedesktop.hostname1'
    Mar 26 00:41:42 tpyoga systemd[1]: Started Hostname Service.
    Mar 26 00:41:42 tpyoga gnome-session[877]: Gjs-Message: JS LOG: [pixel-saver]: Can't find original state for Home with id 0x2600007
    1. No problems moving windows.
    2. I haven’t been able to run dmesg exactly at the resume that causes the lag yet.
    3. Dims screen when inactive and blank screen after 5 min. Automatically suspend when closing laptop lid.
    4. How do I post the output from my Intel card?
    5. I am on a laptop and this does indeed sound a bit extreme. I can try it if it doesn’t get better with anything else. But I would like to explore more other solutions first.

    Let me know if this is in any way helpful. Thanks again for taking the time to help me!

  • yes.very helpful.
    I will respond back in a day or so as am a bit busy with business at the moment; however, for #11
    lspci -vnn | grep VGA -A 12

  • I’m having the same issue on up-to-date Arch Linux. Currently, I just restart Gnome Shell once the issue occures: Alt+F2 -> r -> Enter.

    I use i915 driver; I have xf86-video (slightly newer version than the topic starter has) and libva (I have just upgraded to 1.7.0, but I am running the same 1.6.2 version now) installed. I have plenty of RAM available, and CPU is also idle, and since simple restart of Gnome Shell solves the issue, I guess, it should be something wrong specifically with Gnome Shell (for example, animations in a browser are performing just fine).

  • @frol Great, thank you! Restarting Gnome Shell works perfectly, all the stuttering animations are smooth again afterwards! And I posted a bug regarding this with Gnome.

    @Modisc Although the workaround is quite simple and solves the problems, I include the out put from lspci -vnn | grep VGA -A 12, in case that helps towards a permanent fix:

    00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) (prog-if 00 [VGA controller])
            Subsystem: Lenovo Device [17aa:503e]
            Flags: bus master, fast devsel, latency 0, IRQ 45
            Memory at f0000000 (64-bit, non-prefetchable) [size=16M]
            Memory at e0000000 (64-bit, prefetchable) [size=256M]
            I/O ports at 3000 [size=64]
            Expansion ROM at <unassigned> [disabled]
            Capabilities: <access denied>
            Kernel driver in use: i915
            Kernel modules: i915
    00:03.0 Audio device [0403]: Intel Corporation Broadwell-U Audio Controller [8086:160c] (rev 09)
            Subsystem: Lenovo Device [17aa:503e]
  • @cheflo Friend, i have the same proble after the last updates, but, now the problem is worse.

    For a time i haven problem with suspend the session closing the tape of my laptop, in the first, my problem was that the fonts corrupted after init the session again, then i hadn’t this problem.

    With the last updates i have a worse problem: Whe i init the session again gnome doesn’t work, doesn’t load, or, better, the screen ever seen black, i can listen all that happen, so, the session is open, but nothing is renderized in the screen. I have to to ctrl+alt+f2and then ctrl+alt+f7 to use alt+f2and the same command to put r and again to do enter for restart gnome session and have the screen back.

    Can anyone say me what happen here?


Posts 9Views 3646
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.