• Transmission refuses to save torrents to ntfs disk


    I’m using transmission-qt. When I add torrents and set the download folder to somewhere that has free empty space (that’s a ntfs partition), transmission will always fail with “permission denied” error (and no files/folders created).

    Owner/group are root:root (because you can’t have anything else on ntfs), permissions are 777 (free for all).

    How do I tell transmission to knock it off a bit, as running transmission as root is not a really bright idea?

  • Try:
    sudo chown -R -v Tamius Han after you cd to that NTFS hard drive.
    also, do you have ntfs-3g installed?

    Also, you have to look at your fstab file after you do fdisk -l
    It will say something like dev/sdb* for your NTFS HDD.
    Then, you could even edit that file with
    /dev/sdb* /media/YOUR/NTFS/HARD/DRIVE/DIRECTORY ntfs-3g defaults 0 0

    You might also want to create some mount points:
    sudo mkdir /media/YOUR/NTFS/HARD/DRIVE/
    and then
    sudo mount -a

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • chown fails
    ntfs-3g is installed.

    The partition is in fstab with appropriate options (ntfs-3g defaults,rw,realtime 0 0)

  • ok. could you give me a day or so to find a method to get this resolved for you. It’s been a very long, tiring, and very hard working day today.
    I’m kind of “pooped-out” (exhausted) right now.
    I promise to help you out as far as I am knowledgeably able to.

    EDIT. Just wanted to include that I had the exact same problem as you did; however, I resolved it by the most simplest method. I just had Gparted wipe and re-install a new a FS for me.
    It was for a USB.

    However, I don’t think you would be wanting to do that, so I’m going to research a different method for you.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Well, so the permissions that you set as posted in your 1st post are correct.
    That most obviously is not working.

    Some QUESTIONS and possible SOLUTIONS:

    Question:
    Were your files or your hard drive set up on a different OS? If it was, that might be one of the reasons that you experience this because they have different ownership.
    However, you have ntfs-3g installed so for some unexplained reason that is not working out for you the way as intended. That being said, it is interesting to note that NTFS support in the kernel is not all that reliable.
    Just say’in…

    If you are not using Windows or Mac OS, but only Linux, then you do not need NTFS.
    Can have this hard drive non-NTFS, such as EXT 2,3,4 or even FAT and FAT32 (for files less than 4 Gigs).
    This is because the latter 2 are RW out-of-the-box for any FS types.
    For files greater than 4 Gigs, then it is best to have that FS in exFAT.
    For this one, you might need exfat-utils
    The thing with NTFS is that particular FS does not have file size limitations.

    Possible SOLUTIONS:

    1. If you experience no success and/or do not want to format the NTFS for what-ever reasons, then try this in your fstab file. I do not know if it will work, but let’s try it:
      LABEL=YOUR-NTFS-DRIVE none ntfs rw,auto,nobrowse
      You may or may not need to log out/ or reboot.

    2. Or try this ( I know that it is similar to a solution you tried earlier, but it is slightly different – In all honesty, it might not work but let’s try it anyways.) :
      After you cd to that drive, do sudo chown -R -v Tamias Han:Tamius Han *

    3. If continuing to be a no-go, then post the output for each of the following commands:
      fsck -l and mount.
      We will work from what you have from there if still a no-go.

    4. Try the following next solution.
      Unmount the NTFS hard drive with umount /dev/sdXX.
      Then remount it with:
      mount /dev/sdXX /run/media/Tamius Han/ -t ntfs-3g -o nls=utf8,umask=0222

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    Were your files or your hard drive set up on a different OS? If it was, that might be one of the reasons that you experience this because they have different ownership.

    Hard drive was partitioned with Gparted, some files and folders were created under Windows, others were created under Linux. The target folder was created on Linux.

    If you are not using Windows or Mac OS, but only Linux, then you do not need NTFS.

    I am using Windows, though and the partition in question should allow for big files, so ext* and fat aren’t feasible.

    1. What the hell is the nobrowse option supposed to do? (No seriously, it’s not in the man files and the only explanation Google finds it is “its an OSX thing” and “just add that to your fstab, you don’t really need why or when to use it”.

    It doesn’t work.

    1. Didn’t work either.

    2. I assume you meant fdisk, not fsck?

    3. I don’t see how removing write permissions with umask would work. I’ve tried it anyway. It didn’t work. umask=0000 did work, though (though I wonder why because ls reports exact the same permissions it did before I included that line).

    Thanks for the help.

Posts 6Views 1103
Log in to reply