• Migrated from AMD to Nvidia GPU Xorg Problems


    Hello all. I am a relatively new arch user – not particularly amazing (but trying). My install is based off of Antergos – using xfce but with gdm display manager.

    I recently migrated from AMD to Nvidia. Today was my first attempt to load up linux since the switch. Unfortunately, I think my xorg is now all borked. I can enter the grub loader fine, I run my de-encryption password through, then (when I usually get the option to deencrypt my /home folder) I receive a black screen – display still having the indicator light that it is receiving a signal.

    I have tried booting with `nomodeset’, and this works. I proceeded to replace opengl, lib332 opengl, and x64 drivers with nvidia variants. I ran <sudo nvidia-xconfig> to produce a new xorg but without any benefit. <sudo nvidia-settings> runs fine. <lscpi> recognizes the nvidia card – so it’s not a hardware issue (i don’t think).

    Please, Antergos community, you are my only hope. Thanks in advance.

    I’ve tried uploading journal logs, but the forum says they are too big (1.2mb) to upload. Any suggestion on a file share site acceptable would be welcome.0_1457988704985_xfcelogs.tar

  • 0_1457988860972_journallog.tar I think this is the correct journal log.

Posts 3Views 424
Log in to reply