• Failed to start Load Kernel Modules, Can't start Win XP in virtual vox


    Hi
    I have installed Antergos Openbox installed in my brother’s laptop. He is basically Windows user and did not update Antergos for more than a year. Today I updated his Antergos. I have installed Windows XP in virtualbox as guest OS which was working fine till yesterday After update today while booting I get error message

    [FAILED]Failed to start Load Kernel Modules
    See “systemctl status systemd-modules-load.service” for details.

    But system boots ok.

    But when I open virtual box and try to start Windows XP, I get following error.

    Kernel driver not installed (rc=-1908)

    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

    ‘/etc/init.d/vboxdrv setup’

    as root. If it is avaiable in your distribution. you should install the DKMS package first. This package keeps track of linux kernel changes and recompiles vboxdrv kernel driver if necessary.

    where: suplibOsinit what: 3 VERR_VM_DRIVER not installed(-1908)

    • The support driver is not installed. On linux, open returned ENONET.

    What shall I do to fix this?

    Thanks.

  • Take a look here…
    https://plus.google.com/+SammysHP/posts/Cygbe1mvxRE

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • when reinstalling linux headers make sure you install the package linux-lts-headers if you are running antergos lts… obviously… just occured to me after a few hours of removing-reinstalling.
    Now VBOX works again like a charm

  • @anarch Thank you very much, After installing linux-headers it worked.

  • You are wslcome!👍

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I (like many of us) had the same error, reinstalled linux-headers and the problem is gone, Vbox running so far so good, but in the booting keeps me with the “Failed to start load Kernel Modules”, what can i do?

    Antergos Gnome - Lenovo G4070
    Antergos XFCE - Asus E-11
    Xubuntu 16.04.4 LTS - Dell D630
    Puppy Linux Precise 5.7.1 - Asus 701 EEEpc

  • @ben70 Thanks man. You save my day. I was not able to start Virtualbox after upgrade it (kernel: 4.1.20-1-lts). 👍

  • @edconocerte Cheers man!

Posts 8Views 1901
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.