• error: failed retrieving file multilib.db


    Hi, I tried to update by command, everything worked only I got a error message: error: failed retrieving file ‘multilib.db’ from ftp.halifax.rwth-aachen.de : The requested URL returned error: 404. Could somebody help me how to solve this?

  • @rvroom said:

    …Could somebody help me how to solve this?

    Nothing more simple :smile: . It simply means that your particular mirror is temporarily out of sync. Just wait some minutes until it is synced, without doing anything.

    Anyway, it’s not a problem for pacman. If it doesn’t find a file on a mirror, it uses other mirrors from your /etc/pacman.d/mirrorlist and looks in all of them until it finds a file it is looking for.

    That is why it is useful to have more than only 1 mirror in the mirrorlist. By using reflector it’s possible to have in the mirrorlist any number of mirrors you want.

  • Okay thank you for help. I tried to update again but i get the same error. Do I change the file /etc/pacman.d/mirrorlist?

  • @rvroom said:

    Okay thank you for help. I tried to update again but i get the same error.

    Mirrors syncing depends on a zillion of various factors. It may take from few minutes to some hours.

    Do I change the file /etc/pacman.d/mirrorlist?

    The decision is only up to you. If you’re satisfied with mirrors’ speed, you may avoid doing that.

    With my mirrors, and if I remain within the same country for a long time, it happens to me to rebuild the mirrorlist three or four times a year:

    sudo reflector --age 8 --fastest 128 --latest 64 --number 32 --sort rate --save /etc/pacman.d/mirrorlist
    
  • Thanks for help. I have tried again to update and this time there is no error. The speed is acceptable so I leave the mirrors like they are.

  • @rvroom OK, it’s nice to hear that. Marking the topic as [Solved].

Posts 6Views 1175
Log in to reply