• Bumblebee "This pci device is not a vga device"


    So I’m trying to install Antergos for the past 2 days and I simply can’t get past the booting fase. I always get stuck at a black screen with a blinking cursor.
    I have a NVIDIA GeForce 840m and an Intel I5-4210U. That’s why I tried to install Bumblebee, I’ve followed Just’s posts on how to install it successfully but the end is always the same.
    Here’s my dmesg:
    Sprunge

    I’ve almost sure that my problem is how vgaarb handle with the devices, it only detects VGA and completely ignores my 840M because it marked as 3D. The only solution that I found was to patch my karnel but as a total newbie in Arch and Linux in general, I wont be messing with kernel right now!

    If you guys need more information, just ask. This is driving me mad!
    Thanks for everythings!

  • @GiovaniAbel There’s a new edition of the Bumblebee for NVIDIA Optimus article on Antergos Wiki. The series of posts in the forum is long and may be confusing. The article is very short and hopefully more clear now. Did you see it?

    I have no GeForce GT 840M card, so can’t speak about it for sure. The most recent card I have for tests is GeForce GT 750M. It works nicely with Bumblebee.

  • @GiovaniAbel If you can boot up to bash prompt, of have another Linux installed, can you post back here the full output of two commands:

    lspci -vnn | grep '\''[030[02]]'
    

    and

    inxi -Gxx
    

    The second command requires the package inxi to be installed. For more complete graphic’s card info it is good to have also the mesa-demos package installed.

  • @GiovaniAbel I’m sorry for saying that, but Asus computers are very bad on their own. Combined with hybrid video cards they become a total disaster. In recent 2-3 years all problems with Bumblebee always arise on Asus.

    Your boot parameters are good. The rcutree.rcu_idle_gp_delay=1 may not be necessary. It solves alternate optirun problem. It is not needed it if the computer is not affected by it. If present, it doesn’t hurt though.

    As a last resort, try to boot with one, and only one, of these parameters:

    • vga=789
    • nomodeset

    Simply add one orr another to the boot line.

    Finally, I hope that you DO NOT install Antergos enabling Nvidia drivers. As I warned time ago, currrently that drivers probably work for simple Nvidia (single-GPU) cards only. They DO NOT allow to start a GUI on Nvidia Optimus computers.

  • @just Sorry for not answering this sooner. The first command you sen’t me lspci -vnn | grep '\''[30[02]]' gave no results.
    inxi -Gxx returned this: http://sprunge.us/GiPh <- LINK FIXED

    Have tried booting with nomodeset and vga=79, black screen stays there, no real changes occurred.
    I still think I need to find a fix to the vgaarb, the moment bbswitch start to identify my NVIDIA as a vga device, everything should work fine.

  • @GiovaniAbel said:

    @just Sorry for not answering this sooner. The first command you sen’t me lspci -vnn | grep '\''[30[02]]' gave no results.

    That’s impossible. It’s like typing 2+2= on a calculator and receiving no result…

    Stop. There’s the error in your command. It really returns nothing. But I’ve asked to type in another command. Do not type it in by hand. Copy it into the clipboard and paste if in terminal from my post.

    inxi -Gxx returned this: http://sprungr.us/GiPh

    The link returns the error “Server not found”.


    I still think I need to find a fix to the vgaarb, the moment bbswitch start to identify my NVIDIA as a vga device, everything should work fine.

    Don’t follow you. Sorry.

    Can you answer a simple question - did you install Antergos enabling Nvidia drivers installation? Just yes or no.

  • @just How can I copy paste the command? I’m actually typing from the same notebook I’m trying to install Antergos, but I’m on the Windows I have installed on it. Rebooting consumes a lot of time and most of the commands I need to use I just write down on a paper so I can remember it. If you could access IRC I installed tmux and WeeChat, to makes this process less time consuming while trying to fix these bugs.

    About the vgaarb part, let me try to explain better:
    When I try to execute optirun pwd to check if bumblebee is working it returns:

    [  365.250501] vgaarb: this pci device is not a vga device
    [  396.002277] vgaarb: this pci device is not a vga device
    

    So after doing a lot of research I found out that this is a bug on bbswitch, this vgaarb is looking for a VGA device, and my 840M is somehow seen as 3D device. There’s a patch made to fix this problem, but I know nothing about kernels and can’t with my actual knowledge do something as complicated and time consuming as compiling a custom kernel.
    I’m basing myself on these posts:
    Bumblebee Issues Github
    Bugzilla

    @just said:

    Can you answer a simple question - did you install Antergos enabling Nvidia drivers installation? Just yes or no.

    I can’t remember, but if there was an option to install needed drivers I must have said yes. Maybe reinstalling Antergos could be an option?

  • @GiovaniAbel said:

    …but I know nothing about kernels and can’t with my actual knowledge do something as complicated and time consuming as compiling a custom kernel.

    No-no-no, I’m not asking you to do that :smile: !

    @just said:

    Can you answer a simple question - did you install Antergos enabling Nvidia drivers installation? Just yes or no.

    I can’t remember, but if there was an option to install needed drivers I must have said yes.

    That’s the worst thing you could do for your Nvidia Optimus. Answering yes currently kills it.

    Maybe reinstalling Antergos could be an option?

    It’s the best thing you can do now. Pay attention to answer no about nvidia drivers installation!

    Optimus needs only xf86-video-intel to happily run most of the time. It does not need neither nouveau nor nvidia drivers to be up and running. Nvidia drivers may be installed later. They are only optional.

  • Okay, I’ll try to reinstall everything following your new post on Wiki. Would be glad with we could chat while doing that if I encounter any new problem.
    PS. Fixed the link from the last posts.

  • @GiovaniAbel said:

    …Would be glad with we could chat while doing that if I encounter any new problem…

    I hate chats, forums, email, phones and other means of communication in general :smile: . Trying to not use them. Sorry.

  • @just Reinstalled Antergos, but this time without the graphical driver. Everything went fine, now Im at least able to use Antergos normally. Ill try to install bumblebee now, since I have interest in using PlayOnLinux. Also noticed that my keyboard is strange, some accents arent working. Will change the keymap to see if it works better.

  • @GiovaniAbel said:

    @just Reinstalled Antergos, but this time without the graphical driver. Everything went fine, now Im at least able to use Antergos normally…

    I’d make a full system backup right now, before installing Bumblebee.

  • Installed Bumblebee, screen went black again. Modified /etc/bumblebee/bumblebee.conf, nvidia as driver and virtualgl as bridge.
    Also modified /etc/bumblebee/xorg.conf.nvidia, needed to change the BUSID for the one of my card.
    Rebooted and everything went fine, Im writing this from Antergos finally! Now I just need to check if I can really use my GeForce 840M full power!

Posts 13Views 3003
Log in to reply