• Error creating partitions and filesystems


    hello, I’ve already asked in the IRC channel but since i still don’t have an answer and have to leave i’ll just ask again here with extra info.
    I’ve been trying to install antergos in a VirtualBox VM but if i chose the auto-partition method (with or without choosing to encrypt the HDD, I’d like to encrypt the HDD though) i get the following error message:

    [img:3e42p75u]http://i.imgur.com/SaVEJvN.png[/img:3e42p75u]

    But it does create the partitions with the correct file system. Anyone knows if this error occurs in a real machine or if there is any way to avoid such error ?

    P.S. I do manage to install antergos if i partition the HDD myself using the GUI tool but i dont know how to set up HDD encryption this way.

    P.P.S. Other than this issue antergos does seem a really nice way to set up an arch system in a fast(er) way.

  • hello, I’ve already asked in the IRC channel but since i still don’t have an answer and have to leave i’ll just ask again here with extra info.
    I’ve been trying to install antergos in a VirtualBox VM but if i chose the auto-partition method (with or without choosing to encrypt the HDD, I’d like to encrypt the HDD though) i get the following error message:

    [img:3e42p75u]http://i.imgur.com/SaVEJvN.png[/img:3e42p75u]

    But it does create the partitions with the correct file system. Anyone knows if this error occurs in a real machine or if there is any way to avoid such error ?

    P.S. I do manage to install antergos if i partition the HDD myself using the GUI tool but i dont know how to set up HDD encryption this way.

    P.P.S. Other than this issue antergos does seem a really nice way to set up an arch system in a fast(er) way.

  • Hi,

    Sorry we missed you on IRC. Would you mind making another attempt and then posting the contents of /tmp/cnchi.log? It should provide more information as to whats causing the error. Instead of running the installer from when it automatically starts, go ahead and close it and relaunch from terminal with this command:

    sudo -E cnchi -d -v
    

    This will ensure nothing gets left out of the logs.

    Best Regards,

  • @“lots.0.logs”:1ac1qw35 said:

    Sorry we missed you on IRC. [/quote:1ac1qw35]
    No problem, i understand that’s its not possible to always get an answer immediately.

    I did what you requested and got the following logs:
    if i enabled disk encryption: [url:1ac1qw35]http://pastebin.com/s24d9GTE[/url:1ac1qw35]
    if i didnt enalbe sick encryption: [url:1ac1qw35]http://pastebin.com/ZsV8yg8k[/url:1ac1qw35]
    They appear to be the same to the exception of the LUKS lines, one thing that changed was that this time it did fail to create the partitions.
    [img:1ac1qw35]http://i.imgur.com/mzKHn6N.png[/img:1ac1qw35]

    I’ll now try with the testing .iso to see if the error still occurs.

    Update1: The testing image doesn’t give any error, after the installation finishes i’ll post here if everything went fine
    Update2: Although it (the testing image) gave an error in the end the system seems to have been successfully installed, the respective log: [url:1ac1qw35]http://pastebin.com/2uSLPDVv[/url:1ac1qw35] and respective screenshot of the layout created by the installer [img:1ac1qw35]http://i.imgur.com/s43TGtB.png[/img:1ac1qw35]

  • Thanks for taking the time to test and report the results. It is much appreciated. I caught a typo thanks to that last log so that’s one bug fixed. The errors concerning grub theme are fixed as of today but its not merged into the main testing. I have them on my own testing git repo. As far the LUKS errors, there was a typo that I just corrected and also a few changes were made after the version you tested was generated.

    If you decide to put Cnchi through some more testing, run the setup script listed in this post: [http://forum.antergos.com/viewtopic.php?f=5&t=1285][0]">viewtopic.php?f=5&t=1285 from the live system. It will perform a few temporary fixes that havent made it onto the live image yet and it will update cnchi to the current state of our git testing branch.

    Thanks again for testing!

    Cheers!

    [0]: <a href=

Posts 5Views 1110
Log in to reply