• Change Keyboard layout system wide


    How can I go about changing my default layout for my keyboard at a system wide level so that I am able to sign in to my account using Dvorak layout as apposed to trying to remember where the keys are on the Qwerty layout.

    Cinchi did not keep my keyboard layout choice for the installed system.

    Also a seperate issue… I am unable to sign into these forums via id/password. I get a user does not exist error when I do. To sign in I am FORCED to click the facebook login button. but i would rather not have a facebook connection.

  • Try this

    loadkeys dvorak
    

    And recently the forum was rolled back and it might have deleted your account in the database.

    Cheers! I don't know what I'm talking about!

  • loadkeys dvorak only changes it for the current session and is not persistent.

  • Maybe this would help?

    wget -qO- http://limeblack.github.io/dvorak/xmodmap/default.sh | sh

    Cheers! I don't know what I'm talking about!

  • What desktop are you using (gnome, cinnamon, kde…). To change keyboard layout sytem wide I would go to control center /system settings or whatever depending on your DE.
    For the forum, I may be wrong but I think I used to sign in with my ID before, now you have to enter your full email address.

    Intel NUC D54250WYK, 16 Gb RAM, 1 Tb SSD
    Multi -boot (no MS-Win &no UEFI) Legacy MBR with GPT

  • @ant77 Changing the layout like that only affects the users session. What I’m looking to do is change the layout system wide so I can use Dvorak even at the login screen.

    This is a freshly created account, but the problem seems to have resolved itself now, so I can login as intended now.

  • Found a possible solution on the ArchWiki but will have to wait 27 hours before I can test it as I am encoding a video in Handbrake ATM.

    localectl set-keymap --no-convert dvorak

  • Nope, diddn’t work, open to more help on this problem.

  • A persistent keymap can be set in /etc/vconsole.conf

    but first do this: localectl list-keymaps
    find what keymap you want, then change it.

    To search for a keymap, use the following command, replacing  with the code the SEARCH TERM for your language, country, or layout:
    

    localectl list-keymaps | grep -i SEARCH TERM

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc /etc/vconsole.conf has only 1 line in it with KEYMAP=dvorak is there any more content that is needed in this file to make this work?

    Not working to change my login screen keyboard layout with just that 1 line in the file.

    EDIT: after a powerout here and start up… something has apparently worked to set my Login Screen to Dvorak. Don’t know what it was that did it, but I’ll take it nonetheless

  • @Nymmie
    Good to hear.
    Probably needed a reboot to take effect.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi All,
    Changing the file /etc/vconsole.conf to KEYMAP=us didn’t work for me even after restart. I am in KDE Plasma and changed it through settings and it worked immediately!
    System Settings > Input Devices > Keyboard > layouts > +add > us > apply.
    Cheers.

Posts 12Views 1416
Log in to reply