• Like 0

    Cnchi 0.14: "'InstallationZFS' object has no attribute 'bootloader'"


    I’m trying to install antergos via the live cd and Cnchi. But, whenever I get to the “Create Your User Account” section of the setup it gives me this error.

    “Antergos Installer - Error
    ’InstallationZFS’ object has no attribute ‘bootloader’”

    Is there anyway to install ZFS after I finish the installation? Please help.

  • Like 0

    Oh, sorry I didn’t see this before.

    I’ve created an issue report in github:
    https://github.com/Antergos/Cnchi/issues/555

    Could you run cnchi this way from a terminal?
    sudo -E cnchi -dv

    And when it fails, upload in github (or pastebin) the log (file is /tmp/cnchi.log)

    Thanks!

  • Like 0

    @karasu So, is there any way I can fix this myself or do I have to wait for 0.16?

  • Like 0

    Hi,

    You can clone the github repository and test it. From the iso:

    git clone https://github.com/Antergos/Cnchi cnchi
    cd cnchi
    ./run
    

    Cheers!

  • Like 0

    @karasu I ran into a new issue. How do I run the cloned github cnchi repository in debug mode?

  • Like 0

    Hi,

    The run script does that for you. If you prefer, you can run it yourself this way:
    sudo -E cnchi -dv

    Cheers!

  • Like 0

    @karasu OK, I’m not sure if this is related to the same issue or a completely new one. Whenever I try installing Antergos via Cnchi, it tells me at the end of the installation that GRUB had issues installing and that booting will have issues. When I try booting, it doesn’t work. Here’s my log: https://paste.ee/p/68bPQ

  • Like 0

    @ConsciousExalt

    I’m afraid you have several errors:

    • Not fatal, but you have a lot of download errors
    warning: download failed: http://mirrors.antergos.com/antergos/x86_64/antergos.files: Could not resolve host: mirrors.antergos.com
    warning: download failed: http://mirror.lty.me/archlinux/community/os/x86_64/community.files: Could not resolve host: mirror.lty.me
    warning: download failed: http://mirror.cinosure.com/archlinux/extra/os/x86_64/extra.files: Could not resolve host: mirror.cinosure.com
    warning: download failed: http://softlibre.unizar.es/cinnarch/antergos/x86_64/antergos.files: Could not resolve host: softlibre.unizar.es
    warning: download failed: http://ftp.rnl.tecnico.ulisboa.pt/pub/archlinux/multilib/os/x86_64/multilib.files: Could not resolve host: ftp.rnl.tecnico.ulisboa.pt
    warning: download failed: http://mirror.nl.leaseweb.net/archlinux/extra/os/x86_64/extra.files: Could not resolve host: mirror.nl.leaseweb.net
    ....
    
    • As you tried several times, zfs can’t use your sdb3 as root because it is part of another pool. You should reboot between installation attempts (and even better, wipe out sdb yourself before retrying).

    • Grub can’t find the EFI partition:

    016-03-11 03:13:02 [WARNING] run_cmd.py(82) call(): Error running ['grub-install', '--target=x86_64-efi', '--efi-directory=/install/boot/efi', '--bootloader-id=antergos_grub', '--boot-directory=/install/boot', '--recheck']: Installing for x86_64-efi platform.
    grub-install: error: failed to get canonical path of `/install/boot/efi'.
    

    This must be our fault. I’ll have a look into it asap. Thanks for reporting it! (Sharing the log is very useful to us, thanks again).

    https://github.com/Antergos/Cnchi/issues/564

Posts 10Views 853
Log in to reply