• \[SOLVED\] Install Antergos on PC with Windows.


    Hello,

    I have installed (two times, tried CLI and GUI installer) the Antergos linux. I selected Grub2 in both cases but after restart it says that I do not have any bootloader on HDD. So I could not boot Windows nor Linux. I had to install another linux with GRUB2.

    Could you give me some advice or hint?

    Thank you.

  • Hello,

    I have installed (two times, tried CLI and GUI installer) the Antergos linux. I selected Grub2 in both cases but after restart it says that I do not have any bootloader on HDD. So I could not boot Windows nor Linux. I had to install another linux with GRUB2.

    Could you give me some advice or hint?

    Thank you.

  • You can boot into antergos live media, mount everything necessary:

    [https://wiki.archlinux.org/index.php/Change_Root#Mount_the_partitions][0]">[https://wiki.archlinux.org/index.php/Ch][1] … partitions

    From there you can attempt to install grub2 manually, you can find the instructions here, pick the one that corresponds with your system; BIOS or UEFI, and follow the instructions here:

    [https://wiki.archlinux.org/index.php/Grub2#Installation][0]">[https://wiki.archlinux.org/index.php/Grub2#Installation][2]

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Ch
    [2]: https://wiki.archlinux.org/index.php/Grub2#Installation

    gmail: [email protected]
    irc: [email protected]

  • I have installed Antergos, stuck on no bootloader on any device. So I booted Antegros live. Installed grub via pacman and fixed out of memory error then mounted disk with windows, / where Antergos is installed and /home for Antegros. Then I executed this

    [[email protected] ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file …
    Found linux image: /boot/vmlinuz-linux
    Found memtest86+ image: /boot/memtest86+/memtest.bin
    /usr/bin/grub-probe: warning: unknown device type dm-0
    .
    done

    There is more information [code:24f8wlvh]http://pastebin.com/w0iramEM[/code:24f8wlvh]

    Should I continue through the guide even if I have the warning /usr/bin/grub-probe: warning: unknown device type dm-0 ?

  • What version of windows are you attempting to install antergos along side? If windows 8 it will be uefi, and you can replace the win bootloader with grub2 efi, and manually add windows entry, i see you have sdb 1-7. Is your boot partition for windows fat32?

    gmail: [email protected]
    irc: [email protected]

  • Windows 8, I am not using UEFI.

    /dev/sdb2 is the one with windows.

    Screen from Gparted [code:3pphrdnt]http://www.imagehosting.cz/?v=snmekzdxd.png[/code:3pphrdnt]

  • You can try to read this

    [https://wiki.archlinux.org/index.php/Windows_and_Arch_Dual_Boot][0]">[https://wiki.archlinux.org/index.php/Wi][1] … _Dual_Boot

    Sorry but i have to go as of now, i will be back tomorrow, im sure someone more qualified will help you as soon as they see you are in need of help, sorry i haven’t been much help to you.

    * i skimmed over that article and i think that it covers using windows bootloader to boot into linux.

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Wi

    gmail: [email protected]
    irc: [email protected]

  • @“Howpathetic”:2ef3hp8w said:

    Windows 8, I am not using UEFI.
    [/quote:2ef3hp8w]

    Hi,

    Did you purchase your system with Win8 installed or did you upgrade to Win8 from Win7? I’d just like to verify that you are without a doubt 100% certain that your system is not UEFI.

    @“Howpathetic”:2ef3hp8w said:

    I have installed Antergos, stuck on no bootloader on any device. So I booted Antegros live. Installed grub via pacman and fixed out of memory error then mounted disk with windows, / where Antergos is installed and /home for Antegros. Then I executed this

    [[email protected] ~]$ sudo grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file …
    Found linux image: /boot/vmlinuz-linux
    Found memtest86+ image: /boot/memtest86+/memtest.bin
    /usr/bin/grub-probe: warning: unknown device type dm-0
    .
    done[/quote:2ef3hp8w]
    Did you use arch-chroot to chroot into the installed system before running the grub-mkconfig command? From your explanation it seems you tried to run the grub-mkconfig on the live environment which would be why it failed. Use pacman to install “arch-install-scripts” which will include arch-chroot. Mount the root partition of the installed Antergos system and then run

    sudo arch-chroot /mnt/point/of/root
    

    Now run grub-install:

    grub-install --target=i386-pc --recheck --debug --force /dev/sdaX
    

    and then…

    grub-mkconfig -o /boot/grub/grub.cfg
    

    That should get you up and running. Please let me know the result.

    Best Regards,

  • I have done everything that you wrote.

    Still stuck at no bootloader.

    I have installed the grub on the /dev/sda6 because it is / for the installed antergos and has boot flag.

    Here is a log ->

      
    Here is grub.cfg -\> 
    

    I do not have UEFI, I bought this notebook with OpenSuse preinstalled. So I erased whole HDD and installed windows on it.

    Edit: I have found that Windows loader is located on /dev/sda1 not /dev/sda2, but it should not have an impact on installing bootloader, Windows entry in Grub would be corrupted.

  • Okay it looks like everything completed correctly with grub. It found the Antergos kernel images and also the windows loader on sda1. The way you installed it means it does not have primary control of the boot, that control stays with Windows Bootloader. There should be an extra entry available in the windows bootloader for you to load grub. If it is not automatically detecting it you could try manually adding the entry as described here: [https://wiki.archlinux.org/index.php/Windows_and_Arch_Dual_Boot#Using_Windows_7.2F8_boot_loader][0]">[https://wiki.archlinux.org/index.php/Wi][1] … oot_loader

    Alternatively you could use grub as the primary bootloader by doing the same process you just did but install it to /dev/sda instead of the actual partition.

    EDIT: This may be of some use: [http://www.eightforums.com/tutorials/5817-startup-options-choose-default-os-run-startup-windows-8-a.html][0]">[http://www.eightforums.com/tutorials/58][2] … s-8-a.html

    Best Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Wi
    [2]: http://www.eightforums.com/tutorials/58

  • But after installation I can not boot to Windows. To boot to Windows I have to install another linux with installer which configures GRUB2 by itself. And then I can boot to linux / Windows, but after antergos I just have No boot device found screen instead of Grub2 screen ( I can only boot to Live Linux) .

  • @“Howpathetic”:tkp0bxv0 said:

    I just have No boot device found screen instead of Grub2 screen[/quote:tkp0bxv0]

    This is because you installed grub on the partition (sdaX). If you install it to the disk as a whole (sda) it will place the necessary code on the disks MBR space so that you can boot both Antergos and Windows. I am looking into what is causing this in the first place but to get it working from your current state this is the right action to take.

    If you continue to be unable to boot both windows and antergos, you can get windows to boot by loading the livecd. Use gparted to unset the boot flag on your antergos partition and make sure the windows system partition has its boot flag set. This wont be your C:\ drive but a smaller partition that windows has created. If thats the only one with a boot flag then windows will boot successfully. However, I still advise doing the proper grub install that I mentioned before trying anything else.

    Best Regards,

  • Hi, its finally working!

    I just installed antergos via CLI installer, selected GRUB2, SET BOOT FLAG ON WINDOWS BOOTLOADER partition, rebooted and everything is working now.

    btw. When I installed firefox ( pacman -S firefox ), I could not find it in app drawer ( I can run it only via terminal " firefox", using Gnome ).

    Thank you for your help.

  • Glad to hear you were able to complete your install!

    Best Regards,

Posts 14Views 5041
Log in to reply