• Change Default Desktop Environment??

    I have a few Desktop Environments installed: XFCE, Mate, KDE, etc. When I get to the log-in screen, it used to show the last DE I logged into as the default option, but now it shows XFCE every time, despite my main DE being Mate. Obviously, all you have to do to change it is pick Mate from the drop down, but I’m curious as to why it suddenly shows XFCE as the default option. Is there a way of manually setting up Mate to show us as the default option at the log-in screen?

  • @melchizedek
    Look and see if you have a ~/.dmrc file.
    Per the archwiki: https://wiki.archlinux.org/index.php/LightDM#Default_session
    that is where you would set that.

  • @dastagg Yeah, the odd thing is that Mate is set as default in .dmrc, yet when I get to the log-in screen, the default entry still shows as XFCE. It’s not a terrible chore to change–it’s just a case of choosing Mate from the drop down–but it’s an extra step that (a) wasn’t a problem a week ago, and (b) I often forget to do it, meaning I have to log out and then back in again.

  • @melchizedek
    Sorry that didn’t help.
    I completely understand what you mean.
    So that means there is another config file buried somewhere else that the drop-down box is populated from. I’ll take a look at another computer that has a similar (to yours) setup and see if I can find what/where those settings are stored at.

  • @dastagg Cheers, buddy, I appreciate the effort.

Posts 5Views 2533
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.