• Font rendering and display manager issues


    I’ve just installed Antergos XFCE, and I’m having a few issues here and there. I’ll refer to the GUI issues here specifically.

    First, my computer is an Acer TravelMate 5335 laptop, with Intel GMA 4500M graphics.

    Font rendering is a bit off. Subpixel anti-aliasing is on (and set correctly to RGB), hinting is on (Slight or Full doesn’t make much difference), I’ve also added the relevant lines in /etc/fonts/local.conf for LCD filtering (set to light, because the regular lcdfilter makes text a bit too blurry. Font rendering is OK on the UI itself (especially on GTK+3 applications, by the way I’m using Lato as a system font), but it has weird kerning and smoothing issues on the content though in some specific applications. Here are some examples on Firefox:

    0_1457039108988_Screenshot_2016-03-03_21-44-24.png

    You can see a certain blockiness on the bold text (look at the “Like”, “Comment”, “Share” text for example, or the bold text on the top), with single characters overflowing a bit into each other, while regular fonts are wiry.

    0_1457039246927_Screenshot_2016-03-03_21-56-56.png

    Here you can better see the big contrast between (hard to read) bold and (thin) regular text.

    I’ll stress that I dual boot with Mint, which has none of these rendering issues.


    I’m having big problems with the display manager. Locking the screen through its command doesn’t work, and when the OS automatically locks the screen itself (after inactivity) it is nearly impossible to log back in because the UI is garbled. Logging out makes it completely impossible and forces me to hard reset the machine. I’ve seen another forum thread on the issue, I don’t know what DM I’m using (how do I find out?), there is no clear course of action on the wiki (at least, I didn’t find it).

  • Here are some more examples from a popular website:

    0_1457042005751_Screenshot_2016-03-03_22-51-30.png

    You can see how especially the p and the a overlap.

    0_1457042030643_Screenshot_2016-03-03_22-52-12.png

    Here the text is blocky and the letter “e” is clearly rendered differently.

  • Did you rebuild font information cache files:

    fc-cache -fv
    

    Then logout and back in.

    It improves overall fonts appearance enormously. On any newly installed system, or after adding new fonts.

    What browser do you use? If it is Chromium, did you apply the Chhromium fonts patch from Antergos Wiki?

  • said:

    I’m having big problems with the display manager. Locking the screen through its command doesn’t work, and when the OS automatically locks the screen itself (after inactivity) it is nearly impossible to log back in because the UI is garbled. Logging out makes it completely impossible and forces me to hard reset the machine. I’ve seen another forum thread on the issue, I don’t know what DM I’m using (how do I find out?), there is no clear course of action on the wiki (at least, I didn’t find it).

    If you didn’t change anything, you’re using lightdm. You could try another login manager. There’re a lot of options to choose from. Gdm is very popular (the one made by Gnome guys). You also have lxdm. If you have no idea how to make the change, just ask.

    Cheers!

  • OK, guys, so:

    • I switched to the GTK greeter, things now work and it’s also more consistent with the desktop (as both use the same theme). I’d say that the webkit2 greeter has severe issues as of now.
    • I use Firefox. I’ve actually installed Chromium too to see whether there was a difference and yes, Chromium renders fonts much better. But Chromium is unusable for me (memory usage is very high, and I’m very memory constrained - 2GB) and I prefer Firefox anyway.
    • I rebuilt the font cache but there is no real improvement. I’ll add though that not all fonts are displayed badly here on Firefox, some fonts are very well displayed, for example the fonts you use here on the Antergos forums (and website). But, I repeat, on Mint (which uses the Ubuntu patches to Freetype, I think) there was no issue with font rendering even on Firefox, so I know it can be done. I’ve read about the Infinality patches but apparently they wreak havoc on math text in PDFs (or not?), and I strongly depend on them (I’m an EE student). I would try them but at the moment the AUR is not accessible due to the yaourt issues. I could do things manually but I’d prefer to use the package manager for the time being.
  • Anyone, then? I’ve tried all sorts.

    I’ve tried adding symlinks to presets for disabling bitmaps and bitmap font scaling in /etc/fonts/conf.d/, I’ve tried experimenting with lcdfilter settings, etc. but it’s no big difference really. The Arch forums aren’t very helpful either. I have no idea how to proceed, and to my knowledge yaourt is still broken (so I can’t access the AUR, unless I do it manually).

  • Huh. Shit community, this is. :stuck_out_tongue:

    (A partial fix is turning on autohinting. I say it’s partial because text rendering is heavily mangled anyway).

  • Today has been an update to yaourt. It should work. Please update it.

    About your font issues, maybe installing google-fonts package improves your results.
    Also, check your conf.d symlinks. I have these:

    10-autohint.conf -> /etc/fonts/conf.avail/10-autohint.conf
    10-scale-bitmap-fonts.conf -> /etc/fonts/conf.avail/10-scale-bitmap-fonts.conf
    10-sub-pixel-rgb.conf -> /etc/fonts/conf.avail/10-sub-pixel-rgb.conf
    20-unhint-small-vera.conf -> /etc/fonts/conf.avail/20-unhint-small-vera.conf
    30-metric-aliases.conf -> /etc/fonts/conf.avail/30-metric-aliases.conf
    30-ttf-liberation-mono.conf -> /etc/fonts/conf.avail/30-ttf-liberation-mono.conf
    30-ttf-liberation-sans.conf -> /etc/fonts/conf.avail/30-ttf-liberation-sans.conf
    30-ttf-liberation-serif.conf -> /etc/fonts/conf.avail/30-ttf-liberation-serif.conf
    30-urw-aliases.conf -> /etc/fonts/conf.avail/30-urw-aliases.conf
    30-win32-aliases.conf -> ../conf.avail/30-win32-aliases.conf
    40-nonlatin.conf -> /etc/fonts/conf.avail/40-nonlatin.conf
    45-latin.conf -> /etc/fonts/conf.avail/45-latin.conf
    49-sansserif.conf -> /etc/fonts/conf.avail/49-sansserif.conf
    50-user.conf -> /etc/fonts/conf.avail/50-user.conf
    51-local.conf -> /etc/fonts/conf.avail/51-local.conf
    57-dejavu-sans.conf -> ../conf.avail/57-dejavu-sans.conf
    57-dejavu-sans-mono.conf -> ../conf.avail/57-dejavu-sans-mono.conf
    57-dejavu-serif.conf -> ../conf.avail/57-dejavu-serif.conf
    60-latin.conf -> /etc/fonts/conf.avail/60-latin.conf
    60-ttf-droid-sans-mono-fontconfig.conf -> /etc/fonts/conf.avail/60-ttf-droid-sans-mono-fontconfig.conf
    65-fonts-persian.conf -> /etc/fonts/conf.avail/65-fonts-persian.conf
    65-nonlatin.conf -> /etc/fonts/conf.avail/65-nonlatin.conf
    65-ttf-droid-kufi-fontconfig.conf -> /etc/fonts/conf.avail/65-ttf-droid-kufi-fontconfig.conf
    65-ttf-droid-sans-fontconfig.conf -> /etc/fonts/conf.avail/65-ttf-droid-sans-fontconfig.conf
    65-ttf-droid-serif-fontconfig.conf -> /etc/fonts/conf.avail/65-ttf-droid-serif-fontconfig.conf
    69-freefont.conf -> /etc/fonts/conf.avail/69-freefont.conf
    69-unifont.conf -> /etc/fonts/conf.avail/69-unifont.conf
    70-no-bitmaps.conf -> /etc/fonts/conf.avail/70-no-bitmaps.conf
    80-delicious.conf -> /etc/fonts/conf.avail/80-delicious.conf
    81-ubuntu.conf
    90-synthetic.conf -> /etc/fonts/conf.avail/90-synthetic.conf
    99pdftoopvp.conf
    
  • I already have the Google fonts (I selected them in the installer).
    I see you have basically autohinting + subpixel rendering, but according to various sources (eg. https://wiki.gentoo.org/wiki/Fontconfig#Anti-aliasing.2C_hinting.2C_and_sub-pixel_rendering) you should not use them together. In fact font shapes are distorted when used together.
    Do you have the Infinality patchset installed? What is the content of your 81-ubuntu,conf file?

  • I do not recall touching anything, maybe some package has done this.
    I do not have Infinality installed, of this I’m sure (I tried a long time ago, and it messed up my system).

    My 81-ubuntu.conf file:

    <?xml version="1.0"?>
    <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    <fontconfig>
    
    <!-- Fixes for Ubuntu family:
         - Medium variant is used instead of Regular on Qt apps:
           https://bugs.launchpad.net/ubuntu-font-family/+bug/744812
         - Medium and Bold looks the same in certain applications:
           https://bugs.launchpad.net/ubuntu/+source/gnome-specimen/+bug/813373
    -->
    
    <match target="scan">
            <test name="fullname" compare="eq">
                    <string>Ubuntu Light</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Ubuntu</string>
            </edit>
            <edit name="style" mode="assign">
                    <string>Light</string>
            </edit>
    </match>
    
    <match target="scan">
            <test name="fullname" compare="eq">
                    <string>Ubuntu Light Italic</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Ubuntu</string>
            </edit>
            <edit name="style" mode="assign">
                    <string>Light Italic</string>
            </edit>
    </match>
    
    <match target="scan">
            <test name="fullname" compare="eq">
                    <string>Ubuntu Medium</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Ubuntu</string>
            </edit>
            <edit name="style" mode="assign">
                    <string>Medium</string>
            </edit>
            <edit name="weight" mode="assign">
                    <const>demibold</const>
            </edit>
    </match>
    
    <match target="scan">
            <test name="fullname" compare="eq">
                    <string>Ubuntu Medium Italic</string>
            </test>
            <edit name="family" mode="assign">
                    <string>Ubuntu</string>
            </edit>
            <edit name="style" mode="assign">
                    <string>Medium Italic</string>
            </edit>
            <edit name="weight" mode="assign">
                    <const>demibold</const>
            </edit>
    </match>
    
    </fontconfig>
    
Posts 10Views 2112
Log in to reply