• Problemas con Yaour [solved]


    Después de hacer la instalación el día de hoy, entre los paquetes a actualizar estaba yaourt, aparece este error en la terminal:

    teto ~ $ yaourt -Syua
    [sudo] password for teto: 
    :: Sincronizando las bases de datos de los paquetes…
     core está actualizado
     extra                                        1769.8 KiB   496K/s 00:04 [----------------------------------------] 100%
     community                                       3.4 MiB   610K/s 00:06 [----------------------------------------] 100%
     multilib está actualizado
     antergos está actualizado
    /usr/lib/yaourt/util.sh: línea 190:  1026 Instrucción ilegal     (`core' generado) package-query "${PKGQUERY_C_ARG[@]}" "$@"
    error: missing 'kdebase-workspace' dependency for 'kdeartwork-kscreensaver'
    error: missing 'kdebase-workspace' dependency for 'kdeartwork-styles'
    error: missing 'kdebase-workspace' dependency for 'kdebase-plasma'
    error: missing 'kdebase-workspace' dependency for 'kdeplasma-addons-applets-lancelot'
    error: missing 'kdebase-workspace' dependency for 'kdeplasma-addons-libs'
    error: missing 'kdebase-workspace' dependency for 'kdeplasma-addons-runners-audioplayercontrol'
    error: missing 'kdebase-workspace' dependency for 'kdeplasma-applets-plasma-nm'
    error: missing 'kdebase-workspace' dependency for 'qtcurve-kde4'
    error: file owned by 'kdeplasma-addons' and 'kdeplasma-addons-libs': 'usr/lib/libplasmacomicprovidercore.so.1'
    error: file owned by 'kdeplasma-addons' and 'kdeplasma-addons-libs': 'usr/lib/libplasmacomicprovidercore.so.1.0.0'
    error: file owned by 'libudev.so.0' and 'libudev0': 'usr/lib/libudev.so.0'
    error: file owned by 'ffmpegthumbs' and 'ffmpegthumbs-git': 'usr/lib/qt/plugins/ffmpegthumbs.so'
    error: file owned by 'ffmpegthumbs' and 'ffmpegthumbs-git': 'usr/share/kservices5/ffmpegthumbs.desktop'
    

    Como siempre muchas gracias por su ayuda. Saludos

  • Hola,
    yo lo he solucionado editando /etc/pacman.conf y añadiendo el repositorio de yaourt antes que el de Antergos quedando el archivo de la siguiente manera.

    [archlinuxfr]
    SigLevel = Never
    Server = http://repo.archlinux.fr/$arch
    [antergos]
    SigLevel = PackageRequired
    Include = /etc/pacman.d/antergos-mirrorlist

    luego he desinstalado yaourt y package-query sudo pacman -Rdd yaourt package-query, seguidamente actualizas los repositorios sudo pacman -Syy, limpias el cache de pacman sudo pacman -Scc y vuelves a instalar yaourt y package-query solo que esta vez te lo instalará desde archlinuxfr sudo pacman -S yaourt package-query.

    A mi me ha funcionado perfectamente, ya dirás como te ha ido.

    Saludos.

  • Muchas gracias @kmi , funcionó a la perfección. Saludos

  • @kaxlanwa said:

    Muchas gracias @kmi , funcionó a la perfección. Saludos

    Marked as [Solved].

  • @kmi gracias, mefunciono

yaourt20 Posts 5Views 1291
Log in to reply