• ZFS mirror install in VM: cannot open 'zroot' no such pool.


    I’m planning on installing Antergos on a machine and I wanted to test out the ZFS option first in virtualbox.

    I made two drives and used the installer to set them up as a ZFS mirror. However, when it reboots it always reports it cannot open the pool as there is no such pool.

    I tried various combinations of the ZFS setup - 4K/GPT/MBR/naming anything that I could change I tried. I also tried on a different virtualbox installation on a different host OS.

    What can I do to identify and fix this issue?

  • Try to boot your VM from the install iso and instead of reinstalling, open up a terminal and try:

    sudo zpool status

    Does it list your drives? Is there any error?

    I tried to install like you did on a real system but the installer would not set up 2 drives as a mirror. It didn’t say what the problem was, just said the zpool create command had failed. So I installed to a single drive and planned to use zpool attach after installing the system. Install completed, I rebooted and zpool,zfs commands do not work, giving the error “illegal instruction.”

  • Hi,

    Let me check in a VM and get back to you.

    …and zpool,zfs commands do not work, giving the error “illegal instruction.”

    I have no idea of what that means… have you checked that zfs and spl modules are loaded?

  • Okay, so I’ve had time to do some further investigation.

    The error is misleading. The mirrored zpool was created and can be booted from.

    It seems the problem is the swap file, and things related to it - hibernation and possibly what component it trying to mount/start it.

    These are all the errors from boot:

    ERROR: resume: no device specified for hibernation
    ash: 1: unknown operand
    cannot open 'zpool': no such pool
    no pools available to import
    

    It continues to:

    [---*---] A start job is running for dev-disk...008ba35d.device
    

    This times out after 1.5 minutes, then continues to boot.

    What threw me for a while was that there’s some weird graphics glitch but hitting enter so I can type my password into the display manager makes everything appear.

    Googling around to try and see what the problem/fix is, but it’s definitely to do with swap!

  • ERROR: resume: no device specified for hibernation
    That means that in grub, in your kernel line, there’s no resume option specified. Anyway, I haven’t been able to make linux use my zfs swap zvol as resume device for hibernation, to be honest.

    But using it as a swap device should work, so something must be wrong (maybe it’s Cnchi’s fault, I don’t know).

    What does sudo zfs status give? Is there a swap zvol created?

  • sudo zpool status

      pool: zroot
     state: ONLINE
      scan: none requested
    config:
    
    	NAME        STATE     READ WRITE CKSUM
    	zroot       ONLINE       0     0     0
    	  mirror-0  ONLINE       0     0     0
    	    sda2    ONLINE       0     0     0
    	    sdb     ONLINE       0     0     0
    
    errors: No known data errors
    

    sudo zfs list

    NAME         USED  AVAIL  REFER  MOUNTPOINT
    zroot       5.80G  1.40G  4.77G  /
    zroot/swap  1.03G  2.44G    16K  -
    

    It’s present and there’s no errors.

    Looking in the Arch wiki I changed the swap in fstab to:

    /dev/zvol/zroot/swap none swap discard 0 0
    

    It used to be UUID=... swap swap discard 0 0

    That stopped the waiting for dev-disk systemd item, but it still says all the previous errors.

    Although it boots and works so it’s not a big deal, just slightly annoying to see.

Posts 6Views 1518
Log in to reply