• Like 0

    Problem after updating package-query


    After the last package-query update , there seems to be a problem…
    yaourt -Syyua
    core 122,1 KiB 399K/s 00:00 [######################] 100%
    extra 1773,0 KiB 456K/s 00:04 [######################] 100%
    community 3,4 MiB 456K/s 00:08 [######################] 100%
    multilib 162,6 KiB 455K/s 00:00 [######################] 100%
    antergos 460,6 KiB 456K/s 00:01 [######################] 100%
    /usr/lib/yaourt/util.sh: γραμμή 166: 1195 Ακατάλληλη εντολή (core dumped) package-query "${PKGQUERY_C_ARG[@]}" "$@"

    Suggestions how to deal with it?
    ***Just reporting that my other laptop, which I didn t use for a couple of days, I did all the updates that I found waiting and everything is running perfectly. I used the CL as always. Checked pamac to see if it worked, and that, too, worked ok…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Like 0

    A.
    Write a conf file at this location:
    /etc/systemd/coredump.conf.d/custom.conf

    inside it, write this:

    [Coredump 1195]
    Storage=none
    

    then systemctl daemon-reload

    EDIT: I think that 1195 is the core dump name/number. Not too sure. Try including that and see what happens. If some error, can try to remove the 1195 number so that your conf file looks like this instead:

    [Coredump]
    
    Storage=none
    

    B.
    If you want to disable core-dumps completely, do this:
    /etc/security/limits.conf
    and
    * hard core 0

    The ARCH WIKI: /https://wiki.archlinux.org/

  • Like 0

    @Modisc said:

    A.
    Write a conf file at this location:
    /etc/systemd/coredump.conf.d/custom.conf

    inside it, write this:

    [Coredump 1195]
    Storage=none
    

    then systemctl daemon-reload

    EDIT: I think that 1195 is the core dump name/number. Not too sure. Try including that and see what happens. If some error, can try to remove the 1195 number so that your conf file looks like this instead:

    [Coredump]
    
    Storage=none
    

    B.
    If you want to disable core-dumps completely, do this:
    /etc/security/limits.conf
    and
    * hard core 0

    For me same problem with arch repositories. And i don’t have the file “coredump.conf.d/custom.conf”…
    I found that: http://www.manjaro.fr/forum/viewtopic.php?f=13&t=6151
    a problem with package-query ?

  • Like 1

    mkdir make-package-query-git
    cd make-package-query-git
    wget https://aur.archlinux.org/cgit/aur.git/snapshot/package-query-git.tar.gz
    tar xfz package-query-git.tar.gz
    cd package-query-git
    makepkg -Acs
    sudo pacman -U package-query-git-1.8-1-x86_64.pkg.tar.xz

  • Like 0

    dependency problem:
    :: package-query-git et package-query sont en conflit. Supprimer package-query ? [o/N] o
    erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
    :: yaourt : supprimer package-query casse la dépendance « package-query>=1.6 »

  • Like 0

    @bertrand47 said:

    dependency problem:
    :: package-query-git et package-query sont en conflit. Supprimer package-query ? [o/N] o
    erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
    :: yaourt : supprimer package-query casse la dépendance « package-query>=1.6 »

    sudo pacman -Rdd package-query

  • Like 0
  • Like 1

    @Toga I think it should be
    sudo pacman -U package-query-git-1.8.2.gc4e1da3-1-x86_64.pkg.tar

Posts 8Views 1322
Log in to reply