Hi again,

Let’s start with practical fixes. This post is intended for users with existing Bumblebee installation. 1st time installations will not have this issue.

If Bumblebee was installed recently, by following Antergos Wiki article, then it may miss the nvidia-settings utility. With this name utility is launched from terminal. In menu it is called NVIDIA X Server Settings.

The utility was installed by dependencies in the past. Due to changed dependencies it is not installed automatically anymore. Simply install it by hand:

sudo pacman -S nvidia-settings

Done.

Remember, the only correct way to execute the utility on Nvidia Optimus computerrs is to launch with the command

optirun -b none nvidia-settings -c :8

If you launch it with default command, it may report an error and suggest to run nvidia-xconfig first. Never do that on Nvidia Optimus computers with installed Bumblebee.

Adjust your menu launchers with this command. In Kde right click on Application Menu button, select Edit Applications… from popup menu, find NVIDIA X Server Settings menu entry, change the default command with the one shown above.

In GTK desktops (Mate, Cinnamon, Gnome) the NVIDIA X Server Settings menu entry has the corresponding .desktop launcher. The launcher has the same NVIDIA X Server Settings external name, while its real physical filename is nvidia-settings.desktop. The launcher is found in the folder

/etc/share/applications

As root open the file manager. Always as root, open the text editor. In file manager navigate to indicated folder. You’ll see the launcher with its external name. Drag-and-drop the file to root’s text editor. Modify the Exec= instruction by replacing the default command with the one shown above.

Missing nvidia-settings utility is added now.

Other posts from this series are listed here.

Good luck.