• Like 0

    Update Manager not working


    I run Antergos Linux and I use pamac 3.2rc1-2 and pacman 5.0.1-2 . I am able to install software from command line and also using pamac . However, Update Manager (Software Update) no longer works. It notifies me that there are software to be updated but does not show the list of software to be updated. Screenshot:

    https://dl.dropboxusercontent.com/u/2171814/update-manager.png

    I have already refreshed the mirrors list. The problem remains. Suggestions are welcome.

  • Like 0

    Had the same issue here… its a bug in the latest version… roll back and use AUR pamac https://aur.archlinux.org/packages/pamac-aur/ and will fix it

  • Like 0

    hey,
    i have same problem.
    what does it mean to rollback(newbie here)/
    how do i fix this thingy?
    ;o

  • Like 1

    We have to wait for package-query update.

  • Like 0

    @Iriya
    uninstall your pacmac 3.2rc1-2
    go to the AUR wbsite link in my last post and download the package (Download snapshot) link.
    extract and open the folder in a terminal and type makepkg -sri
    done.

  • Like 0

    worked fine so far, but pamac instantly wants to remove pamac-AUR and install the non-working version. How can I make pamac ignore the update?

  • Like 0

    @paulikid1910 go to pamac settings and add pamac-aur to ignore list

  • Like 0

    omg…

    Thank you for your help, how could I not see this? :stuck_out_tongue_closed_eyes:

  • Like 0

    I have the same problem and cannot use my update manager…it just hangs. Can someone please explain in simple terms on how to fix this?? I don’t understand the above explanation on how to fix this or it does not seem clear to me.

    Thanks T

  • Like 0

    @user39506 wait for the fix and meanwhile to update your apps just type in a terminal: sudo pacman -Syu

  • Like 0
    • open up a terminal

    • type “sudo pacman -R pamac” (without quotation marks)

    • open the link posted by raphaelmal

    • click on “Download snapshot”

    • extract the downloaded archive

    • go to the folder where the files were extracted, right-click and choose “open terminal here” (or similar entry)

    • type “makepkg -sri” (without quotation marks)

    • after installation of pamac-aur completed reboot your machine

    • open up pamac as if you want to install updates

    • go to settings

    • click on “+” under the “ignore”-box

    • choose “pamac-aur” - package from the list

    • done

  • Like 0

    @paulikid1910 thanks! thats what I should have posted if I wasn’t so lazy!!! kkk

  • Like 0

    Just install the program downgrade
    then as root
    dowgrade pamac
    and choose #2
    Done and done.

  • Like 0

    response to paulikid1910

    I downloaded and extracted the “Download snapshot” file, I then right-clicked “open terminal here” and then typed “makepkg -sri” ALL without quotes and got the following below: Thanks for you help and please advise, tx

    [email protected] pamac-3.0.1]$ makepkg -sri
    ==> ERROR: PKGBUILD does not exist.
    [email protected] pamac-3.0.1]$

  • Like 0

    @herbie I tried your suggestion and it did not work. Have you misspelled the commands?

    Thanks for you help and please advise, tx

  • Like 0

    It happened today, and I just ran the command line

    sudo pacman -Syu

    Answered Y to the prompt and all is fixed. I did not see any further problems.
    Suspect something got glitched in gathering up repository data.
    But if it worked form the command line, and now the panel indicator tells me it is up to date.
    I will go no further, until future problems crop up.

  • Like 0

    @user39506

    nice to hear that the issue seems to be fixed in the meanwhile. For you the missing package “pkgbuild“ prevented the described solution. As an alternative, you could have used yaourt instead of building the package yourself:

    “yaourt pamac-aur“

  • Like 0

    @paulikid1910

    I think I may be messing things up further and have decided to wait it out with the suggestion above of using ONLY “sudo pacman -Syu” for updating until there is a fix. The error I get currently when using either Software Update OR Add/Remove Software is listed below. Regards, T

    Failed to execute command “pamac-updater”.

    Failed to execute child process “pamac-updater” (No such file or directory)

  • Like 0

    As i was reading this,… the fix is now released and the Update-Manager is working again.

  • Like 0

    @kb50

    I think the downgrade is the fix until, as it is back doing the Mabeline again. Same problems. I guess you will fix it sooner or later.

  • Like 0

    @herbie said:

    downgrade

    There is no downgrade program.
    none exists, so I cannot downgrade unless you show how to get downgrade.

    I tried to remove pamac which closes itself, then yaourt pamac which worked to bring it back.

    The pamac -Syu works fine from terminal, but the GUI still hangs on an empty busy cursor and does not work as it should or used to.

Posts 30Views 3172
Log in to reply